Require Featured Image

Descrizione

Semplifica la tua vita da Editor

Richiede che i tuoi vari tipi di post — come specificato nella pagina delle opzioni — abbiano un’immagine in evidenza prima che possano essere pubblicati. Se la mancanza di un’immagine in evidenza causa problemi al tuo layout, o non appare al meglio, questo è il plugin per te.

Piuttosto che costringerti ad includere nei tuoi standard editorial l’aggiungere un’immagine in evidenza in ogni post, se i tuoi collaboratori non aggiungono un’immagine in evidenz al post prima di pubblicarle semplicemente saranno impossibilitati a pubblicarlo.

Impostando il Plugin

Funziona in modo predefinito solo sul contenuto di tipo “Post”, ma puoi selezionare altri tipi do contenuto, o disattivarlo per i Post nella nuova pagina delle opzioni nella barra laterale a sinistra: Settings > Req Featured Image. Semplicemente seleziona e deseleziona i tipi appropriati, imposta una dimensione minima se vuoi, clicca salva e hai finito di impostare. Buona pubblicazione!

Altro?

Non dimenticare di vedere i plugin sul nostro sito, e non esitare a farci visita e farci un fork su GitHub. Hai un progetto unico su WordPress per il quale hai bisogno d’aiuto? Entra in contatto con la Press Up per prepararti al successo.

Screenshot (schermate di esempio)

  • L'avvertimento che vedi quando stai modificando un post che non ha un'immagine in evidenza. Inoltre il bottone "Pubblica" è disabilitato

  • La pagina delle impostazioni, che ti consente di specificare su quali tipi di post il plugin dovrebbe operare.

Installazione

Attiva il plugin. Non sono richiesti altri passi per richiedere un’immagine in evidenza solo sui Post.

Se vuoi richiedere le immagini in evidenza su di un diverso tipo di contenuto, o consentire che i Post siano pubblicati senza allora semplicemente vai nella pagina delle opzioni nella barra laterale a sinistra: Settings > Req Featured Image. Semplicemente seleziona e deseleziona i tipi appropriati, imposta una dimensione minima se vuoi, clicca salva e hai finito di impostare. Buona pubblicazione!

FAQ

Su quali tipi di post (contenuto) questo plugin lavora?

Ogni “tipo personalizzato di post” — o varietà di contenuto — ora è supportato. Prima della versione 0.5.0, questo plugin poteva essere usato solo per forzare le persone a includere le immagini in evidenza nei Post, non nelle Pagine o nei tipi personalizzati di post. Ora tutti sono solo a distanza di qualche clic sulla pagina delle opzioni.

Come impedisce alle persone di pubblicare un post senza immagine in evidenza?

Ci sono due metodi: uno è un enorme Javascript sullo schermo di modifica che rende molto chiaro alle persone che devono aggiungere un’immagine in evidenza, l’altro gli rende impossibile premere il bottone Pubblica prima di averla aggiunta.

Se questo fallisse per un qualsiasi motivo, si aggancia anche nel metodo di pubblicazione e impedisce la pubblicazione quando un’immagine in evidenza non è presente. Questo dovrebbe impedire la pubblicazione anche se un autore ha il Javascript disattivato, o se la pubblicazione è tentata tramite metodi più oscuri.

Non vedo uno dei miei tipi di post personalizzato nella pagina delle impostazioni. Perché?

Per semplificare la pagina delle impostazioni, ed evitare confusione, solo i tipi di contenuto che supportano le immagini in evidenza appariranno sulla pagina. Non avrebbe senso provare a forzare un contenuto che non può avere un’immagine in evidenza ad averne un senza la quale non può essere pubblicato. Se vuoi richiedre che un tipo di contenuto abbia un’immagine in evidenza ma non è supportatom contatta lo sviluppatore, giocherella con la chiamata register_post_type() creando tu stesso il tipo di contenuto, o contattaci alla Press Up, ci piace essere d’aiuto!

Perché dovrei usare questo plugin?

Poiché vuoi che sia richiesto che i tuoi post abbiano le immagini in evidenza prima che siano pubblicati. Se ti piacerebbe che i tuoi post avessero le immagini in evidenza, ma non è indispensabile per i tuoi standard editoriali, questo plugin potrebbe non essere adattto a te.

Ci sono altre opzioni?

Sì, solo per i diversi “tipi di post personalizzato” Nella barra laterale a sinistra, nelle impostazioni, dovresti trovare “Req Featured Image”. Lì ci sono le opzioni. Puoi scegliere quali tipi di post vuoi controllare e impostare una dimensione minima per l’immagine in evidenza. Buona pubblicazione!

Supporto per altre lingue?

Sì. Attualmente (inizio 2016) speriamo che questo possa essere fatto tramite traslate.wordpress.org, quindi se vorresti contribuire e hai familiarità con il procedimento, vai avanti e fallo lì.

Mentre la polvere si deposita su questo procedimento, continueremo a supportare altre lingue tramite contributi di traduzione che saranno inclusi nelle successive versioni del plugin, come abbiamo sempre fatto.

Recensioni

8 Novembre 2019
It allows to delete thumb image on existing posts. If I open post that already doesn't have thumb image it doesn't show any error message.
Leggi tutte le recensioni di 15

Contributi e sviluppo

“Require Featured Image” è un software open source. Le persone che hanno contribuito allo sviluppo di questo plugin sono indicate di seguito.

Collaboratori

“Require Featured Image” è stato tradotto in 9 lingue. Grazie ai traduttori per i loro contributi.

Traduci “Require Featured Image” nella tua lingua.

Ti interessa lo sviluppo?

Esplora il Codice segui il Repository SVN iscriviti al Log delle Modifiche. Puoi farlo tramite RSS con un lettore di feed.

Changelog (registro delle modifiche)

1.5.0 (2019.12.17)

  • It was impossible to publish a post (which was never saved as a “Draft”) because of the server-side check. It is no longer.

1.4.1 (2019.05.29)

  • Fix to crude Gutenberg compatibility in JS

1.4.0 (2018.11.09)

  • Crude-and-quick Gutenberg compatibility

1.3.0 (2017.08.16)

  • Fixing an issue where the PHP didn’t stop the post from publishing, if it were invoked
  • Fixing an issue where the size warning banner would flash on in Chrome erroneously

1.2.3 (2016.11.23)

  • Fixing an issue that would make the plugin seem not to work when newly installed.
  • Adding composer.json and Japanese translation.

1.2.2 (2016.02.22)

  • Molti cambiamenti nel codice per una migliore leggibilità e comprensibilità.

1.2.1 (2016.02.08)

  • Valanga di piccoli cambiamenti per rendere il codice più leggibile e standardizzato nella formattazione.
  • Risolto un problema dove una funzione di traduzione era usata al posto sbagliato nel momento sbagliato.

1.2.0 (2016.02.01)

  • Aggiunta la possibilità di stabilire, controllare e imporre una dimensione minima per l’immagine in evidenza. Numerosi ringraziamenti a @cjk508 per averlo reso possibile.

1.1.4 (2015.12.7)

  • Aggiunta traduzione in finlandese. Questo potrebbe/dovrebbe sbloccare i language pack su .org, quindi potrebbe essere l’ultimo!
  • Aggiunto il supporto per WordPress v4.4

1.1.3 (2015.10.19)

  • Migliorato il supporto per WP4.3 risolvendo il problema dell’individuazione degli h1/h2 in jQuery. Grazie Jamie.
  • Aggiunta la traduzione in danese. Grazie Jess!

1.1.2 (2015.10.01)

  • Aggiunto il supporto per WordPress v4.3+

1.1.1 (2015.06.22)

  • Corretto un errore logico che rendeva quasi impossibile pubblicare i post. Le mie scuse a chi ha avuto inconvenienti.

1.1.0 (2015.06.21)

  • Salto di versione poiché finalmente abbiamo risolto il problema del quale le persone si lamentavano nella 1.0, dove potevi pubblicare con un’immagine e poi cancellarla. Il cambiamento nella 1.0 era stato fatto per consentire alle persone con vecchi contenuti senza le immagini in evidenza di modificare i post facilmente, che era un problema prima della 1.0. La soluzione è stata di mettere una condizione sull’attivazione del plugin e attivarlo solo da lì in avanti. Le persone con il plugin già attivato la avranno impostata a due settimane prima da quando hanno aggiornato.

1.0.10 (2015.05.24)

  • Aggiunta traduzione in portoghese.
  • Aggiunta traduzione in olandese.
  • Testato con un varie versioni di WordPress.

1.0.9 (2015.04.21)

  • Traduzione in portoghese brasiliano di matheusmb.

1.0.8 (2015.04.21)

  • Giochi VCS…

1.0.7 (2015.04.21)

  • Aggiunta traduzione in serbo di Andrijana Nikolic della WebHostingGeeks. Grazie Andrijana!

1.0.6 (2015.03.24)

  • Aggiunta traduzione in norvegese di Alf Otto Fagermo.

1.0.5 (2015.03.18)

  • Aggiunta traduzione in tedesco di Wolfgang Tischer.
  • Corretto un errore di battitura in un file .pot che rendeva una stringa non tradotta.

1.0.4 (2015.03.10)

  • Ripulito la pagina delle impostazioni.

1.0.3 (2015.01.27)

  • Corretta una funzione nominata male nel Javascript.

1.0.2 (2015.01.24)

  • Fatto un errore durante i giochi VCS, un salto è stata la soluzione più semplice.

1.0.1 (2015.01.24)

  • Compreso che il controllo JS per consentire la modifica dei post non pubblicati senza un’immagine in evidenza non funzionerebbe nelle installazioni non inglesi. Trovato un metodo basato sul markup per scoprire la stessa cosa.

1.0.0 (2015.01.24)

  • Grandi lavori sul JavaScript quindi le conclusioni sono ovvie.
  • Fatto in modo che quando un post è publicato senza immagine in evidenza, il plugin non impedisce di salvarlo (risolto un errore di battitura).
  • Grande balzo di versione. Questa è troppo usata per non essere tipo 1.*, e sarebbe dovuta uscire prima.

0.6.5 (2015.01.12)

  • Aggiunte traduzioni in greco.
  • Cambiamenti al Leggimi (revisone al supporto per la 4.1)

0.6.4 (2014.09.18)

  • Aggiunta traduzione in arabo.
  • Cambiamenti al Leggimi (revisone al supporto per la 4.0)

0.6.3 (2013.04.30)

  • Cambiamenti al Leggimi (revisone al supporto per la 3.9, alcuni cambiamenti di copia).

0.6.2 (2013.04.05)

  • Aggiunta traduzione in spagnolo di Andrew Kurtis della WebHostingHub. Grazie Andrew!

0.6.1 (2013.03.02)

  • Aggiornato il Leggimi in modo che la versione live cambi, e rimosso un file .mo che non avevo intenzione di pubblicare.

0.6.0 (2013.03.02)

  • Grandi cambiament: aggiunto il supporto per le traduzioni. Credo. Sono un principiante con questo.
  • Cambiato sotto l’apparenza per fargli usare un aggancio appropriato piuttosto che un terribile hack che avevo usato prima.

0.5.0 (2013.12.31)

  • Grandi cambiamenti: ora supporta tutti i tipi di post personalizzati. Si può usare tramite la pagina delle opzioni (metodo raccomandato e preferito) o tramite un filtro chiamato ‘rfi_post_types’.
  • Creato una pagina delle opzioni per rendere più facile l’aggiornamento dei tuoi tipi personalizzati di post e impostarli usando l’interfaccia di amministratore.
  • Alcuni piccoli miglioramenti alla struttura interna del codice per aumentare la leggibilità e la comprensibilità. Questo plugin dovrebbe finalmente essere abbastanza grande per beneficiare del design a oggetti, ma non per la 0.5.0.

0.3.0 (2013.08.07)

  • Migliorato un test condizionale PHP poiché impediva i salvataggi.

0.2.2 (2013.08.02)

  • Corretti alcuni piccoli errori nella documentazione

0.2.1 (2013.08.02)

  • Corretto un errore di battitura nel nome del file JS.
  • Corretto wp_die() in modo che sia attivato solo se post_type è un post.
  • Aggiornato la documentazione dopo averlo visto nella repository.

0.2 (2013.08.01)

  • Prima versione