Supporto » Fixing WordPress » Accesso admin rifiutato – dilemma version php

  • Ciao a tutti,
    non accedo più all’ amministrazione di wordpress.
    Hosting linux su aruba
    ######
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at postmaster@testtest.it to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.
    ######
    Il sito è online e funzionante, non lo modifichiamo mai , al massimo un paio di volte l’ anno.
    Ho mandato un ticket ad Aruba e mi rispondono ciò:
    ######
    Gentile cliente,
    La invitiamo a modificare la versione PHP attualmente utilizzata dal sito e passare alla versione 5.3 e verificare successivamente il corretto accesso.
    #####
    Dal test PHP risulta che la versione in uso è la seguente 5.2.17
    “”sò che sto utilizzando versioni obsolete , ma adesso l’obbiettivo è accedere alla pagina di amministrazione e fare la modifica richiesta , SENZA INTERROMPERE IL SITO WEB E MODIFICARNE CONTENUTI E FORMATTAZIONE”.

    Cambiando la versione di php dalla 5.2 alla 5.3 il sito potrebbe perdere la sua funzionalità? , tipo transizioni , pulsanti etc etc.
    Grazie

Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Se precedentemente avevi un backup del database, riabilitalo.

    Moderatore Guido Scialfa

    (@wido)

    Ciao @cha2016,

    Pur non essendo un forum di supporto agli hosting, per cui sarebbe meglio chiedere direttamente ad aruba la procedura per poter modificare la versione di php, vorrei chiarirti un paio di cose riguardo al tuo problema.

    Molto probabilmente avrete aggiornato un qualche plugin, tema. La versione di php non intacca funzionalità frontend determinate dal css o da javascript.

    I pulsanti, transizioni di cui parli è territorio di css e/o javascript.

    L’ideale per voi sarebbe aggiornare alla versione più recente disponibile dall’hosting, consiglierei la versione 5.6.x che è la stessa che consiglia la documentazione WordPress.

    La versione di php 5.6 perderà supporto questo fine anno e verrà aggiornato per altri due anni esclusivamente per bug fixes, mentre le versioni precedenti sono ormai abbandonate ed obsolete.

    Detto questo, WordPress supporta a partire dalla versione di php 5.2.x come puoi leggere nella Requirements.

    La versione di php non viene modificata dal back-end di WordPress ma dal pannello di controllo del tuo hosting.

    In questo articolo viene spiegato come modificare la versione di php. Si tratta dell’hosting windows, ma credo che sia uguale anche per l’hosting linux.

    Per ulteriori info ti invito a contattare direttamente il supporto dell’hosting e chiedere informazioni precise su come effettuare questa modifica.

    • Questa risposta è stata modificata 5 anni, 5 mesi fa da Guido Scialfa.
Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Il topic ‘Accesso admin rifiutato – dilemma version php’ è chiuso a nuove risposte.