Supporto » Fixing WordPress » Accesso al sito ma non alla dasboard, utente amministratore

  • Risolto crisgiada

    (@crisgiada)


    Posso accedere al mio sito solo come se fossi un sottoscrittore, quindi posso vedere il sito e la barra superiore di wp, ma non posso continuare a lavorarci. Errore apparso dopo un aggiornamento che non è andato a buon fine.
    Alcune informazioni necessarie:
    Il sito è in locale con Ampps.
    Posso accedere senza problemi. Il sito è visibile, senza accesso al back-end.

    Il mio profilo non è cliccabile, quindi non ho nessun accesso agli utenti.

    Altre pagine aggiunte manualmente nell’url vanno in 404.

    Se dopo l’accesso effettuato scrivo url/wp-admin per cercare di entrare nella dashboard, mi da che non ho i permessi per accedere.

    Ho controllato i permessi e creato un nuovo utente dal db senza successo.
    Il permesso di amministratore nel database è corretto (le capacità sono-> a: 1: {s: 13: “administrator”; b: 1;}).

    I file del core sono stati sostituiti dopo che si è verificato l’errore solo per essere sicuri …
    Era un progetto iniziale, purtroppo sono stata veloce a svilupparlo ed era quasi finito, non ho fatto a tempo a creare backup. 😫

    Ho provato a disabilitare tutti i plugin spostandoli in una cartella diversa senza risultati. Se sposto il tema ho una pagina bianca.

    Non ci sono sistemi di caching attivi.
    La modalità di debug è attiva, nessun errore visibile.
    I cookies sono stati cancellati più volte.
    Nella finestra ispezione del browser non ci sono errori.
    Cosa ho dimenticato di fare? Perchè non va?

    • Questo topic è stato modificato 5 mesi, 3 settimane fa da crisgiada.
    • Questo topic è stato modificato 5 mesi, 3 settimane fa da crisgiada.
Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Ciao @crisgiada,

    Grazie per aver aperto un thread su WordPress.org! Sono Matteo, piacere di conoscerti.

    Personalmente ciò che posso capire è che si tratta di un insieme di cose che potrebbero disturbarsi. Personalmente proverei a reinstallare WordPress e vedere ciò che accade. Se ancora non si risolve, prova a reinstallare WordPress a mano senza importare gli utenti, ma prova a gradi. Potrebbe essere qualche problema di dati immagino.

    inoltre, consiglio personale: hai valutato di spostarti su ambienti locali più “amici” di WordPress come Local o DevKinsta? Avresti un ambiente pronto per WordPress e ciò ti aiuterà molto in quel che stai facendo ora.

    Se ancora non si risolve rispondi a questo thread: troveremo una soluzione insieme.

    A presto,
    Matteo

    Chi ha creato la discussione crisgiada

    (@crisgiada)

    Hey Matteo! Grazie! Ho risolto tramite WPCLi, resettando i permessi. Dovevano per forza essere i permessi! Sebbene da database non risultasse nulla erano misteriosamente completamente scoparsi tutti i ruoli e li ho ripristinati! Ed in ambiate local! Yeah!

    Con Ampps mi trovo abbastanza bene, ormai lo conosco come le mie tasche e lo giro e rigiro come un calazino!

    Local, parere personale, non mi piaciuto molto. Devkinsta non l’ho testato.

    Ma ormai ho passato tutto in stage per mostrare il lavoro svolto, perché ho quasi finito, prossima volta.

    Spero che la mia esperienza possa esser almeno di aiuto a qualcun altro!
    A presto!
    Kri

    Capisco ciò che intendi, ma DevKinsta e Local sono software pensati per WordPress, quindi semplificano molto il lavoro.

    A presto! 🙂

    Chi ha creato la discussione crisgiada

    (@crisgiada)

    Grazie Matteo, non usando solo Wp … 😉

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.