Supporto » Installazione e Aggiornamento » aggiornamento a wp 5.3 con tema HelloSexy 1.1.1

  • cmaurizi

    (@cmaurizi)


    Buongiorno, sono nuova del forum. Gestisco il sito della Biblioteca comunale di Fabrica di Roma e ieri finalmente mi sono decisa ad aggiornare wp da 3.2.1 (non ridete…) a 5.3. Il tema e’ HelloSexy 1.1.1 (ridete pure…) Ho effettuato l’aggiornamento dal pannello di controllo di Aruba alla versione PHP 5.6.32 poi ho aggiornato wp. Conclusa l’operazione non riuscivo piu’ ad accedere (500 Internal Server Error), ho aspettato un po’ non si sa mai, poi ho recuperato il backup in locale e ho ricaricato tutto tramite FTP, cancellando man mano in remoto e ricaricando. Alla fine compariva un Parse error relativo al file wp-includes/link-template.php. Ho risolto recuperando una copia del file da un backup piu’ vecchio. Ora il sito e’ di nuovo visibile e funzionante ma non voglio rinunciare all’aggiornamento, purtroppo temo che il problema sia dipeso dal tema piuttosto vecchio che ha un solo aggiornamento 1.3.6 risalente al 2013. Come avrete capito non sono una scaltrona in materia e quindi mi affido a voi, cosa mi consigliate di fare?
    Sono qui e aspetto, grazie grazie
    Caterina Maurizi

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve cmaurizi,

    quando la versione è troppo obsoleta il consiglio è di seguire questa guida

    https://wordpress.org/support/article/upgrading-wordpress-extended-instructions/#upgrading-across-multiple-versions

    in cui si segnala che :

    Se si prevede di eseguire l’aggiornamento in più di due versioni principali, è necessario prendere in considerazione l’aggiornamento incrementale per evitare potenziali conflitti e ridurre al minimo i rischi di danni al database. Le versioni precedenti di WordPress possono essere scaricate dall’archivio delle versioni.

    Ovvero non fare un unico upgrade ma farne molti prendendo vecchie versioni di WP da questo archivio https://wordpress.org/download/release-archive/

    Per quanto riguarda il tema
    https://it.wordpress.org/themes/hellosexy/

    come scritto nella pagina del tema stesso :

    Questo tema non è stato aggiornato da più di 2 anni. Potrebbe non essere più manutenuto o supportato e potrebbe presentare problemi di compatibilità quando utilizzato con versioni più recenti recenti di WordPress.

    Quindi il consiglio è di cambiarlo per motivi di sicurezza e di prestazioni

    Aggiornaci

    Chi ha creato la discussione cmaurizi

    (@cmaurizi)

    Grazie, seguiro’ le tue indicazioni e vi faro’ sapere. Un chiarimento: meglio cambiare il tema come prima cosa prima di procedere agli aggiornamenti?

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Prima di fare ogni modifica al sito fare sempre un BACKUP

    Il consiglio è di attivare un tema di default delle vecchie versioni WP che si chiama Twenty + [numero]

    Per esempio nella versione 3.2 di WP il tema di default era Twenty Eleven

    https://wordpress.org/news/2011/07/gershwin/

    Aggiornaci

    Chi ha creato la discussione cmaurizi

    (@cmaurizi)

    Ok, grazie!

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Il topic ‘aggiornamento a wp 5.3 con tema HelloSexy 1.1.1’ è chiuso a nuove risposte.