Supporto » Fixing WordPress » Aggiornamento alla versione 4.7

  • Risolto fcimpiantisrl

    (@fcimpiantisrl)


    Salve,
    ho da poco aggiornato il mio sito alla versione 4.7 ma sto riscontrando problemi. Mi risulta, infatti, impossibile accedere alla gestione delle pagine, dell articoli, dei plugin e quant’altro del mio sito. Visualizzo solo una pagina bianca. Come posso risolvere? Grazie in anticipo

Stai vedendo 15 repliche - dal 1 al 15 (di 23 totali)
  • Moderatore Guido Scialfa

    (@wido)

    Ciao @fcimpiantisrl,

    Direi che prima di tutto devi verificare se vi sono errori che non vengono mostrati a causa della configurazione di wp.

    Se apri il file wp-config.php e indentifichi la linea che definisce la costante WP_DEBUG e la imposti a true come definito nel codex – debug wp-config, possiamo provare come prima cosa a vedere se esce un qualche errore.

    In caso di risposta negativa preleva il log php e vedi se lì vi è qualcosa in merito.

    Se non sai come recuperare il file chiedi al tuo hosting delucidazioni.

    fcimpiantisrl

    (@fcimpiantisrl)

    Ciao @wido,
    grazie per avermi risposto così tempestivamente.
    Ho provato a fare ciò che mi hai suggerito ma mi mostra sempre una pagina bianca quando provo ad accedere alla gestione del mio sito.

    Nella barra degli indirizzi ho questo: http://www.effecimpiantisrl.it/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F

    Grazie mille ancora!

    Moderatore Guido Scialfa

    (@wido)

    Ciao @fcimpiantisrl,

    Potrebbe essere un problema relativo alla versione di php oppure a qualche regola errata nel file .htaccess.

    Devi controllare la versione di php, che sia almeno la 5.6 (potrebbe andare anche la 5.4 ma ti consiglio se possibile di usare la 5.6).

    Riguardo invece al file .htaccess dai uno sguardo a questa sezione di documento https://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29, quello che leggi tra # BEGIN WordPress e # END WordPress sono le sole regole di base che ti necessitano in una installazione WordPress che non sia network (se non sai cosa è il network probabilmente non è attivo).

    Quindi effettua un bel backup del database e dei files di WordPress, generalmente gli hosting provvedono a farlo, perciò dal cpanel del tuo hosting dovresti essere in grado di crearlo e scaricarlo.

    Dopo di chè sempre dal cpanel vai nella sezione di gestione dei files e controlla che l’htaccess abbia un contenuto simile a quanto elencato sopra, può darsi che non vi sia nulla come regole aggiuntive definite dall’hosting, importante intanto è che sai se il contenuto è simile a quanto riportato sopra e ci fai sapere.

    Per controllare la versione di Php lo fai sempre da cpanel. Modificare di per se la versione di php non comporta problemi, in questo caso potrebbe solo risolverli, vedi quindi se puoi cambiare versione alla 5.4 o meglio 5.6.

    Ultimo controllo da effettuare, il file di log. Sempre dal cpanel dovresti poter identificare una sezione che ti mostra i logs. Vedi tra gli ultimi messaggi (ogni messaggio mostra data ed ora) ed in caso incolla qui l’eventuale errore (se non è lungo) o usa un servizio come pastebin.

    In questo modo avremo più dati per poter capire il problema.

    Quello tuo, se vuoi fare ulteriori ricerche è il tipico problema di White Screen of Death.

    Maggiori info al riguardo.

    paolopolita83

    (@paolopolita83)

    Salve. Anche io ho fatto un aggiornamento (richiesto), dopodichè la pagina è saltata ed ora non riesco più ad entrare, mi da “ERROR 500”, quando provo ad entrare nel pannello di controllo. Che si può fare? Io non sono esperto di queste cose. Il sito si chiama http://www.dirittoinformazione.it . Grazie. Paolo Polita

    fcimpiantisrl

    (@fcimpiantisrl)

    Ciao @wido,
    la versione PHP che posso utilizzare è 5.6, 7.0 o 7.1; quale devo scegliere?
    Ho controllato il file .htaccess e il contenuto risulta in linea con quello fornito da WordPress.
    Purtroppo il mio hosting non mi permette di accedere al file di log.

    Moderatore Guido Scialfa

    (@wido)

    @fcimpiantisrl attiva la 5.6, la 7 andrebbe bene anche ma non so se utilizzi altri plugin che potrebbero dare problemi con quella versione.

    Ok per il log anche se è strano che tu non possa avervi accesso.

    paolopolita83

    (@paolopolita83)

    C’è qualcuno che può risolvere il problema dietro compenso? Grazie.

    fcimpiantisrl

    (@fcimpiantisrl)

    @wido ho attivato la 5.6 ma non funziona ugualmente 😭

    Moderatore Guido Scialfa

    (@wido)

    @fcimpiantisrl Prova a loggarti da http://www.effecimpiantisrl.it/wp-login.php, a quanto pare se vai in “wp-admin” ti ridireziona alla pagina di upgrade ed è lì che succede il prob.

    Puoi dare informazioni aggiuntive circa plugins installati.
    Ho impressione che qualche plugin a questo punto abbia un conflitto con la versione di WordPress.

    @paolopolita83 in questo forum non si effettuano richieste di lavoro o pagamenti.

    Per questo genere di richieste ti consiglio di chiedere sui canali online appositi.

    fcimpiantisrl

    (@fcimpiantisrl)

    @wido riesco tranquillamente a loggarmi attraverso http://www.effecimpiantisrl.it/wp-login.php ma ora mi riporta questo errore:

    Notice: Constant WP_DEBUG already defined in /customers/6/e/c/effecimpiantisrl.it/httpd.www/wp-config.php on line 89 Warning: Cannot modify header information – headers already sent by (output started at /customers/6/e/c/effecimpiantisrl.it/httpd.www/wp-config.php:89) in /customers/6/e/c/effecimpiantisrl.it/httpd.www/wp-includes/pluggable.php on line 1179

    e non riesco neanche ad accedere alla pagina dei plugin

    Moderatore Guido Scialfa

    (@wido)

    Questo perchè hai definito nuovamente la costante invece di cambiarne il valore.

    Quando inzialmente ti dissi di attivare WP_DEBUG, puoi rimuovere la riga duplicata che hai inserito e dovresti risolvere.

    Solo ho un dubbio sul fatto che sia definita da qualche altra parte uhm.
    Disattiva quella riga duplicata e come hai fatto l’aggiornamento? Dal backend di WordPress?

    In caso saresti in grado di effettuare un update via ftp? Magari è qualche file che si è perso durante l’aggiornamento.

    paolopolita83

    (@paolopolita83)

    Ok grazie.

    fcimpiantisrl

    (@fcimpiantisrl)

    Ho effettuato l’aggiornamento dal Backend.
    Come devo procedere per effettuare l’aggiornamento via ftp?

    fcimpiantisrl

    (@fcimpiantisrl)

    @wido sono riuscito a risolvere disattivando tutti i plugin tramite il file manager e ho scoperto che a dare problemi era il plugin W3 Total Cache. Peccato era molto utile per velocizzare il sito.

    Grazie mille per il tuo aiuto

    Moderatore Guido Scialfa

    (@wido)

    Ciao @fcimpiantisrl,

    Alla grande, felicissimo che hai risolto il problema e grazie per la info, vediamo se riusciamo a trovare un modo per informare lo sviluppatore del plugin.

    Ho letto di recente che vi erano state delle discussioni in merito a questo plugin e non ho capito se è un pò lento nello sviluppo o meno.

    Se vuoi puoi tu stesso tramite il forum di supporto al plugin https://wordpress.org/support/plugin/w3-total-cache dare un contributo. Sembra ci sia già un thread iniziato a tal proposito.

Stai vedendo 15 repliche - dal 1 al 15 (di 23 totali)
  • Il topic ‘Aggiornamento alla versione 4.7’ è chiuso a nuove risposte.