Supporto » Installazione e Aggiornamento » Aggiornamento fallito in modifica di un post

  • Risolto filippo80

    (@filippo80)



    Salve,
    stamattina ho avuto la brutta idea di aggiornare a wordpress5 senza pensare che ci potessero essere problemi ed invece, come da titolo, il problema l’ho trovato!
    In pratica ora appena entro in modifica di un post mi da “Aggiornamento fallito” e, quindi, non riesco più a modificare nulla!
    Ho provato a disattivare tutti i plug-in ma il problema persiste! Qualcuno può suggerirmi qualcosa?
    Grazie!

    P.S.: Sono completamente cieco e non so se c’è un messaggio più esplicativo, nel caso in cui si potesse trovare da qualche parte me lo potreste dire?

Stai vedendo 3 repliche - dal 1 al 3 (di 3 totali)
  • Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    Ciao @filippo80
    la versione 5 di WordPress ha portato novità sostanziali per quanto riguarda l’editor, per cui qualche problema può capitare se il tema in uso non è per esempio compatibile con la nuova versione, oppure qualche plugin etc. per questo potrebbe essere utile ri-attivare il classic editor.
    hai letto questo articolo sulla V.5?
    https://it.wordpress.org/support/topic/leggi-questo-prima-di-aggiornare-a-wordpress-5-0/
    Potrebbe aiutarti a risolvere il problema, in caso contrario scrivici qui.

    Prima di fare ogni modifica al sito fare sempre un BACKUP
    https://codex.wordpress.org/WordPress_Backups

    Facci sapere se risolvi. Ciao

    Ciao @ramthas e grazie per la tua risposta!
    Per quanto riguarda il backup, per fortuna, sono a posto … l’avevo fatto il giorno prima! 🙂
    Il classic editor l’ho installato ma non si è risolto nulla, comunque forse non l’ho impostato correttamente perché non sembra essere cambiato nulla!
    Ora leggo con attenzione il post che mi hai suggerito e provo a risolvere speriamo bene … A dopo per le news 🙂

    Arieccomi,
    dopo aver provato di tutto ho trovato il modo di abilitare il debug ed ecco l’errore che mi restituiva e che non mi faceva salvare nessun post:

    PHP Notice: edit_form_advanced è deprecata dalla versione 5.0.0! Utilizzare al suo posto block_editor_meta_box_hidden_fields. Questa azione è ancora supportata nel Classic Editor, ma è deprecata nel Block Editor.

    Ieri avevo provato ad installare il classic editor ma lo avevo anche disattivato visto che tra i tentativi per risolvere il problema c’era quello di disattivare tutti i plug-in!
    Considero risolto il problema ma, forse, c’è un bug nell’opzione per tenere entrambi gli editor abilitati (intendo l’opzione per lasciare la scelta agli utenti di switchare tra i due editor) e nella disattivazione del suddetto plug-in visto che l’errore me lo continuava a dare nonostante avessi disattivato il classic editor.
    Ora, con il classic editor attivo e l’obbligo per tutti di usarlo, il problema è scomparso!
    Grazie @ramthas per il tuo suggerimento che mi ha portato alla soluzione del problema!

Stai vedendo 3 repliche - dal 1 al 3 (di 3 totali)
  • Devi essere collegato per rispondere a questo topic.