Supporto » Installazione e Aggiornamento » Aggiornamento PHP

  • Risolto ded0145

    (@ded0145)


    Buongiorno a tutti, da poco gestisco un sito su Aruba, vorrei aggiornare PHP che attualmente è alla versione 5.6.32 e portarlo alla 7.1.11, il problema che si presenta e si è presentato fin dall’installazione è che se vado oltre come versione, ho questo messaggio di errore:
    Error establishing a database connection
    Avete già riscontrato questo errore?
    Vi ringrazio
    Roberto

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Cioè ti dà un errore di connessione al database se provi ad aggiornare la versione del PHP?

    Si è tipico su aruba. Apri un ticket e fai presente la cosa. Solitamente ti cambiano il server MySql.

    Di solito per risolvere questo problema di connessione con il database MySql quando si fa l’upgrade di PHP è necessario inserire questa stringa in wp-config.php e ricaricare la home del sito attraverso cui sarà possibile riparare la connessione:

    define(‘WP_ALLOW_REPAIR’, true);

    Ovviamente dopo aver fatto un backup in quanto se non va a buon fine si rischia di perdere i dati.

    ded0145

    (@ded0145)

    Ottimo funziona metto il risolto al topic
    Ti ringrazio davvero
    Roberto Cavazza

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.