Supporto » Installazione e Aggiornamento » Aggiornamento WordPress 6.01

  • Buongiorno,
    succede una cosa strana, mai capitata prima. Ho aggiornato automaticamente alla versione 6.0.1, ma nella pagina degli aggiornamenti, leggo questo:

    “Versione corrente: 6.0.1
    Ultimo controllo il giorno 17 Agosto 2022 alle ore 8:31 am CEST. Verifica di nuovo.”

    E successivamente dice:
    “Hai già l’ultima versione di WordPress.
    Reinstalla la versione 5.4.2-it_IT”

    invece che propormi la versione 6.0.1, come succede in altri miei siti.

    Il sito funziona, ma c’è un plugin che, aggiornandolo, mi dice: internal server error, e forse dipende da un aggiornamento non corretto di wordpress. Quello stesso plugin è stato installato correttamente in altro sito.

    Ho anche aggiornato manualmente wordpress, nel senso che ho eliminato le cartelle wp-admin e wp-includes e le ho caricate di nuovo, ma nulla.

    Qualcuno potrebbe aiutarmi per favore?

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Non è una buona idea passare da una 5.4 alla 6!

    C’era da verificare, prima, la compatibilità dei temi e plugin.

    Chi ha creato la discussione robydc

    (@robydc)

    Grazie Gianluca,
    ma io non sono passato dalla 5.4 alla 6.0, ma dalla 5.9.3 alla 6.0, e il caso strano è che mi propone di reinstallare la vers. 5.4.2.
    E’ questo che non capisco.
    Ho notato un file nella root, che mi ritrovo dal 2018, si chiama ver.php e il contenuto è il seguente:

    “`<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”&gt;
    <html xmlns=”http://www.w3.org/1999/xhtml”&gt;
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=utf-8″ />
    <title>
    <?php echo $_SERVER[“HTTP_HOST”]; ?>
    </title>
    </head>
    <body>
    <?php echo phpinfo(); ?>
    </body>
    </html>`”

    Dato che non me lo ritrovo in altri miei siti, chissà se sia questo file che mi crea problemi.

    Scusa, avevo capito male… beh allora è davvero strana la situazione!

    Quale è il plugin che ti genera problemi?

    Chi ha creato la discussione robydc

    (@robydc)

    Il plugin è Bookly Pro, che con “vie normali2 non riesco ad aggiornare dalla versione 5.0 alla versione 5.2., in quanto mi dà l’errore “internal server error”.

    Ho scritto al gestore dello spazio web, che mi dice però che dal lato server non ci sono problemi, e mi suggerisce le solite cose, cioè disattivare i plugin, caricarli uno a uno, etc…
    Ma anche in questo modo non funziona.

    Cmq sono riuscito ad aggiornare quel plugin per altra via: ho caricato il plugin WP Staging, ho creato una copia del sito, ho disattivato tutti i plugin, cambiato tema, poi ho preso quel plugin che avevo già aggiornato in un altro mio sito, l’ho caricato, e funziona. Ho riattivato i plugin, e tutto è ok.

    Però non è il metodo normale, per cui penso ci sia qualcosa in wordpress che non sia andato a posto,e che per quello mi ripropone di reinstallare la vers. 5.4.2.

    Tu che ne pensi?

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.