Supporto » Installazione e Aggiornamento » Aggiornamento wordpress versione 4.9.11

  • Sto tentando di aggiornare worpress dalla versione 4.9.11 alla versione 5.2.3. L’aggiornamento non va buon fine a causa del seguente errore.

    “Non è possibile effettuare l’aggiornamento perché WordPress 5.2.3 richiede PHP versione 5.6.20 o superiore. Stai utilizzando la versione 5.5.38.”

    Tramite l’host (aruba) aggiorno PHP ad una versione superiore ma nel momento in cui torno sul sito il suddetto non risulta raggiungibile (WSoD).
    Facendo il downgrade di PHP tutto torna alla normalità ma naturalmente non posso aggiornare.

    Grazie

Stai visualizzando 5 risposte - dal 1 al 5 (di 5 totali)
  • Hai verificato se il tema ed i plugin sono aggiornati?

    Si, tutto aggiornato

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve francescomatera

    La versione di WordPress 4.9.1 è di due anni fa

    https://codex.wordpress.org/Current_events

    Il consiglio è di fare prima di tutto un BACKUP

    Successivamente il consiglio è di effettuare degli upgrade graduali

    https://wordpress.org/support/article/upgrading-wordpress-extended-instructions/

    in modo da individuare in quale versione si verifica l’incompatibilità con il plugin o il tema che causa il blocco

    Grazie per la risposta.

    Era proprio perché volevo evitare gli upgrade graduali che chiedevo consiglio nel forum.

    Effettivamente ho posto male il quesito, il problema non sembra essere l’aggiornamento di WordPress in se ma l’aggiornamento di PHP.
    Nel momento in cui aggiorno PHP dalla versione 5.5.38 ad una qualsiasi versione successiva il sito si blocca e non è più raggiungibile nemmeno la pagina di configurazione di wordpress. Questo problema l’avrei anche facendo un upgrade graduale.
    La soluzione sembrerebbe installare una versione recente di WordPress da zero, ma è proprio quello che vorrei evitare.

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Per evitare quel problema il consiglio è di eseguire gli aggiornamenti graduali delle versioni di WordPress PRIMA dell’aggiornamento della versione di PHP

    Arrivati alle ultime versioni si potrebbe aggiornare PHP, dalla 5.1 in avanti per esempio

    Aggiornaci

Stai visualizzando 5 risposte - dal 1 al 5 (di 5 totali)
  • Devi essere collegato per rispondere a questo topic.