Supporto » Fixing WordPress » Codifica caratteri saltata SOLO in 3 pagine del blog

  • Risolto francescoarnesano

    (@francescoarnesano)


    Ciao, vi sottopongo un problema che mi sta facendo perdere un sacco di tempo, ma a cui non riesco a trovare la soluzione.
    Su SOLO 3 pagine del mio blog risulta saltata la codifica dei caratteri speciali. Il resto del sito è ok e ho già tentato di tutto:
    modificare .htaccess, wp-config.php, inserire sotto l'<head> la configurazione UTF-8, ma nulla sembra funzionare.

    Qualcuno ha idea di cosa potrebbe trattarsi?

    Le pagine sono queste.

    serialparts.com/kit-catena-distribuzione-1-3-multijet/
    serialparts.com/migliori-marche-di-ammortizzatori-auto/
    serialparts.com/puleggia-albero-motore/

    Grazie mille in anticipo per il supporto che potrete darmi.

Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • autotutorial

    (@autotutorial)

    Attualmente vedo una pagina dentro un’altra pagina (c’è anche il DOCTYPE dopo un paragrafo 😀 ) , come crei/inserisci gli articoli?
    Si è un problema di codifica ma non lato WordPress poiché nel tuo articolo ci sono entità html (caratteri dell’alfabeto inglese che il browser conosce e li converte in testo) https://it.m.wikipedia.org/wiki/Entità_(markup) in ISO-8859-1 detto anche Latin1 mentre la pagina viene letta in UTF-8.

    francescoarnesano

    (@francescoarnesano)

    Ciao Autotutorial,
    grazie per avermi aiutato ad isolare il problema, in effetti era la causato dal doppio doctype e html causato dal plugin Amazon Associates Link Builder (che non usavo nemmeno in quegli artcoli…)
    Per ora l’ho disattivato in attesa di capire meglio come mai provocava quel bug.
    Grazie mille per il supporto!

    francescoarnesano

    (@francescoarnesano)

    Risolto

    autotutorial

    (@autotutorial)

    Si ho già sentito quel plugin e non da errore unicamente a te… Figurati è un supporto pubblico dove ognuno aiuta spassionatamente.

Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.