Supporto » Funzionalità = Plugin » Download non riuscito. No working transports found

  • Buonasera,
    da qualche giorno non riesco più ad aggiornare i plugin del mio sito (www.distampa.com).
    Ogni volta che provo a farlo, mi compare il seguente messaggio:

    Download non riuscito. No working transports found

    Tra l’altro, contrariamente al passato, wordpress mi ha chiesto di inserire i dati ftp, che ovviamente ho inserito correttamente.

    Ho provato a parlarne con l’assistenza del mio hosting, ma l’unica soluzione che mi ha dato era di ri-aggiornare wordpress. Ci ho provato, ma anche quell’aggiornamento restituisce il medesimo errore.

    Come risolvere questa situazione?

    Grazie e a presto,
    Daniele

    p.s. Il sito, beninteso, funziona ancora correttamente.

Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)
  • Moderatore Guido Scialfa

    (@wido)

    Ciao @carioti,

    Generalmente questi sono problemi legati alle impostazioni del tuo hosting o a particolari configurazioni di plugins per la sicurezza.

    Questi ultimi possono spaziare in vari campi.

    Il mio consiglio è quello di effettuare un aggiornamento manuale via ftp.

    Se non hai mai effettuato una procedura del genere innanzitutto effettua un backup ( tramite plugin magari usando BackWpUp o altro ) sia del database che dei files di Wp dopo di che dai un’attenta lettura a https://codex.wordpress.org/it:Aggiornare_WordPress

    Chi ha creato la discussione carioti

    (@carioti)

    Salve Guido,
    grazie per la risposta.

    Io proverei a seguire subito il tuo consiglio. Ma vorrei anche capire il motivo di questo problema.
    Che compare per la prima volta dopo oltre un anno di aggiornamenti automatici e sempre con lo stesso hosting. Peraltro, questo problema non è nato con l’installazione di nuovi plugin, né aggiornamenti, compreso l’ultimo di wordpress (il sito è aggiornato alla 4.7.3)

    Non vorrei infilarmi in un ginepraio quando, magari, si potrebbe risolvere tutto con due righe di codice e, lbnl, vorrei capire come e perché una condizione perfetta e non toccata in alcun modo si modifica, così, misteriosamente.

    Moderatore Guido Scialfa

    (@wido)

    Ciao @carioti,

    Potrebbero essere problemi legati a cosa permette di fare il tuo hosting più che problematiche di WordPress.

    Ad ogni modo bisognerebbe effettuare un debug per capire il problema ed è una cosa che va fatta analizzando i logs.

    Così su due piedi posso solo dirti che nel trac dei bugs noti non trovo nulla in riferimento a No working transports found.

    Da quello che ho visto nel codice sembra che a te manchi il supporto a cURL o fsockopen.

    Prova richiedere al tuo hosting a tal proposito.

    Chi ha creato la discussione carioti

    (@carioti)

    Ciao @wido,
    grazie ancora per la risposta.

    ho provveduto ad inoltrare i tuoi consigli al mio hosting e sono in attesa di una risposta. Nel frattempo, ho aggiornato tutti i plugin e il tema, e ovviamente dovrei aspettare nuovi aggiornamenti per vedere se il problema persiste. Tuttavia esso c’è ancora, eccome, perché non permette a Jetpack di collegarsi a wordpress.com

    Questo è quanto mi viene restituito dopo il tentativo:

    
    Il traffico HTTPS in uscita non funziona
    
    Il tuo sito non è collegato a WordPress via HTTPS. Questo problema potrebbe essere dovuto a diversi motivi, compreso un certificato SSL irregolare, librerie SSL non configurate in modo corretto o mancanti, o problemi di collegamento alla rete.
    Jetpack effettuerà il re-test per il supporto HTTPS una volta al giorno, ma facendo clic qui puoi rifarlo immediatamente:	Prova di nuovo WordPress segnala che non c'è nessun supporto per il SSL
    Per maggiore aiuto, prova il nostro connection debugger o il troubleshooting tips.
    

    Può essere d’aiuto per trovare la soluzione? Altrimenti, posso provare a fare un log di debug come da te consigliato. Ma poi, come te lo posso eventualmente inviare?

    Grazie mille per il tuo tempo e la tua gentilezza,
    buona serata,
    D.

    • Questa risposta è stata modificata 5 anni, 8 mesi fa da Guido Scialfa.
    Chi ha creato la discussione carioti

    (@carioti)

    Ciao @wido,
    ecco il debug.log:

    [16-Mar-2017 15:29:01 UTC] PHP Notice: Undefined index: a:1:{s:3:”ssl”;b:1;} in /wp-includes/class-requests.php on line 213

    Grazie anticipatamente per l’aiuto,
    D.

    • Questa risposta è stata modificata 5 anni, 8 mesi fa da Guido Scialfa. Motivo: Basta una sola riga
    Moderatore Guido Scialfa

    (@wido)

    Ciao @carioti,

    Definitivamente un problema di configurazione server Php/Apache, bisogna che tu effettui manualmente via Ftp un aggiornamento e/o chiarisci con il tuo hosting se i moduli php per cURL e/o fsockopen sono installati e funzionanti.

    Diversamente non c’è modo di poter effettuare un update via backend, andrà fatto manualmente.

    Il fatto che fino ad adesso non ti ha creato alcun problema non significa che derivi da WordPress / tema / plugins. Qualcosa nella configurazione della tua installazione php è stata modificata.

    PS. Prova a cercare su google con la seguente stringa PHP Notice: Undefined index: a:1:{s:3:”ssl”;b:1;}.

    Troverai informazioni riguardo a quanto definito

    • Questa risposta è stata modificata 5 anni, 8 mesi fa da Guido Scialfa.
Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)
  • Il topic ‘Download non riuscito. No working transports found’ è chiuso a nuove risposte.