Supporto » Fixing WordPress » Error 404 dopo Modifica permalink

  • albertogiardina

    (@albertogiardina)


    Salve,

    Ho modificato da impostazioni -> permalink, il permalink per i prodotti per migliorare SEO del mio sito.
    Il problema è che dopo aver effettuato la modifica sia i prodotti vecchi che quelli che creo nuovi, creano un URL che mi indirizza alla pagina “404 not found”.
    Ho provato a risolvere inserendo il precedente permalink ma non riesco a risolvere il problema.
    Purtroppo non ero a conoscenza prima del dover utilizzare un redirect.
    Come posso risolvere questo problema?

    Grazie

Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Ciao @albertogiardina,
    imposta i permalink nella versione semplice quella che fa terminare il permalink con ?p=123

    Questo dovrebbe evitare l’errore 404.

    Una volta fatto prova a impostare il permalink che ti interessa e svuotare la cache del server. Puoi farlo dal pannello del tuo hosting oppure usando il plugin Clear cache for me prima di visualizzare il frontend. Svuota anche la cache del browser.

    Ho lo stesso problema: dopo aver spostato il sito WordPress su altro server, da Apache a Nginx visualizzo solo la homepage. Tutte le altre pagine danno errore 404.

    Sono riuscito a fare funzionare tutte le pagine mettendo l’opzione “Semplice” nei Permalink. Non voglio però usare questa opzione.

    Con le altre opzioni di Permalink, tra cui “Nome Articolo” ottengo sempre errore 404.
    Ho provato a installare il plugin ” Velvet Blues Update” ma non mi ha trovato errori nell’URL.

    Come posso risolvere il problema? Grazie.


    I have the same problem: after moving the WordPress site to another server, from Apache to Nginx I only see the homepage. All other pages give 404 error.

    I was able to get all the pages to work by putting the “Simple” option in the Permalinks. I don’t want to use this option though.

    With the other Permalink options, including “Article Name” I always get 404 error.
    I tried to install the “Velvet Blues Update” plugin but it found no URL errors.

    How can I solve the problem? Thank you.

Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Devi essere collegato per rispondere a questo topic.