Supporto » Fixing WordPress » Error 500 nei moduli

  • Risolto fdtrader

    (@fdtrader)


    Ciao a tutti,

    Prima di scrivere qui ho cercato ovunque una soluzione, ma non è servito a niente.

    Il problema sul mio blog è questo:
    Quando i miei visitatori tentano di iscriversi alla newsletter tramite il modulo nei widget della barra laterlae oppure cercano di contattarmi utilizzando un altro modulo (form) nella sezione contatti, esce questo errore:

    La pagina xxxxxxx.net non funziona
    xxxxxxxxx.net al momento non è in grado di gestire la richiesta.
    HTTP ERROR 500

    Ho provato cambiando htaccess,aggiornano la pagina dei permalink ma nulla.

    Come potrei fare, non so più cosa cercare e come risolvere.

    Una cosa mi è venuta in mente, potrebbe essere la versione php obsoleta?
    Perchè se vado nel mio pannello di controllo del mio hosting, nella sezione database trovo la versione php 5.4 e dice che non è più supportata e di aggiornarla, ma non vorrei fare danni.

    Vi ringrazio molto.

    Ciao

Stai vedendo 15 repliche - dal 1 al 15 (di 44 totali)
  • Scusa ma non puoi aprire un ticket di assistenza alla società che ti offre il servizio di hosting?

    Mi pare un problema lato server…

    fdtrader

    (@fdtrader)

    Si già fatto mi hanno risposto così :
    Le ricordo che la problematica citata è di tipo software ma che XXXXXX offre supporto per problematiche di tipo infrastrutturale e di connettività.

    Sinceramente non so più a chi rivolgermi per questo problema, le ho provate tutte.

    Se qualcuno di voi può aiutarmi gliene sono grato veramente.

    Grazie

    Ciao

    Mi pare la classica frase “lavamani”… vabbé…

    Per prima cosa fai un backup completo.

    Poi: il tuo servizio di hosting permette di ripristinare i permessi di file/cartelle?

    fdtrader

    (@fdtrader)

    Ho chiesto a loro direttamente e mi hanno detto che si può fare solo via FTP.

    Grazie

    Uhm… miseria ma che hosting è??? 😀
    Cioè non hai Cpanel, Plesk… insomma un pannello di controllo?

    fdtrader

    (@fdtrader)

    Non so se posso scriverlo qui il nome dell’hosting….. ditemi voi 🙂

    Cmq si un pannello di controllo c’è, ma quando gli ho chiesto se potevo cambiare da lì i permessi mi hanno risposto solo da FTP.

    Lascia stare l’hosting…. ripristina i permessi come da link prima inserito.

    fdtrader

    (@fdtrader)

    Ho ripristinato i permessi da FTP, ancora nulla…. stesso errore.
    Ho messo come da esempio 666.

    Grazie

    fdtrader

    (@fdtrader)

    Avevo sbagliato….. ho messo i default permissions che dovrebbero essere questi:
    644 -rw-r–r– /home/user/wp-config.php
    644 -rw-r–r– /home/user/cgi-bin/.htaccess
    644 -rw-r–r– /home/user/cgi-bin/php.ini
    755 -rwxr-xr-x /home/user/cgi-bin/php.cgi
    755 -rwxr-xr-x /home/user/cgi-bin/php5.cgi

    Ma non trovo i file php.ini , php.cgi e php5.cgi

    Potrebbe essere per il fatto che non ho aggiornato la versione php dal mio pannello di controllo?
    Attualmente ho la 5.4 e mi dice che è obsoleta.

    Grazie

    Uhm…

    Il form che ti da l’errore è quello integrato nel tema?

    Prova ad installare Contact Form 7 e vediamo se funziona.

    Così vediamo ed appuriamo se è un problema lato server oppure del form in questione che fa “i capricci”.

    fdtrader

    (@fdtrader)

    I form sono due, il primo è un iscrizione al blog tramite widget di jetpack,
    l’altro è un modulo di contatto in un’altra pagina che ho inserito tramite il normale editor di wordpress.

    Ho installato Contact Form 7, quando clicco submit non mi da alcun messaggio di errore ma carica all’infinito…. non funziona.

    A questo punto si può davvero pensare a qualche problema lato server…. se anche CF7 non funziona….

    Come ultima prova: disponi di uno spazio web alternativo di test? (che so ad esempio altervista)

    fdtrader

    (@fdtrader)

    Non ho un altro spazio web purtroppo.

    Ma secondo te può essere che non vada bene la versione php come dicevo prima?

    Su argomenti lato server sinceramente non sono molto preparato… comunque non credo: ho dei clienti i cui hosting usano ancora php 5.4 e non hanno problemi…

    Imho proverei ancora una cosa.
    Dopo un bel backup completo disattiva TUTTI i plugin e riprova il modulo.

    Nello spazio web è presente un file error log?

Stai vedendo 15 repliche - dal 1 al 15 (di 44 totali)
  • Il topic ‘Error 500 nei moduli’ è chiuso a nuove risposte.