Supporto » Fixing WordPress » Error 500 nei moduli

  • Risolto fdtrader

    (@fdtrader)


    Ciao a tutti,

    Prima di scrivere qui ho cercato ovunque una soluzione, ma non è servito a niente.

    Il problema sul mio blog è questo:
    Quando i miei visitatori tentano di iscriversi alla newsletter tramite il modulo nei widget della barra laterlae oppure cercano di contattarmi utilizzando un altro modulo (form) nella sezione contatti, esce questo errore:

    La pagina xxxxxxx.net non funziona
    xxxxxxxxx.net al momento non è in grado di gestire la richiesta.
    HTTP ERROR 500

    Ho provato cambiando htaccess,aggiornano la pagina dei permalink ma nulla.

    Come potrei fare, non so più cosa cercare e come risolvere.

    Una cosa mi è venuta in mente, potrebbe essere la versione php obsoleta?
    Perchè se vado nel mio pannello di controllo del mio hosting, nella sezione database trovo la versione php 5.4 e dice che non è più supportata e di aggiornarla, ma non vorrei fare danni.

    Vi ringrazio molto.

    Ciao

Stai vedendo 14 repliche - dal 31 al 44 (di 44 totali)
  • Aggiornamento:
    Ho cambiato hosting, troppo poco seria la società precedente.
    Ti chiedo un ultimo favore, se puoi aiutarmi.

    Io ho il backup completo del mio blog wordpress, file,cartelle,database, tutto.
    Vorrei trasferirlo sul mio nuovo hosting e riavere il mio blog esattamente come prima.

    Ho seguito già qualche guida ma non funziona, forse sbaglio qualche passaggio…. devo fare un installazione pulita di wordpress oppure copiare tutto tramite ftp o che altro?

    Ti ringrazio molto

    Devi caricare tutti i file via FTP, editare il wp-config con i nuovi dati del database.

    Ovviamente avrai anche importato il tuo database 🙂

    Salve. non ho trovato come creare una discussione e quindi provo ad accordarmi a questa per un problema con contact form 7.
    Ho inserito nel mio sito il plugin “profile extra field” ed ho previsto dei campi extra sul profilo utente (tutti di tipo Text).
    Come posso fare in modo che su un modulo vengano riportati i campi dell’utente (che ha effettuato il login) compresi gli extra, prelevandoli dal database e più precisamente dal profilo?

    Cioè in testata del form vorrei che venissero riportati (e poi inclusi nella mail di consegna) i campi del profilo utente (nome, cognome, email, azienda, telefono, etc…) magari non modificabili.

    Grazie

    Ho caricato tutti i file via FTP, modificato wpconfig, creato nuovo database e importato.
    Mi dice ad un primo caricamento “sito in costruzione” se provo a ricaricare la pagina “Errore nello stabilire una connessione al database”

    Con quell’errore sicuramente c’è qualcosa che non va… Nome del database è corretto?

    Occhio alla differenza tra minuscole e maiuscole !

    Si è corretto.

    Poi non capisco, perchè al primo caricamento mi dice “sito in costruzione” e la seconda volta errore database.

    Ma riesci ad entrare nella bacheca?
    Il nome a dominio è rimasto uguale?

    Il dominio è lo stesso.

    Sono riuscito ad entrare in bacheca tramite wpadmin, ma quando clicco su visualizza sito mi da “sito in costruzione”.

    un momento…. è partito.

    C’è sempre quel problema con jetpack però:
    Per poter utilizzare Jetpack il tuo sito deve avere permessi di accesso pubblico: site_inaccessible
    Dettagli sull’Errore: The Jetpack server was unable to communicate with your site [HTTP 500]. Ask your web host if they allow connections from WordPress.com.

    Allora risalva i permalink: così le pagine si vedono?

    Sicuro che il sito sia già trasferito completamente e che ti colleghi già al nuovo server?

    Forse ti sei perso il mio secondo msg, te lo riporto qui:

    Un momento…. è partito.
    C’è sempre quel problema con jetpack però:
    Per poter utilizzare Jetpack il tuo sito deve avere permessi di accesso pubblico: site_inaccessible
    Dettagli sull’Errore: The Jetpack server was unable to communicate with your site [HTTP 500]. Ask your web host if they allow connections from WordPress.com.

    Risolto tutto!
    Supporto fantastico del mio nuovo hosting.

    Il plugin che dava problemi era WPSPAMSHIELD, l’ho disattivato e ora funziona tutto.
    Avevo in precedenza disattivato per prova tutti i plugin ma non funzionava cmq, ma ora è andato.

    Grazie mille anche a Webepc!

    Grazie a te fdtrader per il feedback…. delle volte non potendo accedere al sito in questione diventa anche difficile rispondere ai quesiti e si deve andare un po’ a tentoni!

    @kingdave
    Apri una discussione a parte 🙂

    Capisco benissimo Webepc, hai fatto il possibile e ti ringrazio molto.
    Infatti per risolvere il problema il supporto hosting è entrato con username e password nel blog.

    Grazie ancora!
    Ciao

Stai vedendo 14 repliche - dal 31 al 44 (di 44 totali)
  • Il topic ‘Error 500 nei moduli’ è chiuso a nuove risposte.