Supporto » Fixing WordPress » Errore caratteri a seguito migrazione sito

  • Salve Amici,
    un consiglio se possibile,
    ho spostato il mio blog personale da un server ad un altro, prima Mysql ora MariaDB e ora le lettere accentate si presentano con caratteri strani (€)

    Ho migrato nello stesso nuovo server altri WP, ma solo questo mi ha generato problemi, forse perchè il sito è stato realizzato diversi anni fa.

    Vi riporto alcune parti del mio DB (prima ancora dell’importazione nel nuovo sistema) che contengono il charset, secondo voi dovrei operare delle modifiche?

    -- MySQL dump 10.13  Distrib 5.5.59, for debian-linux-gnu (x86_64)
    --
    -- Host: localhost    Database: MYDB
    -- ------------------------------------------------------
    -- Server version       XXXXX.+deb8u1-log
    
    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;
    /*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
    /*!40103 SET TIME_ZONE='+00:00' */;
    /*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    /*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;
    
    --
    -- Table structure for table <code>wp_TABLE</code>
    --
    
    DROP TABLE IF EXISTS <code>wp_TABLE</code>;
    /*!40101 SET @saved_cs_client     = @@character_set_client */;
    /*!40101 SET character_set_client = utf8 */;
    CREATE TABLE <code>wp_TABLE</code> (
    [...]
      PRIMARY KEY (<code>id</code>)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8;
    /*!40101 SET character_set_client = @saved_cs_client */; 

    Grazie infinite!

    Davide

Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Ciao Davide @danjde,

    ATTENZIONE: Prima di seguire i suggerimenti forniti in questa risposta, per favore effettua un backup al tuo sito web per garantire che tu non perda alcun dato importante causato da un eventuale problema che le indicazioni sotto potrebbero portare a creare.

    È un grande piacere conoscerti. Sono Matteo.

    Relativamente al tuo quesito, questa guida potrebbe esserti utile.

    Per qualsiasi ulteriore domanda o quesito, resto a disposizione.

    Grazie,
    Matteo S.

    • Questa risposta è stata modificata 3 mesi, 1 settimana fa da Matteo S..

    Ciao Matteo e grazie per il gentilissimo aiuto!

    Premetto che i caratteri errati non sono i soliti ma al ppsto delle lettere accentate mi trovo il simbolo dell’Euro.

    Ecco un esempio di un titolo (ma il problema riguarda ovviamente ogni contenuto):

    RIFLESSIONI SEMISERIE SU ENTROPIA E UMANITÀ

    aggiungo che avevo già letto e verificato con esito negativo la presenza di:

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Cos’altro mi consigliate di verificare?
    Dalla parte di DB che ho postato emerge qualche anomalia secondo voi?

    Grazie ancora

    Davide

Stai visualizzando 2 risposte - dal 1 al 2 (di 2 totali)
  • Devi essere collegato per rispondere a questo topic.