Supporto » Fixing WordPress » ERRORE CON YOAST SEO DOPO L’AGGIORNAMENTO ALLA VERSIONE 8.0.27 DI PHP

  • stefanopezzola

    (@stefanopezzola)


    Salve dopo l’aggiornamento della versione php alla 8.0.27 del mio wordpress 6.1.1 il plugin Yoast SEO (versione 20.0) ha creato un errore (vedi sotto) ed il sito nella sua parte back-end va in crash.

    Dettagli dell’errore

    ====================

    Un errore di E_ERROR è stato causato nella riga 58 del file /home/awmedia/public_html/wp-content/plugins/wordpress-seo/admin/class-admin-asset-manager.php. Messaggio di errore: tempo di esecuzione massimo di 600 secondi superato

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Più che di php mi sembra che sia una “strozzatura” lato hosting.

    Eleva il max execution time

    Chi ha creato la discussione stefanopezzola

    (@stefanopezzola)

    Ciao Gianluca il max_execution_time era a 300 e l’ho portato a 600 ma non è servito a molto purtroppo ancora il back-end va in loop e dopo poco manda in crash il sistema

    Ciao @stefanopezzola ,

    Se non erro il codice che fallisce è questo, un semplice insermento di script nella head:

    	/**
    	 * Enqueues scripts.
    	 *
    	 * @param string $script The name of the script to enqueue.
    	 */
    	public function enqueue_script( $script ) {
    58:		wp_enqueue_script( $this->prefix .     $script );
    	}

    Dovrebbe volerci meno di 1 secondo. C’è qualcosa che proprio non va.

    Perché non ritorni alla precedente versione di php?

    saluto

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve @stefanopezzola @luca21 @webepc

    il consiglio è di utilizzare la versione minima di PHP che rende la propria installazione WordPress sicura che è la 8.0 perché la 7.4 e precedenti non ricevono più aggiornamenti di sicurezza dagli autori di PHP da novembre 2022

    https://www.php.net/supported-versions.php

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Il topic ‘ERRORE CON YOAST SEO DOPO L’AGGIORNAMENTO ALLA VERSIONE 8.0.27 DI PHP’ è chiuso a nuove risposte.