Supporto » Varie ed eventuali » Errore durante il caricamento di nuove immagini

  • Salve,
    apro un nuovo ticket perché dopo una ricerca tra i post del forum di supporto e online non sono riuscito a risolvere e capire da cose potesse essere determinato il problema.
    Premessa: non sono un esperto di WordPress e sto lentamente imparando come gestire il sito dopo esser rimasto senza assistenza tecnica.
    Intorno al 4/02 ho aggiornato tema (utilizzo Lay Theme) e i plugin vari ed eventuali scaricati sul sito, successivamente ho aggiornato le pagine del sito con ulteriori nuovi progetti senza alcun problema, potendo creare nuovi progetti e aggiungendo immagini relative.
    Negli ultimi giorni, dopo aver istallato Updraft per effettuare dei backup, avevo intenzione di aggiornare la thumbnail di un progetto vecchio già presente sul sito, ma sia dalla scheda del progetto che tramite la Libreria Media, mi è stato impossibile inserire una nuova immagine, dandomi tale errore:

    Impossibile inserire l’allegato nel database.

    Ricercando su internet e leggendo forum di supporto vari, mi dava come possibili spiegazioni (vista l’assenza di successive modifiche dal 4/02): necessità dell’ultimo aggiornamento di WordPress (il quale era effettivamente tra le notifiche del pannello di gestione del sito) o un cambio di permessi nella directory wp-content>uploads (causati erroneamente dal mio host provider, ovvero TopHost).

    Ho provato ad aggiornare i permessi della cartella uploads, settando prima 755 > Includi sottocartelle > Applica solo alle cartelle poi 644 > Includi sottocartelle > Applica solo ai file.
    Dopo il cambio di permessi comunque l’errore persisteva.

    Ho provato, quindi, ad aggiornare WordPress tramite il pannello interno al sito, ma non è mai riuscito ad aggiornarlo perché risultavano in background altri aggiornamenti non specificati, allora ho provveduto manualmente seguendo la guida del supporto entrando direttamente in FTP con le credenziali che mi hanno dato. WordPress risulta aggiornato ad ora e il sito funzionante, senonché l’unica differenza è la scomparsa delle thumbnail di determinati progetti nella homepage iniziale del sito (problema, peraltro, non presente nella versione mobile che risulta funzionante e con tutte le thumbnail).
    L’aggiornamento, però, non ha risolto l’errore presente nel caricamento dei media.

    Il sito è: http://www.charliegfennel.com/ se non risultasse dalle informazioni dell’account.
    Chiedo cortesemente una mano, perché temo di fare ulteriori danni al sito.
    Spero di esser stato abbastanza esplicativo, nel caso richiedeste altre informazioni fatemelo sapere, grazie mille in anticipo!

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Ciao Massimiliano,

    hai provato a verificare lo spazio allocato al tuo database ed al sito sul pannello di controllo di Tophost? A volte le impostazioni standard assegnano a sito e database solo una parte dello spazio che hai effettivamente a disposizione. Mi chiedo se l’ìmpossibilità di caricare possa essere dovuta ad un limite di spazio raggiunto.

    Vuoi provare a dare uno sguardo?

    Chi ha creato la discussione Massimiliano Sacco

    (@dalloshh)

    Ciao Piermario,
    effettivamente non l’avevo controllato perché, non avendo in gestione diretta l’ordine su TopHost, pensavo fosse stato già controllato dalla persona che in primo luogo aveva creato il sito dopo che gli ho presentato le diverse problematiche.
    Ho fatto pressione affinché controllasse e adesso ho anche preso in gestione diretta il dominio, ed era proprio come avevi supposto: spazio locato al database completamente pieno! Ha provveduto ad aumentare quello disponibile sotto tuo consiglio ed ora tutto funziona al meglio. Tutte le problematiche, sia di upload che di salvataggio delle varie modifiche apportate a plug-in e tema, adesso possono essere effettuate.
    Mi chiedo però se, in primo luogo, lo spazio non fosse stato occupato per plug-in di backup che avevo installato i quali, settimanalmente provvedevano a fare una copia di back-up. (avevo scaricato BackUpWordPress che poi avevo disinstallato perché non è mai riuscito a fare dei backup e Updraft, quale face quello dei file ma non era mai riuscito a farne uno del database!) Viste le problematiche che mi avevano dato, avevo provveduto a disattivarli e disinstallarli e successivamente cancellare anche i file rimanenti tramite FTP ancora presenti nella cartella plugins, ma forse avrei dovuto pulire anche dal database accedendovi da cpanel?

    Grazie mille, sei stato gentilissimo e fammi sapere se potrebbe essere dovuto a ciò o se semplicemente lo spazio di memoria era già agli sgoccioli!

    Attendo una tua risposta,
    Massimiliano.

    Ciao Massimiliano,

    il database in sé contiene principalmente testo, solitamente serve un bel po’ per riempirlo, anche con molte pagine o plugin. Escluderei che Updraft in sé fosse causa del problema che hai riscontrato. Probabilmente nel tuo caso il sito era rimasto all’impostazione standard che non assegna al database tutto lo spazio disponibile. Se non l’hai già fatto, ti consiglio di verificare l’impostazione dello spazio allocato anche per il sito in sé, sempre all’interno del pannello di controllo di Tophost.

    Nel frattempo che prendi confidenza con WordPress, ti sconsiglierei di intervenire direttamente sulle cartelle FTP dei plugin. Solitamente basta disattivare e cancellare un plugin dalla pagina apposita all’interno dell’amministrazione del tuo sito.

    Intanto, felice che tu abbia risolto!

    Buona giornata

    Chi ha creato la discussione Massimiliano Sacco

    (@dalloshh)

    Ok, perfetto! Appena ho tutte le credenziali proverò a darci una occhiata direttamente e ancora grazie tante per le dritte.

    Buona giornata a te e comunque sei proprio bono.
    Spero di avere di nuovo a che fare con te!

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.