Supporto » Installazione e Aggiornamento » Errore fatale dopo aggiornamento

  • Risolto aanto19

    (@aanto19)


    Buongiorno,

    dopo aggiornamento a WordPress 5.1.18, è presente questo messaggio: Errore fatale: la sintassi di accesso all’offset di array e stringhe con parentesi graffe non è più supportata in /home/mhd-01/www.avvocatomatricardi.it/htdocs/wp-includes/script-loader.php alla riga 706.

    Come posso risolvere? Grazie mille

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • Wp 5.1 è vecchissimo!

    A prescindere da questo andrei a verificare lato hosting che non sia stata aggiornata la ver. del PHP

    Chi ha creato la discussione aanto19

    (@aanto19)

    Grazie mille. Infatti dalla verifica che mi hai indicato mi viene risposto: “Riportando la versione di php in 7.2 l’errore indicato non viene più generato. Evidentemente sta utilizzando script e plugin obsoleti che andrebbero aggiornati per utilizzare una versione di php più recente.”

    Stamattina da altro browser (Mozilla) accedo e aggiorno a 6.4.3. Risultato: Errore irreversibile: Errore non rilevato: Chiamata alla funzione non definita wp_is_block_theme() in /home/mhd-01/www.avvocatomatricardi.it/htdocs/wp-admin/menu.php:203 Traccia dello stack: #0 /home/mhd-01/www.avvocatomatricardi.it/htdocs/wp-admin/admin.php(158): require() #1 /home/mhd-01/www.avvocatomatricardi.it/htdocs/wp-admin/update-core.php(10): require_once(‘/home/mhd-01/ww…’) #2 {principale} /home/mhd-01/www.avvocatomatricardi.it/htdocs/wp-admin/menu.php on line 203

    Come posso correggere o annullare l’aggiornamento?

    Grazie mille

    Si deve aggiornare tutto (giusto per stare in tema legale anche per rispettare il GDPR) andando ad aggiornare e sostituire tutti i componenti… di sicuro non fare un aggiornamento da WP 5.0.1 a 6.4.3!!!

    Ti conviene scaricare una versione intermedia (5.7?) ed aggiornare il tutto a step.

    Chi ha creato la discussione aanto19

    (@aanto19)

    Risolto! Grazie a Filezilla ho aggiornato con WP 5.7, poi il tutto a step come suggerivi. Ti ringrazio infinitamente e scusa per l’imbranataggine. Buona serata!

    Quindi dopo sei riuscito a portarlo alla 6.4.3?

    Mi raccomando aggiorna il PHP alla versione 8.x

    Chi ha creato la discussione aanto19

    (@aanto19)

    A WP 6.4.3 no, andrò per gradi. Adesso sono a WP 5.7 e con il rinnovo host aggiornerò il PHP alla versione 8.x. Grazie ancora

    Rimane comunque piuttosto obsoleta, intanto sistema il certificato SSL

    Intanto penserei a sostituire il tema: https://wordpress.org/themes/wrock-metro/

    Ha pochissime installazioni e non è più aggiornato da quasi 1 anno

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • Devi essere collegato per rispondere a questo topic.