Supporto » Fixing WordPress » “Errore nello stabilire una connessione al database” dopo la clonazione

  • Risolto federico

    (@federicogb25)


    Buonasera a tutti,

    Poco fa ho provato a clonare il mio sito WordPress al fine di modificare tema e, dunque, per avere un ambiente di testing sul quale lavorare.

    Il problema sorge quando, dopo aver cambiato il dominio dal file wp-config.php (Multisito), inserisco le corrette credenziali MySQL e il sito web mi restituisce l’errore “Errore nello stabilire una connessione al database“.

    Ho provato ad accedere alla pagina wp-admin, e lì mi viene suggerito di verificare che il database contenga delle tabelle (Che sono tutte presenti).

    Quindi, provo a riparare il database utilizzando il metodo di riparazione che ho trovato su https://wordpress.org/support/article/debugging-a-wordpress-network/. Purtroppo, anche quest’ultimo metodo non ha avuto successo in quanto mi viene dato lo stesso errore “Errore nello stabilire una connessione al database“. (Ho già provato ad eseguire i comandi suggeriti nell’articolo sopracitato, ma nulla).

    Ho diversi siti in produzione e tutti quanti funzionano correttamente. Ho anche provato a connettere il sito web allo stesso database del sito web in produzione, ma sembra che non voglia proprio saperne.

    Server: Debian 10
    Webserver: nginx
    Utilizzo MariaDB ed è correttamente configurato e funzionante.
    La versione di WordPress è l’ultima disponibile (5.7)

    C’è un modo per risolvere? Grazie mille in anticipo e buona serata 🙂

    • Questo topic è stato modificato 7 mesi, 3 settimane fa da federico.
Stai visualizzando 5 risposte - dal 1 al 5 (di 5 totali)
  • Ciao @federicogb25 ,

    ho dato un’occhiata ai tuoi post precedenti e quindi non dovresti avere nessuna difficoltà a capire cosa significhi con precisione

    “Errore nello stabilire una connessione al database“

    esaminando i log di errore del server.

    Puoi anche far girare uno script che fa una connessione test per capire che errore sia.

    <?php
    /*	Es_db_PDO	*/
    $servername = "localhost";
    $username = "username";
    $password = "password";
    $dbname = "myDBPDO";
    
    try {
        $conn = new PDO("mysql:host=$servername;dbname=$dbname", $username, $password);
        // set the PDO error mode to exception
        $conn->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
        echo 'connection ok';
        }
    catch(PDOException $e)
        {
        echo $e->getMessage();
        }
    
    $conn = null;
    exit;

    Il codice di errore risultante ti dirà che errore c’è.

    Può darsi che user e password abbiano dei caratteri strani o che si sia altro.
    Allora conviene, penso, cancellare il database e l’user,
    fare magari un restart del server mysql ( trovi in rete i comandi per il Debian . Si fa usando Putty e la connessione SSH ),
    reimpostare database, user e password.

    Io ho sempre evitato di usare il solo server nginx per paura che non fosse perfettamente compatibile con i CMS e forse ho fatto bene.

    Per curiosità, che pannello server usi? (Non dirmi che fai tutto a mano, eh)

    Chi ha creato la discussione federico

    (@federicogb25)

    Ciao @luca21 e grazie per la risposta 🙂

    Come immaginavo, la connessione al database va a buon fine secondo lo script.
    Purtroppo però quest’installazione di WordPress (Proveniente da un backup), sembra che non voglia proprio connettersi al database importato, nonostante provenga dallo stesso backup.

    Ho inoltre provato a riavviare sia il server MySQL che nginx, ma purtroppo ancora nulla da fare…

    Per quanto riguarda il pannello, utilizzo un VPS Linux, quindi devo fare tutto attraverso la riga di comando 😅
    Tuttavia, i pannelli sono installabili anche su questo tipo di server.

    Grazie mille e buona giornata 😀

    Ciao @federicogb25 ,

    devo fare tutto attraverso la riga di comando 😅

    Proprio tutto a mano! Mica tanto facile, anzi difficile e anche laborioso!

    E’ proprio la copia del sito che non va bene, quindi.
    Francamente non riesco ad immaginare cosa ci sia che blocca le cose addirittura dall’inizio.

    Nella peggiore delle ipotesi potresti rifare la migrazione utilizzando uno dei plugin di WP per fare il backup.
    Funzionano bene. Finora non ho mai avuto nessun problema.

    Ciao e buon fine settimana.

    Chi ha creato la discussione federico

    (@federicogb25)

    Ciao @luca21,

    Alla fine ho risolto installando una copia pulita di WordPress e importando tutto il contenuto. Questo errore è molto strano, in quanto eseguo la stessa operazione quando ho bisogno di ripristinare un backup di altri siti web WordPress senza alcun tipo di problema.

    Indagherò più a fondo sulla faccenda.
    Buona serata 😉

    Ciao @federicogb25 ,
    lo è davvero, un errore molto strano.

    Spulciando qua e là ho trovato un post, di qualche tempo fa, con lo stesso errore in un forum in inglese.

    Senza che nessuno ne capisse la ragione. Come questo.

    Un saluto.

Stai visualizzando 5 risposte - dal 1 al 5 (di 5 totali)
  • Il topic ‘“Errore nello stabilire una connessione al database” dopo la clonazione’ è chiuso a nuove risposte.