Supporto » Varie ed eventuali » Errore quando entro nella bacheca

  • Risolto steve92

    (@steve92)


    Il sito funziona e faccio login, ma quando cerco di entrare nella bacheca esce questo errore, il file ha 2 codici identici uno sotto l’altro e se ne tolgo mi fa entrare e funziona tutto.

    Ho un’altro sito che contiene lo stesso file, ma non mi da errore.

    Fatal error: Uncaught Error: Class 'WP_Privacy_Data_Export_Requests_List_Table' not found in /membri/fotoebenessere/wp-admin/includes/deprecated.php:1530 Stack trace: #0 /membri/fotoebenessere/wp-admin/includes/admin.php(92): require_once() #1 /membri/fotoebenessere/wp-admin/admin.php(97): require_once('/membri/fotoebe...') #2 /membri/fotoebenessere/wp-admin/index.php(10): require_once('/membri/fotoebe...') #3 {main} thrown in /membri/fotoebenessere/wp-admin/includes/deprecated.php on line 1530

Stai visualizzando 3 risposte - dal 1 al 3 (di 3 totali)
  • Ciao @steve92 ,

    c’è un post del tutto simile nel forum inglese
    https://wordpress.org/support/topic/fatal-error-class-wp_privacy_data_export_requests_list_table-not-found/

    A quanto sembra l’errore si verifica quando wp o un plugin cerca di definire un’altra classe col nome simile WP_Privacy_Data_Export_Requests_Table, come estensione appunto di WP_Privacy_Data_Export_Requests_List_Table.
    WP_Privacy_Data_Export_Requests_Table è una classe deprecata da wp , inserita nel file /wp-admin/includes/deprecated.php almeno dal wp ver 5.5.1.

    Di suo la classe WP_Privacy_Data_Export_Requests_List_Table sta nel file /wp-admin/includes/class-wp-privacy-data-export-requests-list-table.php.

    Il succo di tutto questo panegirico?

    Come suggerito dal post inglese è probabile che ci sia tema o un plugin che carica il file deprecated.php prima che sia presente quello che contiene la classe da estendere.

    In luglio io non ci sono e mi dirai più avanti come hai risolto. 🙂

    Un saluto.

    Chi ha creato la discussione steve92

    (@steve92)

    Ho provato ha installare WordPress nuovo, quindi originale, mi da questo nuovo errore, sono 2 giorni che va avanti cosi:

    Fatal error: Uncaught Error: Class 'WP_Session_Tokens' not found in /membri/fotoebenessere/wp-includes/class-wp-user-meta-session-tokens.php:17 Stack trace: #0 /membri/fotoebenessere/wp-settings.php(180): require() #1 /membri/fotoebenessere/wp-config.php(88): require_once('/membri/fotoebe...') #2 /membri/fotoebenessere/wp-load.php(37): require_once('/membri/fotoebe...') #3 /membri/fotoebenessere/wp-blog-header.php(13): require_once('/membri/fotoebe...') #4 /membri/fotoebenessere/index.php(17): require('/membri/fotoebe...') #5 {main} thrown in /membri/fotoebenessere/wp-includes/class-wp-user-meta-session-tokens.php on line 17

    Chi ha creato la discussione steve92

    (@steve92)

    No, comunque ci sono riuscito finalmente, l’ho installato con una connessione fibra più veloce e ora funziona. A quanto pare era un problema di connessione lenta per questo scopo.

Stai visualizzando 3 risposte - dal 1 al 3 (di 3 totali)
  • Devi essere collegato per rispondere a questo topic.