Supporto » Installazione e Aggiornamento » errore tema o plugin

  • salve, sono Vincenzo Gaudino titolare del sito nel link.
    premetto di non essere un esperto e che fino ad ora ho sempre aggiornato i plugin verificandone la compatibilità con le versioni wordpress,cosa che ho fatto anche stavolta prima dell’ultimo aggiornamento
    Ho ricevuto la mail automatica di wordpress che mi diceva di avere tale problema,la pagina in questione risulta bianca con il cerca in alto a sinistra,la mail mi chiede di contattare il mio hosting che in maniera per me abbastanza criptica mi chiede di rivolgermi allo sviluppatore senza indicarmi se del plugin o del tema,pur avendolo chiesto diverse volte, se può essere d’aiuto queste sono le informazioni correnti:Versione di WordPress 5.8
    Tema corrente: Ascend – Premium (versione 1.9.19)
    Plugin corrente: WooCommerce (versione 5.5.1)
    Versione PHP 7.4.16
    la navigazione del sito appare buona tranne delle pagine nel footer che portano a dei link inesistenti oppure obsoleti.
    spero di essermi fatto capire e ringrazio cordialmente chi potrà aiutarmi,saluti

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Buongiorno @vingajewels,

    il link che hai indicato fa riferimento ad una pagina della bacheca di WordPress e non possiamo vederla.

    Tuttavia permette di capire che la pagina in questione è quella dei Widget. Proprio questa pagina, da WordPress 5.8, è cambiata radicalmente, perchè adesso i widget sono gestiti con lo stesso editor a blocchi che utilizzi nelle pagine e nei post.

    Per escludere problemi di cache post-aggiornamento, ti suggerisco di aprire la bacheca da una sessione anonima del tuo browser o di provare un browser diverso.
    Se utilizzi plugin per migliorare le performance del sito, accertati di aver cancellato le relative cache.

    Se il problema persiste, posso ipotizzare due cause:
    – il tema non è ancora stato aggiornato per supportare WP 5.8. Trattandosi di tema premium, l’ideale è contattare il supporto del produttore.

    – stai usando dei plugin che introducono nuovi widget o modificano quelli esistenti e qualcuno di essi non è ancora stato aggiornato per supportare WP 5.8. In questo caso bisognerebbe individuare questi plugin, disattivarli e vedere se il problema si risolve. A quel punto dovresti riattivarli uno alla volta per identificare quello che genera il problema.

    In ogni caso, prima di qualsiasi attività fai un backup completo.
    A proposito, hai un backup precedente all’aggiornamento?

    Ciao 🙂

    Chi ha creato la discussione Vincenzo

    (@vingajewels)

    Andrea,innanzitutto grazie della risposta comunque andranno le cose.
    Per essere più preciso posso dire di aver fatto un backup manualmente dopo avere verificato che sul mio hosting già ci fosse quello giornaliero,
    Se può essere d’aiuto questo è il dettaglio dell’errore mandatomi in automatico da WP, seguono 9 link di pagine non trovate che non so se posson pubblicare
    Dettagli dell’errore
    ====================
    Un errore di E_ERROR è stato causato nella linea 24 del file.
    Ho la certezza di non avere scaricato nessun altro plugin e non averne utilizzati se non quelli in uso e dopo averne verificato la compatibilità a detta degli sviluppatori dei plugin aggiornati.
    Cercherò di fare le verifiche suggeritemi e se posso farò sapere i risultati, cordialmente,Vincenzo

    Chi ha creato la discussione Vincenzo

    (@vingajewels)

    salve Andrea,ho provato a pulire la cache plugin andando nel ftp ma non ho trovato la cartella cache (percorso public html-wpcontent-plugins)
    l’unico plugin non aggiornato perchè non vi è certezza di funzionamento è woocommerce ed ho ricevuto ieri una mail che stavolta mi porta ad un link del footer che è composto con codici html.
    qui però i numeri di telefono sostituiti portano ad un vecchio numero e non so il perchè
    il testo recita:In questo caso, WordPress ha incontrato un errore con uno dei tuoi plugin, WooCommerce.
    mi chiedo quindi se devo attendere aggiornamento woocommerce per la mia versione wp 5.8
    e se posso sostituire i codici html con dei blocchi.
    chiedo scusa per le domande che magari non siano pertinenti,ma sono qui anche per imparare e magari essere indirizzato,cordiali saluti Vincenzo

    Chi ha creato la discussione Vincenzo

    (@vingajewels)

    salve, volevo informarvi che non ricevo più messaggi di errore da wordpress,ho però modificato,nei codici html del footer in questione,i link whatsapp come suggeritomi da un amico e ritengo almeno per il momento risolto la questione,se dovesse ripresentarsi qualche problema ne rifarò menzione data la vs disponibilità,grazie e cari saluti,Vincenzo

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.