Supporto » Varie ed eventuali » FILE ROBOTS NON FA VEDERE SITO SU GOOGLE

  • laGio

    (@lauragioia)


    Ciao finalmente il grande giorno è arrivato, ho pubblicato il sito …ma che succede in google? esce fuori questo messaggio
    “Una descrizione per questo risultato non è disponibile a causa del file robots.txt di questo sito”

    quindi volevo risolvere questo problema e gia che ci sono in effetti non so come indicizzare in modo insomma che google inizi a proporre mio sito e miei articoli.. :/

Stai vedendo 15 repliche - dal 1 al 15 (di 18 totali)
  • Gloria Liuni

    (@glorialchemica)

    Ciao @lauragioia,
    sotto IMPOSTAZIONI > LETTURA al fondo della pagina c’è una voce “Visibilità ai motori di ricerca”
    Se è flaggata vengono scoraggiati i motori di ricerca.
    Hai controllato questa voce?

    laGio

    (@lauragioia)

    ciao gloria
    in realtà non è flaggata ….

    Gloria Liuni

    (@glorialchemica)

    A questo punto puoi provare a installare un plugin che genera una sitemap (che piace ai motori di ricerca); ad esempio questo https://it.wordpress.org/plugins/www-xml-sitemap-generator-org/.

    Il plugin preparerà anche il file robots autorizzando gli accessi ai motori di ricerca.

    laGio

    (@lauragioia)

    non c’è niente che non sia un plugin? ne ho gia installati tanti e vorrei risolvere senza ulteriori plugin in anche per capire perchè fa così :/
    se può aiutare ti dico che ora cercandolo in google mi da tutto nome sito (sottotitolo) e prime righe che spiegano… sul pc no..

    laGio

    (@lauragioia)

    no scusa ma ora il problema sembra sparito anche dal pc..ma è normale?

    laGio

    (@lauragioia)

    e poi scusa mi stavo dimenticando dove si impostano le frasi di preview che google fa vedere associate al sito perchè ora non so se sia un caso ma mi prende proprio quelle di “presentazione” ma essendo anche l’articolo scritto non vorrei che se ne scrivo un altro mi cambia la preview con l’ultimo articolo scritto…grazie

    Gloria Liuni

    (@glorialchemica)

    Nn ho capito il problema

    se può aiutare ti dico che ora cercandolo in google mi da tutto nome sito (sottotitolo) e prime righe che spiegano… sul pc no..

    Per quanto riguarda gli snippets di Google ti consiglio questa lettura: http://www.michaelvittori.it/magazine/cosa-sono-e-servono-rich-snippets/

    Per quanto riguarda il file robots puoi preparare con notepad o similare (non usare word) un file che chiamerai robots.txt con questo codice

    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php

    e lo carichi nella root principale del sito (stesso livello di dove sta il file wp-config.php)

    laGio

    (@lauragioia)

    La parte del messaggio che non avevi capito era perchè per un attimo su google avevo visto sia il nome del sito che una piccola descrizione come poteva andarmi bene, ma ad oggi continua a non esserci .
    Se cerco in google con il mio nome nella ricerca di parole chiave addirittura il mio sito neanche compare se invece vado a cercare nelle parole chiave inserendo anche il dominio (.net) allora compare tra i primi dandomi sempre quel messaggio di errore robot che scusami gloria ma non ho capito niente di quello che mi hai scritto per risolverlo , ti spiace spiegarmelo passo dopo passo? immagino sia appunto un file da cambiare ma non so nenahce che valori inserire.
    Grazie

    Gloria Liuni

    (@glorialchemica)

    Ciao @lauragioia,
    i passaggi te li ho spiegati nella risposta precedente. Non saprei come spiegartelo in altro modo.

    Ricorda che un sito da poco online ha bisogno del suo tempo per posizionarsi nei motori di ricerca (da mesi ad anni)

    Date le tue acerbe conoscenze di SEO e programmazione web, credo che la tua miglior risorsa sia installare YOAST SEO https://it.wordpress.org/plugins/wordpress-seo/, leggere la documentazione https://yoast.com/wordpress-seo/ e consultare il supporto ufficiale https://wordpress.org/support/plugin/wordpress-seo

    laGio

    (@lauragioia)

    ciao Gloria grazie ho installato il plugin che mi hai consigliato e sotto ogni articolo da l anteprima snippet, il problema che ho capito è che se condivido l’articolo su facebook , il post creato quando lo vedo da facebook è perfetto…ha l’immagine, il titolo articolo e una breve descrizione , il problema è quando lo guardi sul cellulare che lo stesso post ha l’immagine piccolissima e solamente il titolo e non si vede minimamente la descrizione…non capisco perchè se sul desktop c’è tutto

    laGio

    (@lauragioia)

    altra info che può esserti d’aiuto a capire il mio problema… oltre che il problema ai post degli articoli che sopra ti ho spiegato…ora ho anche problema quando condivido il link del sito http://www.miosito.it mi mette una serie di immagini da scegliere…quando neanche una settimana fa mi creava il post come volevo: immagine di header sito bella grande, sotto la url “www.miosito.it”.
    A parte il fatto che non ho capito come possa essere cambiato, sta di fatto che nonostante nel plugin che mi hai consigliato indico immagine da usare mi da questo problema, sto impazzendo.
    grazie

    laGio

    (@lauragioia)

    nb attenzione problema della condivisione sito l’ho risolta dovevo solo fare il debug di facebook. Non cambia comunque il solito problema che sul desktop si vede la bella immagine di copertina, la descrizione e il titolo….mentre su cellulare si vede un minuscola miniatura della copertina e solo titolo sito , descirzione sparita …praticamente sul cell il link del sito e degli articoli è inguardabile..non capisco come mai

    laGio

    (@lauragioia)

    ULTIMISSIMA cosa se può aiutare, scusate ma le sto provando tutte ho capito questo:
    LINK DEL SITO
    se copio link su fb da desktop si legge bene (immagine grande, titolo e descrizione) sia su desktop che su cellulare, ma se copio il link su fb da cellulare da quel problema (piccolo e solo titolo)
    LINK ARTICOLO
    sia da desktop che da cell mi da il problema (immaigne miniatura piccola e titolo articolo con sito)
    credo di aver detto tutto spero possiate aiutarmi
    grazie

    Gloria Liuni

    (@glorialchemica)

    Ciao @lauragioia,
    le tue ultime richieste non sono pertinenti al titolo del topic. Questo non permette di far conoscere la tua esigenza agli utenti del forum per poterti aiutare, nè essere di aiuto ad altri utenti col tuo stesso problema. Per cortesia apri un nuovo topic con questa domanda e se quello dei file robots per te è risolto ricordati di segnalarlo.

    laGio

    (@lauragioia)

    scrivo di la
    purtroppo non ho risolto con file robots..perchè non so che dati devo scrivere.

Stai vedendo 15 repliche - dal 1 al 15 (di 18 totali)
  • Il topic ‘FILE ROBOTS NON FA VEDERE SITO SU GOOGLE’ è chiuso a nuove risposte.