Supporto » Fixing WordPress » Font desktop diverso da mobile

  • Risolto danminelli

    (@danminelli)


    Buonasera, ho migrato il mio sito web su un altro hosting e caricato il backup tramite FTP e importato il database .sql.
    Il sito funziona bene, solo che ho un problema: infatti da mobile vedo il font che ho scelto per i testi in maniera esatta, da desktop invece è cose se avessi un font predefinito.
    Premetto che ho precaricato le risorse woff su WP rocket, ma non ho trovato miglioramenti.
    Avete consigli da darmi?
    Il sito in questione: holidayassisi

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 14 risposte - dal 1 al 14 (di 14 totali)
  • Già provato a disattivare eventuali plugin per vedere se la situazione cambia o magari provare con un font diverso?
    Magari qualche minificazione o aggregazione dei css?
    Inoltre proprio il download dell’opensans mi sembra che non vada a buon fine ( https://ibb.co/nsX4YXY )

    • Questa risposta è stata modificata 1 settimana, 1 giorno fa da assistenzasiti.
    • Questa risposta è stata modificata 1 settimana, 1 giorno fa da assistenzasiti.
    Chi ha creato la discussione danminelli

    (@danminelli)

    @assistenzasiti Si ho provato a togliere da wp rocket la fuzione minifica e aggrega del css ma non è cambiato nulla.

    Infatti ho visto che dalla console di chrome ho quel problema, sai come posso risolvere? Perchè la cartella esiste e quei files sono presenti.

    Grazie

    La cartella sicuramente esiste ma il percorso è sbagliato, forse è restituito in maniera errata.
    Giustamente fallisce a scaricare questo
    https://holidayassisi.it/home/customer/www/holidayassisi.it/public_html/wp-content/fonts/open-sans/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsgH1x4gaVQUwaEQXjM.woff

    perchè il percorso esatto dovrebbe essere il seguente:

    https://holidayassisi.it/wp-content/fonts/open-sans/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsgH1x4gaVQUwaEQXjM.woff

    • Questa risposta è stata modificata 1 settimana, 1 giorno fa da assistenzasiti.
    Chi ha creato la discussione danminelli

    (@danminelli)

    @assistenzasiti Sai dove devo modificare il percorso, in quale file nello specifico?
    Che in style.css non ho nulla che utilizzo elementor come page builder.

    grazie

    Nella demo del template originale vedo che il percorso è ok,
    non posso sapere così su due piedi dove potrebbe esser stato inserito il percorso errato.

    Chi ha creato la discussione danminelli

    (@danminelli)

    @assistenzasiti Non c’è un modo, un plugin o altro per capire dove è il problema?

    Ho contattato l’assistenza dell’ hosting e mi hanno detto le 3 richieste 404 vanno a richiamare un percorso che non esiste sul nuovo hosting, ma che forse esisteva sul vecchio provider.
    Dovrei modificare tale richiamo facendolo partire dalla public_html/………. , ma non so dove..

    Grazie

    Mi sembra strano, quel link non dovrebbe essere restituito così quindi mi sembra strano che esistesse sul vecchio hosting, poi non so se effettivamente è stato modificato qualcosa. Non conosco il tema e la storia del sito, senza metterci mano non riesco a dirti di più, mi spiace davvero.

    Pensandoci potresti avere inserito queste customizzazioni nel css aggiuntivo del tema, controlla in aspetto/personalizza/css aggiuntivo
    Magari aggiusta il path da lì.

    Ciao @danminelli,

    ho avuto un problema simile in altre occasioni usando Elementor.
    Quando aggrega i suoi CSS utilizza talvolta dei percorsi relativi alle cartelle sul server e non all’indirizzo pubblico del sito.

    Puoi provare a fare rigenerare i CSS ad Elementor seguendo questo percorso: menu amministrativo di WP -> Elementor -> Strumenti -> click sul pulsante “Regenerate Files & Data”. In questo modo eventuali percorsi vengono aggiornati alla situazione corrente.

    Per precauzione, fai prima un backup del sito.

    Facci sapere come va.
    Ciao!

    Chi ha creato la discussione danminelli

    (@danminelli)

    @andreaporotti Purtroppo nessun cambiamento, la cosa strana è che da safari desktop il font è giusto, mentre da Chrome no.

    Andrea Porotti

    (@andreaporotti)

    Ho dato un’occhiata più approfondita al sito, gli indirizzi errati si trovano all’interno di codice CSS inline presente nel tag HEAD della pagina.

    In particolare, si trovano all’interno di questo tag:

    
    <style id="kirki-inline-styles">
    ...
    </style>
    

    Ho fatto una ricerca e sembra che “kirki” sia un framework indirizzato agli sviluppatori di temi. Qui il sito ufficiale: https://kirki.org/

    Sembra quindi che il problema sia il CSS generato da questo framework o dal tema.

    Non saprei darti una soluzione precisa, ma posso suggerirti:
    – verifica se questo Kirki appare tra i plugin installati. Se si, controlla se mette a disposizione una funzionalità per rigenerare il CSS.
    – verifica in tutte le impostazioni del tema se è presente una funzionalità per rigenerare il CSS.

    Dalla prova che hai fatto e da ciò che vedo, mi sentirei di escludere Elementor.

    Spero di essere stato d’aiuto.
    Aggiornaci.

    assistenzasiti

    (@assistenzasiti)

    @danminelli fai queste due prove ma prima fai un backup di files e database:

    1. vai in wp-content/fonts/ e rinomina i font che trovi, magari sarà costretto a scaricarli nuovamente

    2. se non funziona la prima opzione potresti dover operare sul db. Nella tabella “wp_options cerca” “kirki_downloaded_font_files”, cancella il valore e vedi se si risolve.

    Ripeto: fai prima un backup.

    Se non dovessi risolvere così considera l’idea di contattare un esperto di cui ti fidi ed a cui potresti affidare le credenziali di tutto per dare un’occhiata.

    Chi ha creato la discussione danminelli

    (@danminelli)

    @assistenzasiti Sembrerebbe aver funzionato con il primo metodo! Ho rinominato i files, li ha riscaricati e poi ho cancellato quelli vecchi!.

    Grazie Mille!

    assistenzasiti

    (@assistenzasiti)

    Di nulla 🙂

Stai visualizzando 14 risposte - dal 1 al 14 (di 14 totali)
  • Devi essere collegato per rispondere a questo topic.