Supporto » Installazione e Aggiornamento » Funzioni Backend disattivate

  • Risolto Cobra

    (@cobraarbok)


    Non riesco a diagnosticare il problema sebbene abbia seguito tutti i suggerimenti (o almeno credo).

    Trovandomi il blog appena installato privo di diverse funzionalità…

    • Cancello tutto e reinstallo da zero
    • Inserisco un plugin e controllo subito l’editor visuale e la disponibilità dei pulsanti per gli shortcodes
    • Ripeto il passaggio per ogni singolo plugin attivato

    Faccio il logout senza alcun problema. Faccio il login due ore dopo e non c’è più l’editor visuale ed anche disattivando tutti i plugin non cambia nulla.

    WP: 4.7.2 (scaricato ancora oggi)
    Tema: Twenty Seventeen
    MySQL Versione : 5.5.54
    Versione PHP : 7.0.15
    PHP Memoria in uso: 23.17 MB
    Limite di memoria PHP : 256M

    I problemi che ho riscontrato sono la scomparsa delle icone sulla barra di amministrazione o nei pulsanti sopra l’editor; oppure sono i pulsanti stessi ad essere inattivi o ancora sparisce completamente l’editor.
    A volte sono funzionalità proprie del plugin a mancare.

    Inizialmente ho dato la colpa alla compatibilità, vuoi con il php, con la versione di WP o non so più che altro.
    Però, come dicevo, cancellando tutto e reinstallando i plugin uno alla volta tutto sembra funzionare; ma solo fino al primo login.

    Questo su Win o Linux, Firefox e Chrome, in modalità normale oppure incognito, anche con cache azzerata.

    A questo punto mi chiedo se non sia un problema di hosting (1and1 Unlimited Pro), sebbene mi sembri strano.

    Grazie per i consigli.

Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • Ciao,

    Posso provare a fare un po’ di debug ma ho bisogno:
    – screenshot di cosa vedi
    – screenshot della console js del browser
    – elenco plugin e temi installati / attivi

    hai già provato a creare lo stesso ambiente in locale?

    Cobra

    (@cobraarbok)

    Ma è proprio questo il punto, è tutto molto “random” ed in questo momento non c’è attivato neppure un plugin e a meno di pensare che sia rimasto attivo qualcosa di spurio non vedo una ragione perché sia sparito l’editor.
    Lo screenshot ti riporterebbe solo “Modifica Articolo: Ciao Mondo”, il permalink, il pulsante “Aggiungi media”, la barra dei pulsanti che vediamo anche in questo editor, del forum, più quello di “scrittura senza distrazioni”, fine!
    Nella console JS c’è soltanto una riga:
    “JQMigrate: Migrate is installed, version 1.4.1” con in fondo a destra “load-script.php: 9:542”

    Provo a ricreare la situazione con la problematica maggiore, ma sarei curioso di sapere se l’hosting potrebbe influenzare la situazione perché in questo caso chiedo di anticipare la migrazione ad un ambiente Cloud VPS.
    Semmai ti serva comunque questo è l’elenco dei plugin che attivati funzionavano senza problemi, fino al successivo login.

    Per il momento ti ringrazio della risposta.

    Akismet 3.2
    All In One WP Security 4.2.5
    Authors Widget 2.4.5
    Breadcrumb NavXT 5.6.0
    Contact Form 7 4.6.1
    Flamingo 1.5
    Hide “Comments are closed” 1.0
    Italy Cookie Choices (for EU Cookie Law) 2.5.1
    Jetpack by WordPress.com 4.6
    Magee Shortcodes 1.6.0
    Read More Without Refresh 2.3
    Shortcodes In Use 1.2.1
    Shortcodes Ultimate 4.9.9
    W3 Total Cache 0.9.5.2
    Yoast SEO 4.3
    WP Super Edit 2.5.3

    • Questa risposta è stata modificata 2 anni, 7 mesi fa da  Cobra.

    OK, puoi anche provare ad aprire un ticket presso il tuo provider e vedere cosa ti rispondono…

    Cobra

    (@cobraarbok)

    Notizia dell’ultimo minuto, adesso funziona tutto.
    Quindi sono proprio portato a pensare che ci sia un qualche filtro JS da qualche parte.
    A capire quale sia e quando intervenga a questo punto è essenziale perché se no si perde tempo e basta in debug inutili.

    Provando sullo stesso PC, ma in due Sistemi Operativi diversi, con due Browser differenti, con o senza modalità “in incognito” resta da pensare che sia o nella “rete” (Vodafone) o sul provider.

    • Questa risposta è stata modificata 2 anni, 7 mesi fa da  Cobra.
    • Questa risposta è stata modificata 2 anni, 7 mesi fa da  Cobra.
Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • Il topic ‘Funzioni Backend disattivate’ è chiuso a nuove risposte.