Supporto » Installazione e Aggiornamento » HTTP Error 500 – Imagick

  • federico

    (@federicogb25)


    Salve a tutti. E’ già la seconda volta che provo a reinstallare WordPress per questo problema insensato:

    Vengo subito al dunque: Poco fa ho installato l’estensione PHP “Imagick”. WordPress mi richiedeva di reinstallarlo per performance più elevate. Una volta installato, il sito ha iniziato ad essere inaccessibile causa HTTP ERROR 500.

    Controllando i log del server, non danno nessun errore. Ho provato a disinstallare l’estensione, ma il sito continua a non funzionare.

    Utilizzo un server Debian 10 + Nginx e la versione di php è 7.4.4.

    C’è un modo per risolvere?
    Grazie e buona giornata.

    Federico.

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve Federico,

    Imagick is recommended as it provides extra functionality, but it’s not required.

    tratto da questo scambio sul forum internazionale:
    https://wordpress.org/support/topic/php-imagick-module-not-installed-or-disabled-message/

    in cui sembra anche abbiano trovato una soluzione

    Aggiornaci

    federico

    (@federicogb25)

    Ciao @cristianozanca e grazie per la tempestiva risposta,

    ho provato a seguire la procedura descritta nella soluzione del thread menzionato, ma non ho ancora risolto. Ho provato ad abilitare l’estensione riavviando i dovuti processi, ma questo non sembra funzionare…

    federico

    (@federicogb25)

    Riguardando gli errrori del server, mi sono accorto che solo adesso sono spuntati questi errori:
    2020/04/21 16:31:27 [error] 29434#29434: *12 FastCGI sent in stderr: "PHP message: PHP Warning: require_once(/var/www/html/dominio.eu/wp-config.php): failed to open stream: Permission denied in /var/www/html/dominio.eu/wp-load.php on line 37PHP message: PHP Fatal error: require_once(): Failed opening required '/var/www/html/dominio.eu/wp-config.php' (include_path='.:/usr/share/php') in /var/www/html/dominio.eu/wp-load.php on line 37" while reading response header from upstream, client: 141.101.77.45, server: dominio.eu, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.4-fpm.sock:", host: "dominio.eu"

    • Questa risposta è stata modificata 6 mesi fa da federico.
    • Questa risposta è stata modificata 6 mesi fa da federico.
    • Questa risposta è stata modificata 6 mesi fa da federico.
    federico

    (@federicogb25)

    Risolto impostando la memory_limit di php a -1 in php.ini

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Il topic ‘HTTP Error 500 – Imagick’ è chiuso a nuove risposte.