Supporto » Sviluppare con WordPress » Immagini WordPress non allineate con il testo tipo “emoji”

  • Risolto internetto

    (@internetto)


    Salve a tutti gli utilizzatori di WordPress.Org,
    PREMESSA: questo è il mio primo post nel blog e, anche se sono circa 2 anni che gestisco un paio di siti web, vi scrivo perché non sono mai riuscito a risolvere questa problematica e richiedo l’aiuto di persone più esperte di me. Ringrazio tutti ed espongo subito il problema:

    – Nella normale pubblicazione di immagini su WordPress (ho installato il CMS WordPress sul mio server dalla nascita del sito), “mi si sfasa sempre l’allineamento delle immagini” se ridimensiono le immagini che carico sul sito. Mi spiego meglio: se voglio caricare una immagine e “renderla piccola come il testo” (delle stesse dimensioni), durante l’editor l’inserimento è normale e l’immagine è allineata al testo come si può vedere qui (in questo caso il testo è a 12 px e l’immagine è 12×12, ma le dimensioni non ribaltano il risultato):

    https://www.internetto.it/wp-content/uploads/2020/01/Le-immagini-si-sfasano-su-Wordpress-1.jpg

    TUTTAVIA l’immagine viene “spostata” un po’ in alto non appena pubblico (o aggiorno) il post, come si può vedere qui:

    https://www.internetto.it/wp-content/uploads/2020/01/Le-immagini-si-sfasano-su-WordPress-2.jpg

    Come è possibile? Ho pensato che forse WordPress lascia in automatico uno spazio per la didascalia, ma non avrebbe senso… Inoltre sono stato costretto a disattivare Gutember e uso TinyMCE Advanced come plugin per la scrittura.

    Il post è il seguente (anche se questo “bug” mi succede su qualsiasi pagina):

    https://www.internetto.it/come-convertire-gratuitamente-file-avi-in-mpeg-4-con-macos/

    Grazie ancora! Spero di risolvere quanto prima…
    Buona giornata 🙂

    P.S. Specifico che non voglio pubblicare questo tipo di immagini “come cornice al testo” o “intorno” al testo o “immagini con didascalia”. Quello lo so fare e ho fatto tutti i tentativi del caso. Vorrei semplicemente usare delle immagini JPEG (che carico io) “come emoji”, cioè inserendole quadrate (ad esempio 12×12) per usare come vere e proprie parole allineate con il testo, nella stessa linea in basso ______.

    P.P.S. Riposto il link del codice dell’immagine di cui sopra:
    https://www.internetto.it/wp-content/uploads/2020/01/Le-immagini-si-sfasano-su-WordPress-3.jpg

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve internetto,

    nel file https://www.internetto.it/wp-content/themes/dt-the7/css/main.min.css?ver=8.1.0

    alla riga 6984 c’è questa istruzione che è parzialmente commentata

    .alignnone {
     /*! float:none; */margin:0 auto 10px;
    }

    se si commenta e rimuove anche la parte successiva, l’icona si allinea correttamente

    .alignnone {
     /*! float:none; margin:0 auto 10px;*/
    }

    Però con questa azione NON si risolve il fatto che al primo aggiornamento del tema la modifica salta

    Quindi il consiglio è di impostare quell’istruzione CSS in un child Theme oppure nei custom CSS dal backend

    Il consiglio è anche di testare se con quella modifica funziona tutto bene anche nel resto del sito

    Aggiornaci

    Non c’è un plugin in grado di riportare la situazione alla normalità? Preferirei non toccare i CSS del backend.

    Ad ogni modo, sa per caso spiegarmi “in parole povere” il problema?

    Uso The7 come tema, ma smanettando nelle impostazioni non ho trovato nessuna impostazione dedicata all’allineamento immagini.

    Grazie!

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve internetto,

    Se stai usando un tema o un plugin a pagamento e hai bisogno di aiuto ti suggeriamo di visitare i canali di supporto ufficiali del prodotto.

    http://tiny.cc/otasiz

    Al fine di essere una buona guida della comunità di WordPress e incoraggiare innovazione e crescita, crediamo sia importante indirizzare le persone verso i canali ufficiali di supporto 🙂

    Noi non abbiamo accesso ai prodotti a pagamento, quindi non possiamo sapere perché il tuo tema o plugin non stanno funzionando correttamente, questa è la ragione per cui ti stiamo reindirizzando verso i canali ufficiali del venditore, il quale è l’unico responsabile del funzionamento del proprio prodotto.

    La domanda resterà aperta a chiunque abbia già risolto lo stesso problema e riesca ad essere d’aiuto

    Ecco un chiarimento su le policy del forum: https://it.wordpress.org/support/lineeguida/#non-pubblicare-informazioni-su-prodotti-commerciali

    Buon pomeriggio,
    avevo supporto fosse un problema del mio tema, ed in effetti credo sia così, ma sono riuscito lo stesso a trovare una (brutta) soluzione “macchinosamente”:

    Dal codice dell’immagine, ho semplicemente tolto “alignnone” dal codice testuale dell’immagine ed ho aggiornato; l’allineamento (che ho scoperto essere rialzato di 10 px e non so il perché) è tornato normale.
    Il procedimento è macchinoso, ma almeno risolvibile…

    Purtroppo l’assistenza è a pagamento dopo 365 giorni, quindi dovrò continuare a procedere così, oppure aspettare qualcuno che qui conosca The7 meglio di me…

    Grazie comunque di tutto e buona giornata

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.