Supporto » Fixing WordPress » Impossibile caricare immagini

  • Risolto orsocapo

    (@orsocapo)


    Buongiorno, da quando sono migrato su https non riesco a caricare le immagini nella libreria media.
    Ho provato a disattivare i plugin ma niente.

Stai vedendo 8 repliche - dal 1 al 8 (di 8 totali)
  • Ciao @orsocapo,
    sei sicuro che i permessi alla cartella siano gli stessi e che il processo di sostituzione delle URL per utilizzare il nuovo certificato SSL sia andato a buon fine?

    Le due cose forse non sono correlate ma è sempre bene controllare.

    Inoltre proverei a mettermi in contatto con il proprio hosting e vedere se hanno dei problemi loro dovuto al nuovo certificato.

    Altrimenti prova ad arricchire la tua richiesta perché abbiamo pochi dati sui quali lavorare.

    Per esempio, se ricevi come errore HTTP error è probabile anche che tu debba lavorare sul file .htaccess per assicurarti che le regole impostate siano corrette anche dopo la modifica.

    Ultimo consiglio, anche se hai già provato a disattivare i plugin, lo hai fatto anche con il tema? Anche se credo che il tuo problema principale sia con la configurazione del server web è sempre un test che puoi fare per vedere se riesci a risolvere 😉

    Attendiamo maggiori dettagli per essere in grado di aiutarti ulteriormente. A presto,
    Andrea

    Ciao Andrea, grazie per la risposta.
    I permessi sono tutti 0755.
    Il problema me lo da anche se ad esempio cerco dei plugin da aggiungi nuovo plugin.
    Non mi da nessun codice di errore. Continua all’infinito con la rotella sul fondo grigio del backend.
    Con il tema non ho provato. Farò anche questa prova dopo pranzo.
    Il mio tema è comunque “Calluna” di themeforest.
    Per il passaggio a https ho utilizzato il plugin really simple ssl.

    Il mio .htaccess è il seguente:
    http://codepad.org/5YqzxuCx

    Grazie mille per il tuo supporto

    Ma se cambio il tema e metto per esempio twentyten incide sulla gestione del backend? E soprattutto, rimettendo calluna torna tutto come prima?

    domanda stupoida, hai cambiato anche site url e home nella tabella wp_options nel database aggiungendo https ? prima di cambiare tema fai sempre backup del database.

    ciao ciao

    orsocapo

    (@orsocapo)

    Buongiorno,
    nella tabella wp_options apro la colonna option_name e l’unico url che vedo è su category_base: risulta con https
    Stessa cosa su otpion_value
    Cliccando su Mostra in option_name non compare nessuna voce siteurl
    Grazie per il supporto

    Moderatore Andrea Barghigiani

    (@pr0v4)

    Ciao @orsocapo e intanto perdonami se non ti ho più risposto.

    La prima cosa che mi viene da dire è che il tuo file .htaccess è molto complicato e inoltre hai delle regole che impostano la cache del browser ripetute con valori differenti.

    Oltre a questo noto molte voci che ti consiglierei di togliere, potresti ripartire con un .htaccess di questo tipo ma fai sempre un backup di quello precedente che nel caso in cui dovesse esserci qualche problema puoi sempre sostituirlo nuovamente.

    Scusa se mi ripeto ma mi raccomando, non sostituire il tuo .htaccess senza fare prima un backup.

    È probabile che tu abbia qualche plugin per la cache malconfigurato e questo crea problemi nel caricamento dei nuovi file. Se tutto è dovuto al file .htaccess non avrai alcun beneficio disattivando e attivando tema/plugin.

    Se però il test con il nuovo .htaccess non dovesse risolvere il problema il consiglio diventa nuovamente disattivare uno alla volta tema e plugin e fare dei test per scoprire se il problema è causato da uno di questi.

    Rispondendo alla tua domanda “se cambio tema/plugin e il problema si risolve che faccio?” hai due strade da percorrere:

    1. resti con il tema/plugin disattivato e cerchi di tornare a lavorare con il tuo sito web sfruttando strumenti diversi
    2. chiami uno sviluppatore che ti possa risolvere questo problema.

    Purtroppo quando si parla di problemi non sempre è possibile risolvere da soli, per questo motivo esistono meccanici, idraulici, dentisti e anche sviluppatori 😉

    In bocca al lupo e tienici aggiornati su come stanno andando le cose, sarebbe veramente bello riuscire a mettere la flag Risolto in questa discussione.

    In bocca al lupo e a presto,
    Andrea

    orsocapo

    (@orsocapo)

    Buongiorno Andrea, grazie infinite per le tue gentilissime e utili indicazioni.
    Ho modificato il file .htaccess ed è successo questo ma forse devo aspettare ancora un po’ e vedere se torna di nuovo il sito:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at postmaster@lacanforabnb.com to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.

    orsocapo

    (@orsocapo)

    Ho capito il problema. Se apro da ftp il file .htaccess mi apre in realtà un file .htaccess2 blocco note
    ho ricarticato il file vecchio e ora è tornato visibile il sito.
    Dimenticavo: sulla riflessione circa il chiamare uno sviluppatore sottoscrivo. Hai perfettamente ragione 🙂

    • Questa risposta è stata modificata 1 mese fa da orsocapo.
Stai vedendo 8 repliche - dal 1 al 8 (di 8 totali)
  • Devi essere collegato per rispondere a questo topic.