Supporto » Funzionalità = Plugin » Impossibile installare / aggiornare plugin da backend

  • Risolto crispiatico

    (@crispiatico)


    Ciao
    ho preso in gestione il sito https://natura-lycosmetics.com

    Entro con un account che ha privilegi come amministratore

    ho notato che
    1) non posso aggiornare in automatico WP all’ultima versione
    2) nella pagina /wp-admin/plugins.php non posso aggiornare i plugin presenti
    3) non posso installare nuovi pluglin. Su altri siti che ho posso andare alla pagina /wp-admin/plugin-install.php e installare nuovi plugin.
    Qui se vado alla pagina
    https://natura-lycosmetics.com/wp-admin/plugin-install.php
    Ho il messaggio di errore
    “Non hai il permesso di accedere a questa pagina.”

    Come posso fare ?

    Grazie a tutti

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Ciao @crispiatico,

    se hai i permessi per farlo, prova a creare un nuovo utente amministratore e verifica se ha lo stesso problema.

    In alternativa controlla nel wp-config.php che non ci sia qualche configurazione “particolare” che disabilita anche gli aggiornamenti manuali (in genere da lì si disattivano quelli automatici).

    Altro dubbio: il sito si trova su un hosting “gestito”, uno di quelli in cui gli aggiornamenti sono controllati dal provider? Potresti verificare nella lista dei plugin se ne trovi uno realizzato dallo stesso fornitore dell’hosting.

    Facci sapere se scopri qualcosa.
    Ciao!

    Chi ha creato la discussione crispiatico

    (@crispiatico)

    Grazie Andrea per la risposta.

    Ho confrontato i file di questo sito con quelli di un altro in cui non ho i problemi descritti
    – wp-settings.php
    – wp-config.php
    A parte le impostazioni “locali” non ho trovato qualcosa che possa impedire gli aggiornamenti.

    in entrambi i siti gli utenti sono amministratori e hanno nella tabella
    xxx_usermeta
    wp_user_level = 10

    Anche nella tabella xxx_options non vedo anomalie

    Ho fatto un check dei plugin ma non ho riscontrato app anomale …

    Proseguo nelle mie indagini

    Grazie

    Chi ha creato la discussione crispiatico

    (@crispiatico)

    [RISOLTO]

    Nel file wp-config.php erano presenti in coda le istruzioni

    define('DISALLOW_FILE_EDIT', true);
    define('DISALLOW_FILE_MODS', true);

    Ho cambiato le impostazioni in

    define('DISALLOW_FILE_EDIT', false);
    define('DISALLOW_FILE_MODS', false);

    ed ora tutto funziona correttamente.

    Spero sia di aiuto ad altri 🙂

    Ciao @crispiatico,

    ottima notizia e grazie per aver condiviso la soluzione.

    La riga
    define( 'DISALLOW_FILE_EDIT', true );
    disabilita l’editor dei file di temi e plugin presente nella dashboard (sotto la voce Strumenti o Aspetto, in base al tipo di tema attivo).
    Io di solito la lascio impostata a “true” come misura di sicurezza e non interferisce con gli aggiornamenti.

    Ciao!

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.