Supporto » Varie ed eventuali » indirizzare correttamente un’immagine

  • Buonasera,
    mi sono reso conto che se allego un’immagine a una pagina o a un articolo, Google la indicizza in modo tale che se si clicca su di essa non si viene inviati alla pagina o all’articolo in cui è inclusa, ma a una pagina a sé stante contenente soltanto l’immagine stessa, tipo http://www.miosito/titoloarticolo/4508g.
    Come posso ovviare al problema?
    Grazie

Stai visualizzando 10 risposte - dal 16 al 25 (di 25 totali)
  • Ho cliccato sulla foto di Cartier-Bresson e si è aperta una pagina con altre sue foto.
    Se quello è il contesto nel quale hai inserito a suo tempo quella foto, direi che si, è così che vorrei.

    Ed è così che diventerà il tuo sito, dai tempo a Google…

    Questo è il codice che ha creato WP quando ho inserito l’immagine nella pagina

    <div class="wp-block-image"><figure class="aligncenter is-resized"><img src="https://albertifoto.altervista.org/wp-content/uploads/hcb29-400x348.jpg" alt="Immagini di Henri Cartier-Bresson" class="wp-image-2618" width="300" height="261"/></figure></div>

    ti ringrazio ma penso che ci sia un altro problema, dato che l’evento che mi ha fatto accorgere della cosa è accaduto da pochi giorni, ma riguarda la foto di un articolo pubblicato ormai tre anni fa.

    • Questa risposta è stata modificata 3 mesi, 1 settimana fa da clack.

    Può darsi che tu quella foto c’è l’hai ancora nel server. Guarda nella cartella uploads è li che ci sono le immagini.
    Google non trova quello che non c’è.

    Certo che c’è, fa parte di un articolo tuttora in linea.

    Scusa ma, allora non ho ancora capito cosa vuoi ottenere.
    Posta il link e spiega…

    Scusa ma sono due giorni che mi sto sgolando e la sto mettendo in tutti i modi possibili.

    Partiamo dal presupposto che se pubblico una foto è esclusivamente perché è a corredo di un articolo. Ossia di un testo scritto, leggibile andando su un indirizzo come http://www.miosito/mele-golden.
    Pertanto a me interessa che si legga l’articolo.
    Di conseguenza desidero che nel momento in cui la foto pubblicata sul mio sito a corredo dell’articolo che parla di mele golden compare in una ricerca di Google, il link visualizzato dal motore di ricerca non conduca a una pagina vuota, tranne che per la foto stessa, ma alla pagina contenente l’articolo di cui quella foto fa parte.

    Cosa che peraltro mi sembra avvenga per tutte le foto che ho trovato su Google

    Spero di essere stato chiaro almeno questa volta.

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve @clack,

    Il consiglio è di seguire la scelta del plugin Yoast che non fa più il redirect dall’immagine sulla pagina dalla versione 7.0, reindirizza all’immagine stessa per i motivi illustrati qui:

    Redirect attachment URLs to a post or page

    Versions earlier than Yoast SEO 7.0 offered the option to redirect to a post or page. This method, however, was not always reliable and caused a lot of issues, especially when an image was added to multiple parts of your site. Therefore, the option was updated to redirect to the actual image.

    tratto da https://yoast.com/help/redirect-image-attachment-urls/

    Ciao Cristiano, grazie dell’intervento.
    Come plugin SEO utilizzo AIOSEO, col quale mi sono trovato bene per vari motivi.
    Sai per caso se anche con questo è possibile ottenere il risultato che desidero?
    Grazie.

    Edit:
    comunque anche questa scelta di wordpress che per ogni immagine crea una pagina a sé stante non mi sembra una trovata così brillante, oltre a consumare spazio e banda inutilmente.
    Ma forse sono troppo ignorante in materia per comprenderne le motivazioni.

    • Questa risposta è stata modificata 3 mesi, 1 settimana fa da clack.
    • Questa risposta è stata modificata 3 mesi, 1 settimana fa da clack.

    @clack
    Come hai potuto vedere con il mio sito è così che funziona con Google e non uso plugin, non capisco perché con te non dovrebbe funzionare.

Stai visualizzando 10 risposte - dal 16 al 25 (di 25 totali)
  • Devi essere collegato per rispondere a questo topic.