Supporto » Funzionalità = Plugin » Installare Traduzione Incompleta Plugin

  • Salve,
    come da titolo, sto tentando di installare una traduzione incompleta a cui ho anche contribuito, il plugin è Ultimate Member..
    Ho scaricato la versione incompleta in formato .po ed ho provato sia ad inserire il file .po con finale it_IT, sia a sostituirlo con il file con finale en_US..
    In tutti e due i casi, la traduzione non è avvenuta.. Ho svuotato la cache del mio browser e volevo svuotare anche quella di WordPress ma a quanto pare non è tra le funzioni di default..
    Dove potrebbe essere il problema?

Stai vedendo 2 repliche - dal 1 al 2 (di 2 totali)
  • tizz

    (@tizz)

    Il fatto che la traduzione sia incompleta è ininfluente. È necessario invece considerare che:
    – i file .po e .mo devono sempre stare insieme, quindi il solo file .po non funziona
    – .po e .mo sono estensioni, e le estensioni per loro natura vanno sempre alla fine, non all’inizio – quindi non è it_IT a stare in finale, ma .po e .mo.
    La dicitura base è it_IT.mo e it_IT.po – a meno che non sia richiesta una dicitura particolare dal plugin o tema stesso (leggi le loro istruzioni per la traduzione, soprattutto per quanto riguarda dove mettere i file), ma si usa sempre la stessa struttura: tipo-nome-del-plugin-o-tema-it_IT.po e stessa cosa per .mo.

    P.S.: WordPress non ha una cache.

    LuigiMdg

    (@luigimdg)

    Si vabbè, era sottointeso che l’it_IT stava alla fine, ma non dopo l’estensione..
    Grazie per la delucidazione riguardo all’accoppiata .mo .po comunque.. 🙂

Stai vedendo 2 repliche - dal 1 al 2 (di 2 totali)
  • Il topic ‘Installare Traduzione Incompleta Plugin’ è chiuso a nuove risposte.