Supporto » Installazione e Aggiornamento » Installazione in locale

  • Risolto arcamio

    (@arcamio)


    Buongiorno, ho il seguente problema con l’installazione in locale del sito, queste le operazioni effettuate:
    A- installato XAMPP
    B- Effettuato il backup del dbase
    C- Effettuato la modifica dei puntatori/line sul file *.zip
    D- Effettuato l’import del db in locale senza nessun problema
    E- effettuato il download di tutti i file del sito tramite Filizilla
    F- modificato il file wp-config.php inserendo il nome del db user e psw

    Questi i problemi che riscontro: (sia utilizzando browser Crome-Firefox-explore)

    1- Il sito parte, ma non si vedono le immagini nella home
    2- cliccando su qualsiasi pagina secondaria del menu ho il seguente errore:
    oggetto non trovato!

    L’URL richiesto non esiste su questo server. Il link della pagina da cui sei arrivato potrebbe essere errato o non essere più valido. Per favore, informa dell’errore l’autore della pagina.

    Se pensi che questo sia un errore del server, per favore contatta il webmaster.

    Error 404

    localhost
    Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/7.0.9

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Moderatore Guido Scialfa

    (@wido)

    Ciao @arcamio,

    Se hai effettuato una importazione del db e modificato le stringhe manualmente il problema potrebbe essere proprio quello.

    Molte informazioni sono salvate in modo serializzato questo significa che hai dei dati aggiuntivi per effettuarne la deserializzazione che include il numero di caratteri del dato.

    Modificando quindi il dato hai creato delle problematiche.

    Consiglio è quello di usare il plugin https://wordpress.org/plugins/wp-migrate-db/ molto intuitivo e fa il lavoro del replace delle stringhe per conto tuo, oppure usa https://interconnectit.com/products/search-and-replace-for-wordpress-databases/ che ti permette di farlo in locale con tutta calma comprensivo di eventuali testing.

    Facci sapere se questo risolve il problema.

    Grazie per l’informazione, ho installato il plug-in e eseguito la procedura di migrazione, ma quando poi importo il db il locale, mi fa vedere qualche immagine, ma rimane il problema del link sulle pagine interne, inoltre mi da il seguente errore..
    Warning: Declaration of DropDownField::getInput($name, $joiner, $fieldName = NULL) should be compatible with Field::getInput($name) in C:\xampp\htdocs\velletrincamperlocale\wp-content\plugins\wp-custom-fields-search\extra_search_fields.php on line 473

    Durante la fase di migrazione con il pulg-in, ho modificato i paramentri come segue:

    //www.velletrincamper.it >>>>> velletrincamperlocale
    /web/htdocs/www.velletrincamper.it/home >>>>> velletrincamperlocale

    Dove “veleltrincamperlocale” è il nome del db in locale… Forse è errata la migrazione

    Grazie

    Moderatore Guido Scialfa

    (@wido)

    Ciao @arcamio,

    L’errore è più un avviso e non blocca il normale flusso della pagina, ad ogni modo per quell’errore devi chiedere allo sviluppatore del plugin incollandogli esattamente il warning.

    È una svista a mio avviso del programmatore.

    Tornando al problema dell’importazione si, hai creato dei path non corretti.

    Il primo dovrebbe essere la url dove si trova il tuo sito, generalmente in locale è tipo //localhost/velletrincamperlocale mentre per il path dei file deve essere quello dove XAMPP va a cercare i files. Ora non so di preciso che sistema operativo usi, su windows è c:\xampp\htdocs.

    Io non uso xampp quindi devi vedere se le url ed i path da impostare sono corretti come te li ho scritti io. Considera che per il secondo deve essere il percorso assoluto.

    Inserendo i path corretti funziona, adesso devo contattare il programmatore del plugin.
    Grazie mille del supporto

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Il topic ‘Installazione in locale’ è chiuso a nuove risposte.