Supporto » Funzionalità = Plugin » La risposta non è una risposta JSON valida

  • Ciao a tutti, ecco il problema:
    Quando creo un nuovo articolo vado a caricare un’immagine dal blocco immagine o galleria, dopo il caricamento mi compare la scritta “La risposta non è una risposta JSON valida” e non mi inserisce l’immagine nel post. Andando a controllare però noto che le immagini sono state correttamente caricate nei media.

    Voi come avete risolto?

    • Questo topic è stato modificato 9 mesi, 3 settimane fa da budicore.
Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Nessun consiglio?

    Ciao @budicore ,
    sembra un errore di quelli davvero esoterici.
    La risposta migliore in questo link:
    https://wordpress.org/support/topic/the-response-is-not-a-valid-json-response-2/

    Consiglia di installare un plugin di controllo e vedere cosa riporta.

    Ciao io ho appena risolto così dopo ore di ricerche e prove.
    Controlla se hai cambiato cambiato l’indirizzo che vorresti dare a wordpress per il tuo sito provose a spiegarmi meglio:

    Vai dalla bacheca in impostazioni del tuo sito…

    se hai esempio
    – Indirizzo WordPress (URL) = [link rimosso per rischio sicurezza]

    – Indirizzo sito (URL) = [link rimosso per rischio sicurezza “detected a potential security threat and did not continue to ##########. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.”]

    Websites prove their identity via certificates. The Browser does not trust this site because it uses a certificate that is not valid for ##########.tk. The certificate is only valid for the following names: *.############.com, ###########.com
    
    Error code: SSL_ERROR_BAD_CERT_DOMAIN
    View Certificate

    Inserisci qui l’indirizzo se vuoi che la tua pagina iniziale sia differente dalla directory di installazione di WordPress.

    a qualsiasi azione otterrai
    Aggiornamento fallito. Messaggio di errore: La risposta non è una risposta JSON valida.

    Io ho ripristinato e così posso lavorare entrambi i cambi per come erano.

    Spero funzioni anche per Te.

    Ciao in bocca al lupo

    Ciao…
    io ho risolto andando a modificare il file web.config (nel mio caso ho l’hosting su windows altrimenti il file di riferimento è .htaccess).

    Nel mio file web.config avevo trovato questo:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <directoryBrowse enabled="false" />
        </system.webServer>
    </configuration>
    

    Invece io l’ho sostituito con questo:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="{R:1}" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>
    

    Spero possa essere utile.
    Ciao
    Massimo

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.