Supporto » Fixing WordPress » LEGGI QUESTO PRIMA di TUTTO WordPress 4.8 Nuove Caratteristiche

  • Moderatore Cristiano Zanca

    (@cristianozanca)


    Evvai! WordPress 4.8 “Evans” è qui! Ma CHE SUCCEDE!? WordPress 4.8 ha creato problemi?

    Niente Panico!

    Prima di andare avanti, assicurati di aver aggiornato i tuoi plugin ed i temi all’ultima versione, cancella i cookies e la cache del browser ed effettua nuovamente il login alla bacheca di WordPress.

    Ancora problemi? Ok, continua a leggere.

    Questo thread contiene i problemi conosciuti con plugins e temi e WordPress 4.8. Per favore leggi l’INTERO ARTICOLO e controllalo regolarmente perché verrà aggiornato.

    Ricorda di stare calmo, sii paziente e rispettoso. I volontari sono qui per aiutarti, ma necessitano del tuo aiuto. Anche qui si applicano le regole del forum.

    In particolare, ti ricordiamo di:

    • usare una capitalizzazione appropriata per i titoli e per il corpo del post. Scrivere usando una formattazione adeguata aiuta a leggere (ad esempio andare a capo, evidenziare le parole,…),
    • inserire una descrizione precisa per il soggetto. “Tutti i permalink non funzionano dalla 4.8” è meglio di un “Ah! Aiutatemi non funziona più niente”
    • descrivere il problema in modo chiaro. Spiega cosa vedi, includendo anche i messaggi di errore ed i link agli screenshot se necessario. Aggiungi il link al tuo sito se il problema è nel front-end
    • essere paziente. Sappiamo che è terribile essere offline, ma pubblicare più volte lo stesso thread non ti fa risolvere il problema più velocemente
    • creare il tuo thread a meno che tu non stia usando la stessa versione di WordPress sullo stesso server dello stesso hosting con gli stessi plugin, temi e configurazione dell’autore originale. Puoi trovare la cosa strana ma è più semplice per noi aiutarti nello specifico se hai il thread apposito
    • segnare il tuo thread come risolto quando il problema è stato risolto
    • Ricorda che non sei solo

    Tieni inoltre a mente che se non ti piace una scelta di design di WordPress non significa che sia un bug. Se non ti piace una funzionalità, non creare una serie di thread a riguardo.

    Controlla se qualcuno ne ha già scritto uno e scrivi lì o considera di far parte del processo di creazione (testando la beta o la versione via SVN). Quello che stai vedendo oggi è il risultato di migliaia di ore di lavoro e test, ed a meno che qualcosa non sia del tutto non funzionante è difficile che venga modificato.

    Infine, prima di postare:

    sii sicuro di aver letto l’intero articolo riguardo alle Nuove Features in WordPress 4.8.

    Vai nella pagina di about example.com/wp-admin/about.php per sapere cosa c’è di nuovo.

    E assicurati di aver provato a…

    • Cancellare la cache per ogni plugin installato, così come quella del server e/o del browser. Non solo il tuo browser ma ogni op cache o contenuto cachato come per esempio Cloudflare. Può risolvere strani problemi con JavaScript.
    • Cancellare la cache dell’hosting. Installazioni WP gestite dall’hosting hanno una speciale cache. Se il tuo host ha tool come “Purge Varnis” o “Flush Memcache”, provali. Puoi chiedere al tuo hosting di effettuare una pulizia della memcache o Varnish al posto tuo se necessario.
    • Problemi con il tuo browser. Il tuo browser può aiutarti ad identificare problemi JavaScript o conflitti e questo articolo (in inglese)  può aiutarti ad effettuare una diagnosi. Questo può aiutare ad identificare problemi con l’editor Visuale.
    • Disattiva tutti i plugin (si, tutti) per vedere se questo risolve il problema. Se questo funziona, riattiva i plugin uno per uno fino a trovare quello che causa la problematica. Se non riesci ad entrare nella bacheca di WordPress, prova reimpostando la directory dei plugin via SFTP/FTP o via PhpMyAdmin (leggi “Come disattivare tutti i plugin quando non puoi loggarti su wp-admin” se necessiti di aiuto). Qualche volta un plugin apparentemente disattivato può causare problemi. Ricorda inoltre di disattivare anche i plugin all’interno della directory mu-plugins. Un modo veloce è rinominare la directory mu-plugins-old.
    • Attiva il tema Twenty Seventeen per escludere ogni problema specifico del tema. Se non puoi loggarti per cambiare temi, puoi rinominare o rimuovere le directory degli altri temi (assicurandoti di averne un backup prima!) mantenendo soltanto il tema predefinito twentyseventeen. Questo forzerà il tuo sito ad usarlo.
    • Aggiornamento manuale. Quando tutto il resto fallisce, scarica una copia del file latest.zip per la versione 4.8 (in alto a destra in questa pagina) nel tuo computer e carica quella versione. Puoi avere la necessità di cancellare le directory wp-admin e wp-includes nel tuo server (NOTA: non cancellare la directory wp-content ed il file wp-config.php). Leggi l’articolo Come aggiornare WordPress.

    source https://wordpress.org/support/topic/read-this-first-wordpress-4-8-master-list/
    traduzione e revisione @wido @lasacco @cristianozanca

Stai vedendo 6 repliche - dal 1 al 6 (di 6 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Non sono bug

    I nuovi widget dei media non funzionano nel mio tema.
    Se il tuo tema elimina i widget in modo predefinito, ad esempio in un pannello di scorrimento, i nuovi widget audio e video potrebbero non essere visualizzati correttamente. Se sei uno sviluppatore di temi, ecco un esempio per risolvere questo problema.

    Il testo del widget di testo aggiornato va fuori dall’area specificata.
    Il tema deve essere aggiornato per lavorare con il nuovo gestore del contenuto dell’HTML dopo l’aggiornamento a 4.8.

    Sto ottenendo un avviso “Impossibile caricare il contenuto del css”.
    Questo avviso viene visualizzato quando un editor di css non è impostato correttamente (ad esempio un tema figlio che cerca di includere un editor di stile del tema padre con @import usando il percorso sbagliato). Il problema dovrà essere risolto dall’autore del tema affinché tutti i collegamenti ai file CSS siano corretti.

    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da  Cristiano Zanca.
    • Questa risposta è stata modificata 9 mesi fa da  Giulia Tosato.
    • Questa risposta è stata modificata 3 mesi, 2 settimane fa da  Cristiano Zanca.
    Moderatore Cristiano Zanca

    (@cristianozanca)

    Problemi relativi a plugin e temi

    Visual Composer ha incompatibilità con WordPress 4.8.1
    Risolto: Aggiornare a Visual Composer versione 5.2.1 o successiva

    • Questa risposta è stata modificata 9 mesi, 1 settimana fa da  Cristiano Zanca.
    • Questa risposta è stata modificata 9 mesi fa da  Giulia Tosato.
    • Questa risposta è stata modificata 3 mesi, 2 settimane fa da  Cristiano Zanca.
    Moderatore Cristiano Zanca

    (@cristianozanca)

    Impossibile caricare il contenuto css

    Questo problema continua a verificarsi agli utenti dopo l’aggiornamento alla versione 4.8, di seguito alcune spiegazioni più approfondite di quello che sta succedendo.

    L’errore significa che la finestra dell’editor non è riuscita a caricare una o più risorse, generalmente aggiunte utilizzando la funzione editor_styles, questa è aggiunta principalmente dal tuo tema, ma può anche essere implementata da plugin (se vuoi identificare la sua causa esatta , segui le normali operazioni di risoluzione dei problemi descritte nel primo post di questo thread).

    Questo problema può avere molte cause, spiegherò alcune di esse, in modo da sapere cosa cercare o di cosa informare il tuo sviluppatore di temi:

    • Il file di stile non esiste affatto
    • Il file di stile utilizza una o più chiamate @import() per includere file, ma il percorso non è corretto
    • Il tuo sito utilizza SSL (il tuo URL inizia con https://), ma le risorse che vengono caricate stanno cercando di utilizzare collegamenti http:// non crittografati
    • L’URL incluso è esterno e non è corretto. Finora principalmente visto con i font di Google, dove viene aggiunto un %2C alla fine del collegamento (questo è considerato una virgola e il collegamento non è valido dal punto di vista di Google se finisce così)

    Tutte queste situazioni, e probabilmente alcuni altri scenari che non abbiamo descritto, causano l’avviso. Quello che è importante prendere in considerazione qui è che questo è solo un avvertimento, non influenzerà le prestazioni del tuo sito web, significa semplicemente che la finestra di modifica del testo non mostrerà un anteprima accurata.

    Questo non è un bug in WordPress 4.8, ma piuttosto un avvertimento introdotto per aiutarti ad usare l’editor nel modo più ottimale possibile, ed è responsabilità degli sviluppatori di temi e di plugin per implementare correttamente le funzionalità.

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Moderatore Cristiano Zanca

    (@cristianozanca)

    HTML e widgets testuali in WordPress 4.8.1

    Un nuovo widget HTML personalizzato è stato introdotto in WordPress 4.8.1 per dare una collocazione adeguata agli snippets di markup che il widget di testo pre-esistente spesso ospitava in passato.

    Si potrebbero visualizzare alcuni avvisi quando si utilizza il widget di testo, non sono motivo di allarme e sono solo lì per aiutarti a utilizzare gli strumenti giusti.

    Widget di testo esistenti
    Quando un widget di testo esistente ha un markup, lo rileverà. Se ciò accade, il widget entrerà in modalità legacy e mostrerà l’avviso Questo widget può contenere codice che potrebbe funzionare meglio nel nuovo widget HTML personalizzato. Che ne dici di provare quel widget invece?

    La modalità Legacy significa che il widget di testo apparirà e si comporterà come prima dell’aggiornamento di 4.8.0, ma non è l’approccio ottimale, per questo motivo mostriamo l’avviso e il consiglio di passare al nuovo widget HTML personalizzato.

    Aggiunta di markup alla scheda visuale del widget di testo
    Se si tenta di incollare un frammento di markup nell’editor di testo, verrà presentato un messaggio di avviso con il messaggio Hey sembra che sia stato inserito l'HTML nella scheda "Visual" del widget Text. Potrebbe essere necessario incollare il codice nella scheda "Testo". In alternativa, prova il nuovo widget "Custom HTML"!

    Questo appare perché il markup nella scheda visiva viene rimosso e ripulito e si può vedere il codice HTML sul tuo front-end.

    Aggiunta di markup alla scheda di testo del widget di testo
    Quando si apre la scheda del widget può apparire l’avviso Hey, hai sentito che abbiamo un widget "Custom HTML" ora? Puoi trovarlo nell'elenco dei widget disponibili in questa schermata. Provalo per aggiungere un codice personalizzato al tuo sito!

    L’avviso appare per invitare gli utenti ad utilizzare il widget appropriato, visto che molti tutorials online invitano ad utilizzare il widget di testo. È ancora possibile inserire il markup nella scheda di testo, ma consigliamo vivamente di utilizzare invece il widget HTML personalizzato.

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Problema Conosciuto

    • Gli strumenti di Editing testuali potrebbero avere dei problemi, l’editor TinyMCE è stato aggiornato in questa versione quindi i plugin o i temi potrebbero essere da aggiornare per funzionare nuovamente
Stai vedendo 6 repliche - dal 1 al 6 (di 6 totali)
  • Il topic ‘LEGGI QUESTO PRIMA di TUTTO WordPress 4.8 Nuove Caratteristiche’ è chiuso a nuove risposte.