Supporto » Installazione e Aggiornamento » non accedo al pannello di amministrazione dopo trasferimento dominio

  • Risolto giafa

    (@giafa)


    Buongiorno a tutt#
    Stamattina ho effettuato (manualmente) il trasferimento di un sito in wordpress all’interno dello stesso hosting ma da un dominio ad un altro.
    Questo:
    http://perlaterra.net >>> http://vociperlaterra.it
    1) Ho effettuato il trasferimento dei file via Filezilla
    2) Ho modificato il database originale in modo da “puntare al nuovo dominio” e lo ho caricato nel nuovo db
    3) Ho modificato il file wp-config.php in modo da richiamare la nuova configurazione
    Tutto funziona … tranne che non riesco ad aprire la pagina di amministrazione.
    Ogni volta che provo mi restituisce una schermata che mi avvisa: “Si è verificato un errore critico sul tuo sito web. Controlla la casella di posta dell’amministratore del sito per istruzioni.- Scopri di più riguardo al debug in WordPress.”.
    Ho provato a disconnettere tutti i plugin modificandone il nome nella cartella via ftp .. niente.
    Qualcuno può mettermi sulla buona strada? ho sbagliato qualcosa nel rinominare i file del db?
    Grazie fin da ora

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Come hai fatto il replace delle URL nel database?

    manualmente … ho trasformato tutte le url perlaterra.net in vociperlaterra.it
    forse mi è scappato qualcosa? devo controllare?

    Hai la possibilità di accedere al “vecchio” sito?

    Se si esporta il solo database con duplicator e vedi se, facendo l’importazione con lui, risolvi.

    Ok …. risolto
    Dopo avere provato di tutto senza capire cosa fosse successo, ho reinstallato il core di wordpress senza caricare via ftp la cartella wp-content
    Ho rinominato le tabelle del db in modo che (dopo aver sovrascritto e riconfigurato il file wp-config) puntassero alle vecchie tabelle che avevo importato (che funzionano senza problemi dunque il problema non era nel db).
    Probabilmente si era corrotto qualche file nelle operazioni download/upload dal vecchio al nuovo dominio.
    Buone feste

Stai visualizzando 4 risposte - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.