Supporto » Fixing WordPress » Non riesco a togliere Sito in Costruzione

  • Eliand

    (@eliand)


    Salve a tutti,
    ho un problema nel mettere on line il mio sito creato con un Tema Personalizzato.
    Io utilizzo Aruba come hosting. Quando vado a digitare il mio sito “www.eliand3d.com” mi appare la scritta sito in costruzione. Sicuramente è un problema di index ma non riesco a capire come fare. Nell’Host ho la cartella http://www.eliand3d.com dove risiede l’index.php con la scritta sito in costruzione, inoltre ho la cartella wordpress dove risiedono tutti i file del sito.
    Grazie a tutti
    Andrea

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • Moderatore Francesco Di Candia

    (@francescodicandia)

    Ciao Eliand, ho provato ad accedere al tuo sito ma mi richiede username e pwd. a parte questo, ho letto che hai WordPress in un’altra cartella: sei sicuro di aver configurato bene l’accesso al tuo WordPress? Prova a leggere questa guida qui, magari può esserti d’aiuto.
    https://codex.wordpress.org/it:Modificare_l’URL_del_sito
    Francesco

    Eliand

    (@eliand)

    Salve Francesco, grazie di nuovo per la risposta. E’ vero c’è una password sulla cartella di WordPress, pensavo servisse solo in off-line e invece…..comunque la tolgo subito. così puoi vedere. Comunque leggo subito il sito così posso postare la soluzione.
    Andrea

    Moderatore Francesco Di Candia

    (@francescodicandia)

    è come dicevo nel mio precedente commento: il tuo sito si vede alla url: http://www.eliand3d.com/wordpress/ quella dove hai installato WordPress. Devi semplicemente modificare l’indirizzo del tuo sito seguendo le info del link che ti ho postato.
    Facci sapere 😉
    F.

    Eliand

    (@eliand)

    Ciao Francesco,
    Dunque…..ho seguito le istruzioni dal sito che mi hai postato e più precisamente nel capitolo “Using a pre-existing subdirectory install” in quanto il tree della mia directory è così composto:

    Screenshot

    Come puoi vedere dall’immagine compaiono i due file index.php (opportunamente modificato) ed il _htaccess in quanto ho modificato i permalink.

    Purtroppo per quando vado sulla mia pagina http://www.eliand3d.com mi compare questa scritta:

    Warning: require(/web/htdocs/www.eliand3d.com/home/www.eliand3d.com/wp-blog-header.php): failed to open stream: No such file or directory in /web/htdocs/www.eliand3d.com/home/index.php on line 17

    Fatal error: require(): Failed opening required ‘/web/htdocs/www.eliand3d.com/home/www.eliand3d.com/wp-blog-header.php’ (include_path=’.:/php5.5/lib/php’) in /web/htdocs/www.eliand3d.com/home/index.php on line 17

    Eliand

    (@eliand)

    Ho notato però che se copio tutti i files e cartelle nella root il sito funziona……..Questo però significa che ogni qualvolta modifico il sito in wordpress devo ricopiare di nuovo tutto?

    Moderatore Francesco Di Candia

    (@francescodicandia)

    il tuo sito funziona quando ricopi tutto nella root perchè è configurato così nelle opzioni. se tu vuoi che funzioni anche quando risiede sotto la dir /wordpress, dovrai modificare dal menù ‘Impostazioni’ -> ‘Generali’ la dir dove risiede il tuo sito e la url corrispondente.
    F.

    Eliand

    (@eliand)

    OK ci provo.
    Grazie

    Eliand

    (@eliand)

    ora è tutto on line ho tolto la scritta wordpress dal campo “Indirizzo sito (URL)” nel menu impostazioni.
    Grazie Francesco……..

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • Il topic ‘Non riesco a togliere Sito in Costruzione’ è chiuso a nuove risposte.