Supporto » Installazione e Aggiornamento » PHP? aggiornamento errato?

  • Risolto lucalenzo

    (@lucalenzo)


    Buongionro,
    Giusto per spiegarmi il meglio possibile premetto che sono ignorante. tempo fa ho acquistato uno spazio su Aruba e c’era compresa la possibilità di usare wordpress che mi dicevano amici essere molto versatile e divertente da usare. Cosi lo ho usato, anche se magari poco . Oggi sono tornato ad aprirlo, volevo fare un articolo, ed ho notato che c’erano aggiornamenti. Per farne uno dovevo aver eseguito prima il backup , e per fare l’altro dovevo aggiornare il PHP alla versione almeno 7.0
    Cosi ho installato 2 plug-in , uno per il backup ed uno per verificare la compatibilità col nuovo PHP. In teoria mi diceva che ero compatibile fino al 7.1 , ed ho installato manualmente il 7.1 anche perchè diceva che in caso potevo tornare indietro ( al 5.2 o 5.4 non ricordo bene )
    Poi però aggiornando la pagina mi è venuto fuori quello che si vede adesso su [Link qui sotto] .
    Cosi sono entrato nel pannello di Aruba ed ho trovato degli strumenti tra cui uno che citava :”Questo strumento ripristina le permissions di tutte le directories e files presenti nello spazio web allo stato originale.”
    ho provato a cliccare, ma nulla.
    E adesso non ho proprio idea di cosa abbia combinato e come risolvere.
    grazie ancora.

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Hai installato SG Optimizer che deve essere usato SOLO su hosting siteground vero?

    Ora devi per prima cosa accedere tramite FTP (o File Manager) e cancellare manualmente il plugin in questione quindi ripristinare i permessi e rinominare il file .htaccess.

    Dovresti poter riaccedere al WordPress

    Questa è la guida di Aruba per gestire le versioni di PHP
    http://tiny.cc/73dsfz

    Grazie mille, per adesso son riuscito a cancellare la cartella SG da file manager.
    Adesso volevo chiedere gentilmente, come si ripristinano i permessi?
    Come devo rinominare il file Htacces (che se non ho visto male è un file di testo) ?

    Grazie ancora

    Si, rinomina il file .htaccess in .htaccess_old

    Magari se avessi una copia di backup dello stesso… non farebbe “male”.

    Ho trovato nel Backup settimanale un file htacces vecchio aprendo quello che c’è adesso trovo:
    # START PHP VERSION CHANGE forced by SG Optimizer
    AddHandler application/x-httpd-php71 .php .php5 .php4 .php3
    # END PHP VERSION CHANGE
    # Leverage Browser Caching by SG-Optimizer
    <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresDefault “access plus 6 months”
    # CSS
    ExpiresByType text/css “access plus 1 year”
    # HTML components (HTCs)
    ExpiresByType text/x-component “access plus 2 months”
    # HTML
    ExpiresByType text/html “access plus 6 months”
    # JavaScript
    ExpiresByType application/javascript “access plus 1 year”
    ExpiresByType application/x-javascript “access plus 1 year”
    # Manifest files
    ExpiresByType application/x-web-app-manifest+json “access plus 0 seconds”
    ExpiresByType text/cache-manifest “access plus 0 seconds”
    # Media
    ExpiresByType audio/ogg “access plus 1 year”
    ExpiresByType image/gif “access plus 1 year”
    ExpiresByType image/jpg “access plus 1 year”
    ExpiresByType image/jpeg “access plus 1 year”
    ExpiresByType image/png “access plus 1 year”
    ExpiresByType image/svg “access plus 1 year”
    ExpiresByType image/svg+xml “access plus 1 year”
    ExpiresByType video/mp4 “access plus 1 year”
    ExpiresByType video/ogg “access plus 1 year”
    ExpiresByType video/webm “access plus 1 year”
    ExpiresByType image/x-icon “access plus 1 year”
    ExpiresByType application/pdf “access plus 1 year”
    ExpiresByType application/x-shockwave-flash “access plus 1 year”
    # Web feeds
    ExpiresByType application/atom+xml “access plus 1 hour”
    ExpiresByType application/rss+xml “access plus 1 hour”
    # Web fonts
    ExpiresByType application/font-woff “access plus 1 year”
    ExpiresByType application/font-woff2 “access plus 1 year”
    ExpiresByType application/vnd.ms-fontobject “access plus 1 year”
    ExpiresByType application/x-font-ttf “access plus 1 year”
    ExpiresByType font/opentype “access plus 1 year”
    </IfModule>
    # END LBC
    # GZIP enabled by SG-Optimizer
    <IfModule mod_deflate.c>
    <IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE “application/atom+xml” \
    “application/javascript” \
    “application/json” \
    “application/ld+json” \
    “application/manifest+json” \
    “application/rdf+xml” \
    “application/rss+xml” \
    “application/schema+json” \
    “application/vnd.geo+json” \
    “application/vnd.ms-fontobject” \
    “application/x-font-ttf” \
    “application/x-javascript” \
    “application/x-web-app-manifest+json” \
    “application/xhtml+xml” \
    “application/xml” \
    “font/eot” \
    “font/opentype” \
    “image/bmp” \
    “image/svg+xml” \
    “image/vnd.microsoft.icon” \
    “image/x-icon” \
    “text/cache-manifest” \
    “text/css” \
    “text/html” \
    “text/javascript” \
    “text/plain” \
    “text/vcard” \
    “text/vnd.rim.location.xloc” \
    “text/vtt” \
    “text/x-component” \
    “text/x-cross-domain-policy” \
    “text/xml”
    </IfModule>
    </IfModule>
    # END GZIP

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    aprendo quello che trovo nel backup trovo:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Ho quindi rinominato il primo aggiungendo _old e copiato incollato l’altro nella stessa posizione.
    non so ancora come si ripristinano i permessi.

    Grazie.

    FERMO FERMO FERMO, FUNZIONA ADESSO FUNZIONA
    GRAZIE MILLE, se aspettavo l’assistenza Aruba chissà quando mi risponderanno….

    Adesso mi studio bene la guida che hai messo per aggiornare senza fare caXXate.

    Grazie ancora,
    buona giornata.

    🙂

    L’importante è che tu abbia risolto.

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Devi essere collegato per rispondere a questo topic.