Supporto » Funzionalità = Plugin » plugin polylang problema stringa errore sopra la testata

  • Risolto anto5678

    (@anto5678)


    Premetto che non ho un background di programmazione, quindi abbiate pazienza per favore…
    Il codice di errore è questo:

    Warning: simplexml_load_file(): I/O warning : failed to load external entity “/membri/residenzasantanna/wp-content/plugins/gp-premium/wpml-config.xml” in /membri/residenzasantanna/wp-content/plugins/polylang/modules/wpml/wpml-config.php on line 53

    Warning: simplexml_load_file(): I/O warning : failed to load external entity “/membri/residenzasantanna/wp-content/plugins/wordpress-seo/wpml-config.xml” in /membri/residenzasantanna/wp-content/plugins/polylang/modules/wpml/wpml-config.php on line 53

    Ho abilitato la connessione server to server

    Codice PHP:
    if ( file_exists( $file = WP_PLUGIN_DIR . ‘/’ . dirname( $plugin ) . ‘/wpml-config.xml’ ) && false !== $xml = simplexml_load_file( $file ) ) {

    polylang usa libxml_disable_entity_loader(true) ? da qualche parte nel codice?

    Grazie in anticipo a chiunque mi aiuti…. grazie!

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Ragazzi che entusiasmo… uno alla volta mi raccomando…
    non mi ha calcolato nessuno…

    Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    Ciao @anto5678
    Ti faccio presente che il forum di supporto è gestito da volontari e che l’aiuto è volontario, pertanto ti chiedo di rispettare chi offre gratuitamente il proprio aiuto anche se non hai ancora ricevuto una risposta.
    Ti consiglio di leggere le regole di questo forum perché non si può uppare un post https://it.wordpress.org/support/lineeguida/#non-uppare-i-tuoi-post
    Inoltre, se desideri una riposta veloce, ti consiglio di contattare il supporto del plugin.

    Grazie

    anto5678

    (@anto5678)

    Ciao Rosetta, mi scuso con te e con tutti, non era mia intenzione urtare nessuno, ho molto rispetto del volontari, perchè faccio tanto volontariato anch’io, 118 ed altre associazioni nel sociale.
    Ho avuto un’uscita un pò infelice tutto qui, è un pò frustrante perchè sono bloccata su questo problema da diversi giorni, comunque ascolterò il tuo consiglio.

    Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    Ciao @anto5678
    tranquilla, succede di essere un po nervosi, l’importante è capirlo, come hai fatto tu, e non ripetere lo stesso atteggiamento.
    Apprezzo molto questo tuo messaggio. Se hai bisogno di aiuto per qualunque altra cosa non esitare a chiedere qui nel forum, noi siamo qui per cercare di aiutare 🙂

    Ps. forse può esserti utile leggere questo topic dove ci sono alcune soluzioni per problemi comuni, forse riesci a risolvere:
    https://it.wordpress.org/support/topic/prima-di-aprire-un-ticket-leggi-qui/
    E anche questo in merito all’ultima versione di WordPress: https://it.wordpress.org/support/topic/leggi-questo-prima-di-tutto-wordpress-5-3/

    Ps2. Anche io sono volontaria di Protezione Civile 😉

    Facci sapere come risolvi, magari può essere di aiuto a qualcun’altro con il tuo stesso problema 🙂

    Devi contattare entrambi i supporti dei due plug-in (possibilmente gp-premium ha un modulo per polylang… Quindi il problema potrebbe crearlo lui)
    Supporto in lingua inglese Gp-Premium https://generatepress.com/support/
    Supporto in lingua inglese Polylang https://wordpress.org/support/plugin/polylang/
    Il supporto Server to Server del tuo hosting é un modo per dire "abilitare la connessione esterna (internet)"
    Se disattivi il plugin gp-premium e tieni attivo polylang il problema scompare? Se é si ( il problema é causato al 100% dal plugin Gp-Premium e non avere questa patch https://bugs.php.net/bug.php?id=62577 libxml_disable_entity_loader(true);
    )

    Grazie a tutti per le risposte, grazie Rosetta per l’impegno nella protezione civile.

    Allora per il momento è stato risolto così, premetto che non l’ho fatto direttamente io:

    Il plugin ha un problema sui warning che dovresti disattivare sul file php.ini relativo ad Altervista.
    Ne parlano qui: https://wordpress.org/support/plugin/polylang/

    Io ho commentato la riga relativa all’errore (riga 53) che esegue un controllo in effetti poco utile.
    Per accedere sono andato su Plugin >> Editor del plugin >> selezionato il plugin Polylang in alte a destra e sotto >> modules >> wpml ho cliccato su wpml-config.php.
    Lì ho commentato con // la funzione relativa alla riga 53.

    ciao

    • Questa risposta è stata modificata 1 settimana, 2 giorni fa da anto5678.

    Si ma sono convinto che é Gp-premium a chiamare polylang, purtroppo é un plugin premium altrimenti avrei cercato la soluzione.
    Attualmente altervista non permette di disattivare la visualizzazione degli errori, però impostando error_reporting(0) (origine del messaggio di errore, forse GP premium) si disabilità l’errore e successivamente imposti error_reporting al vecchio valore, ma poiché a te serve caricare quel file xml devi risolvere il problema altrimenti non ti carica il file.
    Con dovuta calma prova ad esplorare il plugin GP premium dal tuo editore di plugin.
    Inoltre hai verificato il file xml se é well formed? https://wordpress.org/support/topic/issue-with-polylang-since-2x-malformed-wpml-configxml-files/ /membri/residenzasantanna/wp-content/plugins/gp-premium/wpml-config.xml la root del tuo server é /membri/residenzasantanna (non va utilizzata per un percorso remoto, ad esempio su http).
    Da WordPress 5.3 per motivi di cambiamento al codice core, dovrai utilizzare la versione polylang 2.6.7 altrimenti se WordPress inferiore a 5.3 la versione 2.6.6

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Devi essere collegato per rispondere a questo topic.