Supporto » Sviluppare con WordPress » Primi passi con WordPress

  • Salve a tutti,
    sto creando un sito con WordPress 3.6.1 perché lo spazio web che ho a disposizione prevede il supporto per la versione 5.6 di PHP.
    Dopo l’installazione che è andata a buon fine, ho provato a inserire un’immagine per l’header ma l’editor permette la selezione di un rettangolo di dimensioni 1600 x 230 (sto usando il tema di default).
    Ho anche provato a customizzare il css e il js in vari punti cambiando 230px con 450px però il quadratino con il quale si può ridimensionare l’immagine resta uguale (siccome mi sembra troppo invasivo andare a vedere dove modificare il codice per superare questo problema ho lasciato perdere). Allora ho deciso di trovare un nuovo tema che avesse l’header più ampio e ho provato a installarne due. Però quando ho cliccato su customize ho ottenuto i seguenti errori:

    Fatal error: Call to undefined method WP_Customize_Manager::add_panel() in C:\xampp\htdocs\CreubridgeWP\wp-content\themes\rara-academic\inc\customizer.php on line 40

    Fatal error: Call to undefined function wp_script_add_data() in C:\xampp\htdocs\CreubridgeWP\wp-content\themes\writers\functions.php on line 123

    Trovando sulla rete, ho visto che si consiglia di aggiornare wordpress all’ultima versione (che richiede PHP 7), io lo farei ma poi non credo che possa funzionare sul mio spazio web che supporta, come detto prima, PHP 5.6.

    Avete qualche consiglio da darmi ?

    Grazie dell’attenzione

    Alessio Frabotta

Stai visualizzando 1 risposte (di 1 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve @musicale2017 ,

    Benvenuto nel forum!

    Per chi muove i primi passi:
    https://codex.wordpress.org/Nuovo_su_Wordpress_-_Come_cominciare

    Il consiglio è di leggere le regole del forum che si trovano qui:

    Benvenuto

    una domanda = un argomento.
    nel caso di questo topic l’argomento è usare o meno WP 3.6.1

    La risposta è no, per motivi di sicurezza e funzionalità.

    Php 5.6 non è più supportato da php.net, solo upgrade di sicurezza fino al prossimo anno, ma nessuna nuova funzionalità verrà aggiornata.

    Come tutti i software presenti online, ogni elemento (php, mysql/mariadb, apache/nginx, etc…) se non viene aggiornato all’ultima versione stabile apre il proprio sito ad attacchi e malfunzionamenti.

    Se si vuole investire del tempo in un progetto sicuro è possibile scegliere un’hosting che usa PHP7

Stai visualizzando 1 risposte (di 1 totali)
  • Il topic ‘Primi passi con WordPress’ è chiuso a nuove risposte.