Supporto » Fixing WordPress » Problema accesso backend post cambio hosting

  • Risolto freestyler901

    (@freestyler901)



    Salve a tutti,
    dopo aver fatto mille ricerche e mille prove, mi ritrovo qui a scrivervi per chiedere aiuto circa il seguente problema.
    Ho recentemente cambiato servizio di hosting.
    Ovviamente prima di farlo ho eseguito backup di sito e db completo.
    Sul nuovo provider ho caricato backup di sito e db modificando ovviamente nel file di config i relativi dati di accesso.
    Già facendo ciò, provando ad accedere al sito ricevo errore 500 Internal Server Error.
    Eliminando file .htaccess e user.ini riesco a visualizzare il sito che però presenta errori nella visualizzazione del plugin wp-super-cache che è il seguente

    Warning: include(/wp-content/plugins/wp-super-cache/wp-cache-base.php): failed to open stream: No such file or directory in /web/htdocs/www.smallzine.it/home/wp-content/plugins/wp-super-cache/wp-cache.php on line 92

    Warning: include(): Failed opening ‘/wp-content/plugins/wp-super-cache/wp-cache-base.php’ for inclusion (include_path=’.:/php5.6/lib/php’) in /web/htdocs/www.smallzine.it/home/wp-content/plugins/wp-super-cache/wp-cache.php on line 92

    Warning: include_once(/wp-content/plugins/wp-super-cache/ossdl-cdn.php): failed to open stream: No such file or directory in /web/htdocs/www.smallzine.it/home/wp-content/plugins/wp-super-cache/wp-cache.php on line 116

    Warning: include_once(): Failed opening ‘/wp-content/plugins/wp-super-cache/ossdl-cdn.php’ for inclusion (include_path=’.:/php5.6/lib/php’) in /web/htdocs/www.smallzine.it/home/wp-content/plugins/wp-super-cache/wp-cache.php on line 116

    Disattivo WP Super Cache ma anche facendo ciò non riesco ad accedere nel backend.
    Ho provato a disattivare tutti i plugin ma niente.
    Visualizzo la pagina di login, metto user e psw, do invio ma è come se non facesse nulla, non mi riporta alcun errore ma svuota i 2 campi come se non avessi fatto nulla.
    Vi cito una lista dei plugin installati che penso possano essere la causa del problema
    Antivirus
    Gotmls
    Litespeed Cache
    Wordfence
    WP Super Cache
    Se vi state chiedendo come mai così tanti antivirus e malware, la risposta è che il vecchio provider non offriva un servizio tale e quindi il sito veniva spesso colpito e oscurato a causa della presenza di codici malevoli.
    Spero possiate aiutarmi.
    Grazie

Stai vedendo 6 repliche - dal 1 al 6 (di 6 totali)
  • Ciao @freestyler901,

    ho visitato il sito e non mi sembra di aver visto gli errori che riporti. Leggendo

    Disattivo WP Super Cache ma anche facendo ciò non riesco ad accedere nel backend.
    Ho provato a disattivare tutti i plugin ma niente.

    sembrerebbe tu abbia giustamente provato a disattivare tutti i plugin ma non sono riuscito a capire esattamente quale procedura tu abbia adottato, visto che mi sembra di capire tu non abbia accesso al back-end (rinominando la cartella, forse?): potresti per favore spiegare nel dettaglio?

    Ciao, grazie per la risposta.
    Allora ho provato a disattivarli sia singolarmente che l’intera cartella, poi ho anche provato dal DB, ma niente non mi fa accedere al backend.
    Ieri ho eliminato il file htaccess che c’era (interamente modificato dai vari plugin) e sostituito con uno standard con i dati riportati sul sito di WP e le pagine sono tornate a funzionare, niente errore 404, ma comunque il backend non è accessibile. Metto sempre user e psw, do invio e non succede nulla, si svuotano solo i campi compilati.

    @freestyler901,

    perdonami ma non sono ancora riuscito a capire con certezza quale metodo tu abbia adottato per disattivare tutti i plugin: se hai comunque provato da DB (presumo quindi sostituendo il valore esistente in wp_options -> active_plugins con a:0:{}), ti consiglierei di provare i tentativi indicati su questa pagina, specialmente alla voce

    New Login File

    .

    Se continuassi ad avere problemi dopo aver tentato tutti i metodi indicati, ti suggerisco di continuare a chiedere supporto su questo topic aggiungendo le informazioni di configurazione PHP (ricordando di oscurare le informazioni sensibili).

    Tienici aggiornati.

    Ciao,
    ho tentato tutte le soluzioni nel link che mi hai indicato ma niente. Continuo a non accedere al backend. Sempre solita cosa, metto user e psw, do invio e non succede nulla.
    Mi sta facendo uscire pazzo questa cosa.
    Ti indico le info della configurazione PHP come riportate nel link

    PHP Version	5.6.37
    System	Linux webxc235s04.ad.aruba.it 3.10.0-862.3.2.el7.x86_64 #1 SMP Mon May 21 23:36:36 UTC 2018 x86_64
    Build Date	Jul 24 2018 17:03:42
    Server API	CGI/FastCGI

    Circa queste altre voci non riesco a trovare riscontro.

    Apache Version	
    Apache Release	

    Mentre questa è molto lunga e non so se sia sicuro pubblicarla. Dimmi tu
    Under MySQL: Client API version

    Ok ho risolto.
    Guardando un video su youtube mi è venuto in mente di modificare nel DB nel wp_options, sia siteurl che home, che erano corretti, aggiungendo www
    Ora sembra funzionare. In caso di altri problemi vi terrò aggiornati.
    Grazie mille

    @freestyler901,

    tutto è bene quel che finisce bene! 🙂
    Ti prego allora di marcare il topic come risolto e di aprire un altro topic qualora riscontrassi altri problemi.

Stai vedendo 6 repliche - dal 1 al 6 (di 6 totali)
  • Devi essere collegato per rispondere a questo topic.