Supporto » Installazione e Aggiornamento » Problema Aggiornamento WordPress 4.5

  • Risolto raffdes

    (@raffdes)


    Buongiorno,
    sto provando ad aggiornare wp 4.5 ma il back-end si inchioda.

    Nella fattispecie, quando clicco su “Aggiorna ora”, dopo alcuni secondi che inizia a caricare, compaiono i consueti menu a sinistra ed in alto ma il resto resta inspiegabilmente resta tutto grigio, con la dicitura della precedente versione 4.4.2 in basso a destra.

    Grazie in anticipo per la collaborazione.

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • mangiaficogiulia

    (@mangiaficogiulia)

    Buongiorno, seguo la discussione. Ho lo stesso problema,
    Grazie
    Giulia

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve a tutti,

    in questi casi consiglio un Aggiornamento Manuale

    Grazie Cristiano per la risposta.
    Ma questo vale quando hai un solo sito da gestire…

    Quando si tratta di aggiornarne dieci??? 😉

    Spero di arrivare a fare l’aggiornamento automatico altrimenti lascio tutto così com’è.

    Ho aggiornato attraverso Softaculous e non mi ha dato problemi.

    mangiaficogiulia

    (@mangiaficogiulia)

    Io ho risolto. Mi dava problemi il plugin per la sicurezza, itheme security. Disattivandolo wp si aggiorna tranquillamente.

    Confermo ciò che ha scritto mangiaficogiulia.
    Ho pocanzi aggiornato due siti senza problemi, disattivando e riattivando iTheme Security.

    Buongiorno. Ho aggiornato manualmente alla versione 4.5, operazione che faccio normalmente. In questo caso mi compare nelle home del sito in alto questa scritta:

    Warning: mysqli_real_connect(): (HY000/2000): mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD(‘your_existing_password’). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file in /web/htdocs/www.emanuelazibordi.it/home/wp/wp-includes/wp-db.php on line 1489.

    la riga 1489 del file è questa è questa, ma non saprei cosa fare:

    mysqli_real_connect( $this->dbh, $host, $this->dbuser, $this->dbpassword, null, $port, $socket, $client_flags );.

    Nel Mysql accedo normalmente con la mia pw. Il php è aggiornato al 5.6

    Grazie

    • Questa risposta è stata modificata 4 anni, 3 mesi fa da melamela.
    Moderatore Rosetta Facciolini

    (@ramthas)

    Web Manager

    Ciao @melamela
    prova a riavviare MySQL perchè può essere che continua ad usare il vecchio formato della pwd

Stai visualizzando 8 risposte - dal 1 al 8 (di 8 totali)
  • Il topic ‘Problema Aggiornamento WordPress 4.5’ è chiuso a nuove risposte.