Supporto » Aspetto = Temi » Problema dopo aggiornamento tema

  • barbarajermini

    (@barbarajermini)


    Buongiorno. Ieri il mio tema(Enfold) ha fatto un aggiornamento. Da quel momento mi appare un messaggio di errore ogni volta che devo salvare una pagina.
    Io non uso i blocchi di gutemberg, ma il tema classic.
    Ho ricevuto una email con la descrizione del problema, ma non so cosa fare. Scrivo qui:
    Versione di WordPress 5.4
    Tema corrente: enfold Child (versione 4.7.3)
    Plugin corrente: (versione )
    Versione PHP 7.3.16

    Dettagli dell’errore
    ====================
    Un errore di E_ERROR è stato causato nella linea 657 del file /home/daslebe0/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php. Messaggio di errore: Uncaught TypeError: Argument 2 passed to Avia_Gutenberg::handler_display_post_states() must be an instance of WP_Post, null given, called in /home/daslebe0/public_html/wp-includes/class-wp-hook.php on line 287 and defined in /home/daslebe0/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php:657
    Stack trace:
    #0 /home/daslebe0/public_html/wp-includes/class-wp-hook.php(287): Avia_Gutenberg->handler_display_post_states(Array, NULL)
    #1 /home/daslebe0/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #2 /home/daslebe0/public_html/wp-admin/includes/template.php(2170): apply_filters(‘display_post_st…’, Array, NULL)
    #3 /home/daslebe0/public_html/wp-includes/nav-menu.php(823): get_post_states(NULL)
    #4 [internal function]: wp_setup_nav_menu_item(Object(WP_Post))
    #5 /home/daslebe0/public_html/wp-includes/nav-menu.php(749): array_map(‘wp_setup_nav_me…’, Array)
    #6 /home/daslebe0/public_html/wp-includes/nav-menu.php(1105): wp_get_nav_menu_items(Object(WP_Term), Arra

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve barbarajermini ,

    Se è attivo un tema a pagamento e si necessita di aiuto, il suggerimento è di visitare i canali di supporto ufficiali del prodotto:

    http://tiny.cc/papdmz

    Al fine di essere una buona guida della comunità di WordPress e incoraggiare innovazione e crescita, crediamo sia importante indirizzare le persone verso i canali ufficiali di supporto 🙂

    Noi non abbiamo accesso ai prodotti a pagamento, quindi non possiamo sapere perché il tema premium o plugin premium non stanno funzionando correttamente, questa è la ragione per cui ti stiamo reindirizzando verso i canali ufficiali del venditore, il quale è l’unico responsabile del funzionamento del proprio prodotto.

    La domanda resterà aperta a chiunque abbia già risolto lo stesso problema e riesca ad essere d’aiuto

    Ecco un chiarimento su le policy del forum: https://it.wordpress.org/support/lineeguida#Prodotti_a_pagamento

    Chi ha creato la discussione barbarajermini

    (@barbarajermini)

    Scusa Cristiano, in verità mi sono sbagliata! Il problema è dopo l’aggiornamento di WP! Scrivo il messaggio che mi è apparso adfesso, provando a fare una nuova pagina.
    Ho comunque scritto ad Enfold, il mio tema, ma a questo punto forse non dipende da loro.

    Fatal error: Uncaught TypeError: Argument 2 passed to Avia_Gutenberg::handler_display_post_states() must be an instance of WP_Post, null given, called in /home/daslebe0/public_html/wp-includes/class-wp-hook.php on line 287 and defined in /home/daslebe0/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php:657 Stack trace: #0 /home/daslebe0/public_html/wp-includes/class-wp-hook.php(287): Avia_Gutenberg->handler_display_post_states(Array, NULL) #1 /home/daslebe0/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #2 /home/daslebe0/public_html/wp-admin/includes/template.php(2170): apply_filters(‘display_post_st…’, Array, NULL) #3 /home/daslebe0/public_html/wp-includes/nav-menu.php(823): get_post_states(NULL) #4 [internal function]: wp_setup_nav_menu_item(Object(WP_Post)) #5 /home/daslebe0/public_html/wp-includes/nav-menu.php(749): array_map(‘wp_setup_nav_me…’, Array) #6 /home/daslebe0/public_html/wp-includes/nav-menu.php(1105): wp_get_nav_menu_items(Object(WP_Term), Arra in /home/daslebe0/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php on line 657
    Si è verificato un errore critico sul tuo sito web. Controlla la casella di posta dell’amministratore del sito per istruzioni.

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve barbarajermini ,

    l’errore sembrerebbe dovuto ad un conflitto di Avia_Gutenberg presente nel tema qui /home/daslebe0/public_html/wp-content/themes/enfold/config-gutenberg/class-avia-gutenberg.php:657

    rilevato dopo l’aggiornamento a WordPress 5.4, come riscontrato anche da altri utenti dello stesso tema

    https://kriesi.at/support/topic/wordpress-5-4-and-enfold-4-7-4-error-with-customizer/

    la scelta di contattare l’assistenza del tema resta la mossa migliore

    Chi ha creato la discussione barbarajermini

    (@barbarajermini)

    Grazie mille. Ho provato, ma in genere non sono di grande aiuto. Comunque grazie!

    Chi ha creato la discussione barbarajermini

    (@barbarajermini)

    Buongiorno Cristiano, sono di nuovo qui. Avrei bisogno di un consiglio. Ho scritto ad Enfold più volte. Mi rispondono di rado e poi mi dicono che a loro il problema non risulta. Addirittura mi hanno risposto in due quasi contemporaneamente: uno mi ha chiesto l’accesso FTP e l’altro mi ha detto che a lui non risultava il problema, che dovevo togliere tutti i plugins e poi ad uno ad uno rimetterli. Io lo ho fatto, ma il problema sussiste. Il punto è che non sono la sola ad averlo. Ma non mi sembra che prenderanno la cosa in considerazione. Cosa posso fare? Grazie mille!

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve barbarajermini,

    il consiglio è di creare una copia di staging così:
    Spostare (copiare) WP
    https://wordpress.org/support/article/moving-wordpress/

    Creare un ambiente di sviluppo in locale
    https://goo.gl/FQwysK

    nella copia di staging fare un Aggiornamento Manuale

    sempre nella copia di staging, come suggerito dal supporto, togliere i plugin e rimetterli, togliere il tema e reinstallarlo

    se il problema sussiste, contattare il supporto dicendo che il problema si è ripresentato anche in un altra installazione

    Aggiornaci

    Chi ha creato la discussione barbarajermini

    (@barbarajermini)

    Ciao Cristiano. Sai, io non sono tanto esperta e non so fare questa cosa che mi hai consigliato. Ho provato a cambiare tema, mettendo il twenty twenty e il problema non c’era più. Ma da Kriesi (enfold) neanche mi rispondono più. E l’email che ho ricevuto in automatico dice chiaramente che il problema sul sito è causato da enfold:

    WordPress, a partire dalla versione 5.2, ha una funzionalità integrata che rileva quando un plugin o un tema provoca un errore irreversibile sul tuo sito e ti avvisa con questa email automatica.
    In questo caso, WordPress ha incontrato un errore con il tuo tema, Enfold.

    Forse devo semplicemente attendere che facciano un aggiornamento, sperando si risolva.
    Grazie!

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Il topic ‘Problema dopo aggiornamento tema’ è chiuso a nuove risposte.