Supporto » Fixing WordPress » Problemi con Https

  • Risolto fedeb78

    (@fedeb78)


    Salve ragazzi, sono un nuovo utente, scusate se apro un nuovo topic ma facendo la ricerca sono usciti tantissimi risultati e sarebbe difficile vederli tutti.. vengo al dunque, ho un sito “in costruzione” e prima di metterlo online ho pensato di attivare l’SSL che mi fornisce gratuitamente l’host, il problema è che il sito è diventato sicuro solo quando si accede inserendo https:// prima dell’indirizzo, se si accede da http:// o semplicemente digitando www. viene fuori l’avviso “sito non sicuro”. E’ da ieri mattina che discuto con l’host che non è ancora riuscito a risolvere, mi ha detto di svuotare la cache, di eliminare plugin, mi ha cancellato completamente il sito e fatto una nuova installazione pulita, (ora mi tocca ricominciare da capo…) ma niente.. secondo voi quale potrebbe essere il problema?
    Grazie per l’attenzione!

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Scusa ma hai fatto la migrazione da http ad https? prima fai un backup poi prova semplicemente ad installare il plugin Really Simple SSL

    Migrazione in che modo? Perché il supporto del mio hosting ha detto che la sola cosa che dovevo fare era entrare in wordpress, andare su impostazioni > generali e mettere la s all’indirizzo del sito dopo http, ora il sito è sicuro solo se ci si arriva da https://
    Ah bisogna installare necessariamente un plugin per poter mettere l’ssl?

    O modifichi a mano il file .htaccess

    Moderatore Cristiano Zanca

    (@cristianozanca)

    Salve fedeb78,

    quello che intende webepc è che nel database WordPress ci possono ancora essere numerosi riferimenti a url che contengono http e non https

    Il plugin da lui citato Really Simple SSL intercetta le chiamate ad http e le rimanda su https è perfetto per risolvere questa problematica

    Grazie Gianluca, ciao Cristiano, allora devo installare quel plugin? perchè avevo anche letto da qualche parte che inserendo poche righe di codice nel file .htaccess si faceva un redirect che rimandava a https, (queste se non sbaglio:
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] )
    risulta anche a voi?
    Perchè cerco sempre di installare solo i plugin strettamente necessari, ma se non se ne può fare a meno allora..

    fedeb78

    (@fedeb78)

    Alla fine sembra che abbia risolto ragazzi, visto che l’assistenza del mio hosting non sapeva più cosa fare e dava la colpa ad un plugin (under construction) che non c’entrava nulla, ho deciso di provarci, ho creato un file .htaccess, perchè non lo avevo, ho messo dentro quelle 3 righe di codice, l’ho caricato sul server del mio host e ora in qualunque modo si acceda al sito (https://, http://, www.) viene sempre fuori il lucchetto con connessione protetta! Mi sembrava giusto condividerlo. Ora però mando due righe all’assistenza…

    Cambia hosting 😅

Stai visualizzando 7 risposte - dal 1 al 7 (di 7 totali)
  • Devi essere collegato per rispondere a questo topic.