Supporto » Installazione e Aggiornamento » Problemi con il nuovo editor di tema a blocchi

  • Salve
    mi chiamo Simone e sviluppo piccoli siti web con WordPress.

    Appena uscita la versione di WordPress 5.9 ho pensato subito di provarne le nuove funzionalità sopratutto usando i nuovi temi a blocchi, naturalmente la prima scelta è stata il Twenty Twenty-Two.

    La prima cosa che ho provato a fare è usare il nuovo editor di tema (sotto la voce di menu Aspetto per intenderci), con mia grande sorpresa mi mostra solo una pagina bianca.
    Ho usato la console del browser per cercare di capire quale era il problema, l’errore era il seguente
    site-editor.php:1 Mixed Content: The page at 'https://www.webdraft.info/gub59/wp-admin/site-editor.php' was loaded over HTTPS, but requested an insecure resource 'http://www.webdraft.info/gub59/?_wp-find-template=true'. This request has been blocked; the content must be served over HTTPS.
    da quello che ne capisco ho interpretato l’errore in questo modo: il browser per sicurezza non visualizza la pagina perché nella stessa si fa riferimento a contenuti che non passano per https.

    Come possono esserci contenuti misti se WordPress è stato appena installato su un nuovo database ed i contenuti sono quelli di default di WordPress?

    Per completezza è bene chiarire che il resto di WordPress funziona normalmente compreso l’editor a blocchi che si usa per editare post e pagine, il sito viene pubblicato correttamente come si può vedere nel link.

    Prima di porre questa domanda al forum naturalmente ho provato a cercare se esistessero altri casi simili al mio, ad ora non ho trovato niente di simile e di conseguenza mi sono rivolto all’assistenza del mio hosting (Aruba), al momento l’unica cosa che mi hanno consigliato di fare è quella di installare il plugin “Really Simple SSL” e che naturalmente non ha risolto il problema.

    L’unica soluzione funzionante che sono riuscito a trovare tra le diverse prove che ho fatto è quella di intervenire sul file .htaccess inserendo questo comando
    Header always set Content-Security-Policy "upgrade-insecure-requests;"
    ma francamente non so se sia una buona pratica farlo e se possa creare problemi di indicizzazione in un sito nel lungo periodo.

    Ma alla fine la mia vera domanda è:
    Perché il un file di WordPress site-editor.php che lavora su https:// dovrebbe chiamare una risorsa in modo specifico su http:// pur appartenendo sempre allo stesso dominio e che comunque ha un certificato SSL attivo con redirect automatico su HTTPS?

    Vi ringrazio in anticipo per la vostra disponibilità.

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

  • Devi essere collegato per rispondere a questo topic.