Supporto » Varie ed eventuali » problemi di sicurezza

  • Buongiorno.
    Il mio sito http://www.marialberti.it è ospitato su provider Shellrent.
    Versione PHP 7.4.
    Improvvisamente, senza che io facessi alcuna operazione, da due giorni ha smesso di funzionare: non si riesce ad entrare né in front né in back.
    Ho provato a ristabilire il backup registrato su Shellrent risalente al 5 settembre, ma nulla.
    Ho contattato l’assistenza Shellrent che in un primo momento mi ha detto che poteva essere un plugin che aggiornandosi avesse creato problemi. Strano, in quanto io aggiorno i plugin manualmente e non lo avevo fatto.
    Poi mi ha detto che l’errore era sul plugin wp-file-manager. Ho cancellato il plugin.
    Successivamente il problema segnalato era codice malevolo su file index. L’ho ripulito.
    Mi dicono che possono solo metterlo a posto con assistenza a pagamento e che eventuali attacchi malevoli sul mio sito non dipendono da loro e non ne sono responsabili.
    Ora, non essendo la prima volta che mi capita questo problema, anche se su siti differenti (ho presso di loro diversi hosting), vorrei sapere se c’è un plugin (possibilmente gratuito) che io possa installare sui miei siti per evitare che in futuro accadano di questi problemi.
    C’è anche un modo per creare più backup in modo che in caso di malfunzionamenti io possa tornare ad una versione precedente sana? Intendo dire che se per caso anche l’ultimo backup è già corrotto, dovrei poter risalire ad una versione precedente.
    Inoltre vorrei sapere se sapete indicarmi una strada per risolvere il problema odierno, senza dover ricorrere all’assistenza a pagamento di Shellrent.
    Grazie.

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

  • Devi essere collegato per rispondere a questo topic.