Supporto » Installazione e Aggiornamento » Problemi dopo aggiornamento plugin

  • Risolto erasrl

    (@erasrl)


    Buongiorno, dopo l’aggiornamento dei plugin non riesco più ad entrare nel sito e mi compare la seguente scritta: Parse error: syntax error, unexpected ‘[‘ in /web/htdocs/www.erasrl.com/home/era/wp-content/plugins/googleanalytics/class/Ga_Admin.php on line 375

    Grazie

    Adriano

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 9 risposte - dal 1 al 9 (di 9 totali)
  • Sembrerebbe un problema del plugin di Google analytics, prima di aggiornare è stato verificato se gli aggiornamenti lanciati necessitavano anche dell’aggiornamento della versione del PHP?

    erasrl

    (@erasrl)

    Buongiorno, no non ho verificato.
    Come posso rimediare?

    Incomincerei a verificare l’attuale versione del PHP poi abilitate il il debug di WordPress per vedere (come probabilmente accadrà) quale errore e relativo a cosa apparirà.

    Per abilitare il debug leggi qui
    Abilitare Debug in WordPress

    erasrl

    (@erasrl)

    Chiedo scusa anticipatamente, ma sono veramente in difficoltà in quanto non saprei minimamente dove andare e come fare quanto mi ha indicato.
    Come verifico la versione del PHP e dove si abilita il debug di WordPress? Sono residenti sul mio PC o devo intervenire tramite Internet?
    Devo accedere in qualche modo attraverso il mio provider?

    Grazie e scusi ancora.

    Provider, hai letto il link che ti ho linkato prima?

    luca21

    (@luca21)

    Ciao @erasrl ,
    Suppongo che tu abbia abilitato il debug come consigliato.
    Forse ti escono messaggi di errore più esplicativi ma anche così sembra che dopo l’aggiornamento ci sia una apertura di parentesi quadra [ inaspettata: forse una in più del necessario.

    Potrebbe essere un errore intervenuto durante l’aggiornamento ma
    hai dato una occhiata allo specifico forum del plugin?
    https://wordpress.org/support/plugin/googleanalytics/

    Un saluto.

    luca21

    (@luca21)

    Ciao @erasrl ,

    Puoi anche controllare via FTP se il tuo file

    /web/htdocs/www.erasrl.com/home/era/wp-content/plugins/googleanalytics/class/Ga_Admin.php on line 375

    Contiene esattamente questo frammento preso dal repository del plugin:

    /**
    * Adds JS scripts for the settings page.
    */
    public static function enqueue_ga_scripts() {
    wp_register_script(
    GA_NAME . ‘-page-js’,
    Ga_Helper::get_plugin_url_with_correct_protocol() . ‘/js/’ . GA_NAME . ‘_page.js’,
    [ ‘jquery’ ],
    GOOGLEANALYTICS_VERSION,
    false
    );
    wp_enqueue_script( GA_NAME . ‘-page-js’ );
    }

    E’ sufficiente che si sia rovinata una virgola durante l’aggiornamento per provocare l’errore.

    erasrl

    (@erasrl)

    Risolto, grazie

    Scusa @erasrl , mi riusciresti mica a dire come sei riuscito a risolvere quel problema?
    E’ comparso ora anche a me 🙁

Stai visualizzando 9 risposte - dal 1 al 9 (di 9 totali)
  • Devi essere collegato per rispondere a questo topic.