Supporto » Fixing WordPress » sezione aggiornamento sparita, ed altro

  • Ciao, dopo diverso tempo o messo mano su un sito wp versione 4.7.5. Visto che non mi visualizzava sa sezione “aggiornamenti” sotto “bacheca” o pensato di aggiornare il wp tramite ftp. Nel frattempo mi ero accorto anche del fatto che sulla sezione plugin mancava il pulsante “aggiungi nuovo” e nel plugin disattivati non compariva la voce “elimina” per eliminare il plugin stesso.
    Ho pensato che copiandoci sopra la nuova versione 4.9.6 di wordpress, tutto potesse tornare alla normalità, ma così non è. Quindi al momento ho bisogno di installare dei nuovi plugin e non riesco a farlo. Qualcuno ha idea di cosa possa essere successo e di come poter risolvere?
    Grazie a tutti.
    Ciao.

Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • Intanto bisogna dire che devi risolvere non per poter installare i plugin (dato che potresti farlo anche via FTP), ma perché c’è qualcosa che non va, e perché WordPress (insieme ai temi e ai plugin) deve essere sempre aggiornato.
    Chiarito questo, molto probabilmente si tratta di un’incompatibilità data da uno o più plugin. Gli aggiornamenti manuali via FTP hanno senso se si fanno cancellando i vecchi file, non sovrascrivendo.

    Segui quindi alla lettera le istruzioni per l’aggiornamento manuale.

    Edit: a operazione ultimata, prima di riattivare i plugin (meglio se lo fai uno alla volta se non li conosci, e così avrai modo di capire quale eventualmente causa l’errore, se questo fosse indipendente dall’aggiornamento di WP e persistesse), accertati che siano all’ultima, e il più possibile recente versione. Idem per il tema.

    Ciao Tizz, grazie per la risposta. Ho aggiornato tutto in modo manuale, ho provato anche a disattivare tutti i plugin, ma il problema rimane, non ho più il tasto “aggiungi nuovo” a destra della scritta plugin. Inoltre i vari plugin possono essere disattivati, ma non compare più, una volta disattivati, il link “elimina” ma solo il link “attiva” per riattivare il plugin. Veramente strana questa cosa. Ho installato centinaia di wp e non mi era mai successo 🙁

    Prima di fare l’aggiornamento manuale, come descritto nella pagina del link, avresti già dovuto avere tutti i plugin disattivati, compreso il tema, attivandone uno di default della serie Twenty di WordPress.
    In questa situazione – che virtualmente rappresenta un’installazione base senza plugin e con il tema di default – tutte le funzionalità base devono esserci e comparire per forza.
    È qui che ti devi soffermare, come già spiegato:

    – Se tutto è come dovrebbe essere, riattivi il tema e i plugin uno alla volta, controllando attentamente, riuscendo così a capire quale causa il problema.

    – Se invece, pur in quella situazione base, il problema c’è ancora, allora non è causa diretta di WordPress, aprendosi diverse possibilità “esterne” che è difficile ipotizzare non conoscendo la tua installazione, da problemi di configurazione sul server a un banale problema di permessi, da file mancanti o trasferimenti incompleti, fino a modifiche (eventualmente anche sul database) che ne hanno compromesso la funzionalità. Controlla anche l’.htaccess.
    Per individuare eventuali errori sul server devi guardare il log degli errori e/o rivolgerti al tuo provider del servizio.

    Si, ho messo anche il un tema di default, ma il problema è ancora presente. Vedrò di andare più a fondo come mi hai consigliato.
    Grazie per gli input.

Stai vedendo 4 repliche - dal 1 al 4 (di 4 totali)
  • Devi essere collegato per rispondere a questo topic.