Supporto » Installazione e Aggiornamento » Sito in sottocartella non funziona dopo aggiornamento WordPress

  • Risolto cloudspotting

    (@cloudspotting)



    Faccio riferimento al mio sito http://incurva.org/.
    Il sito esisteva già con una vecchia installazione WordPress in root, e per fare il nuovo sito ho fatto una seconda installazione di WordPress in una sottocartella chiamata “/wordpress”. Ho impostato l’htaccess in modo che l’indirizzo del sito prendesse la sottocartella come sito principale.
    Ieri sera WordPress si è aggiornato automaticamente e da quel momento tutti i link alle pagine hanno smesso di mandare all’url giusto, rimandando invece a una “page not found” della precedente versione del sito. L’unica pagina funzionante è la homepage, che rimanda alla corretta versione. È quindi come se l’htaccess non prendesse più i contenuti dalla corretta cartella.
    Inoltre la stessa pagina con l’aggiunta di “/wordpress” nell’url non rimanda comunque alla pagina corretta ma alla stessa 404 con layout vecchio.
    Ho provato più volte ad aggiornare i permalink senza ottenere risultati.
    Cosa posso fare per risolvere il problema?
    Grazie per ogni aiuto!

    • Questo argomento è stato modificato 4 mesi, 1 settimana fa da  cloudspotting.

    Pagina di aiuto: [devi essere connesso per vedere il link]

Stai vedendo 1 repliche (di 1 totali)
  • Risolto. Nel caso qualcun altro riscontrasse lo stesso problema:
    Prima dell’aggiornamento automatico di WordPress nel mio file index.php della root la riga “require” indirizzava alla sottocartella corretta:
    require( dirname( _FILE_ ) . '/wordpress/wp-blog-header.php' );
    Dopo l’aggiornamento, per qualche motivo il require è stato resettato, e quindi compariva così:
    require( dirname( _FILE_ ) . '/wp-blog-header.php' );
    Ho aggiunto nuovamente il “/wordpress” e ora funziona tutto correttamente.

Stai vedendo 1 repliche (di 1 totali)
  • Devi essere collegato per rispondere a questo topic.