Supporto » Varie ed eventuali » traferimento server e dominio

  • Risolto spid3r

    (@spid3r)


    Salve,

    ho dovuto trasferire un sito da un hosting all’altro cambiando anche il dominio.
    Ho fatto backup del sito e database. Una volta uplodato sul nuovo hosting funziona tutto tranne l’home page che viene reindirizzata sul vecchio !!!???!!!!

    Ho provato a spulciare a mano il database, ho provato con dei plugin a cercare se fossero presenti ancora dei collegamenti al vecchio ma niente…..

    Ho provato a guardare se ci fossero dei redirect ma nulla …..

    Come faccio a risolvere questo problema?

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai vedendo 8 repliche - dal 1 al 8 (di 8 totali)
  • Ciao @spid3r,
    se hai spostato il database è probabile che tu non abbia aggiornato i valori nelle tabelle sul nuovo dominio, pertanto il sito viene reindirizzato sempre al vecchio. Se invece le hai aggiornate, controlla nel file .htaccess sulla root del server; controlla anche se hai qualche plugin che si occupa di redirect.

    Ciao @spid3r,
    non ho capito se non funziona la tua home quando si carica la pagina o quando clikki sulla voce di menu che ti porta alla home.

    Nel secondo caso controlla che non ci sia un link assoluto nella voce di menu.

    @lucagrandicelli Ciao e grazie, ho spostato il database e penso di aver rinominato tutti i link presenti nelle tabelle, ho fatto la prova anche con dei plugin come Velvet Blues Update URLs o Better Search Replace e non trovano piu niente con il vecchio url. Per quello che riguarda .htaccess ho controllato e non c’è nessun redirect. Ho controllato anche yoast seo per i redirect ma nulla.

    @glorialchemica Allora tutte le pagine si caricano normalmente, mentre la home reindirizza al vecchio sito, sia copiando e incollando l’url nel browser, sia dalla voce menu ….

    Ci puoi fornire la url?

    La butto lì, hai svuotato la cache del tuo browser?

    @glorialchemica

    BINGO …….. Avevo provato tutto tranne svuotare la cache.

    Che figura da pirla. La cosa piu ovvia, dato che al primo cambio di url nelle tabelle alcuni avevano www davanti e alcuni no. Per cui prima che correggessi entrambi aveva memorizzato le tabelle mezze cambiate e mezze no.

    Grazie 1000 per il vs interessamento

    grazie @lucagrandicelli

    Ahahahah no no, il merito ce l’ha @glorialchemica – Noi dev andiamo sempre a pensare alle cause più difficili…. Meglio così!

    Sono molto contenta tu abbia risolto @spid3r. 🙂

    La cache frega sempre tutti, me compresa, non ti preoccupare.

    Segna il topic come risolto, così sarà di aiuto anche ad altre persone.

Stai vedendo 8 repliche - dal 1 al 8 (di 8 totali)
  • Devi essere collegato per rispondere a questo topic.