Supporto » Fixing WordPress » Url errato quando carico un PDF

  • forlanistudio

    (@forlanistudio)


    Quando carico un PDF nella sezione media, quindi non associato ad alcun articolo, la cartella in cui viene caricata è sempre /uploads/2020/11/ anche se li carico oggi 18/03/2021.

    Con altri media non succede. Cosa potrebbe essere?

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 11 risposte - dal 1 al 11 (di 11 totali)
  • Ciao @forlanistudio,

    Grazie per aver aperto un thread su WordPress.org. Sono Matteo, spero tu stia bene.

    Accade con tutti i PDF o solo con questo? A livello di metadati file, risulta qualche data simile?

    Grazie,
    Matteo

    Chi ha creato la discussione forlanistudio

    (@forlanistudio)

    Buongiorno Matteo,
    Succede con ogni PDF da dopo quella data. Ho scoperto che succede con altri tipi di Media, tipo i video.

    L’unica cosa che cambia è l’url, se controllo i metadati a fianco quando ne seleziono uno all’interno della sezione media di wp sono corretti.

    Se possibile ti mando uno screenshot

    Ciao @forlanistudio,

    Ma se vai in Impostazioni -> Generali, la data e l’ora risultano corrette? Sei su Roma come fuso orario?

    Le date negli articoli sono corrette?

    Per inviare screenshot, caricali qui e mandami il link che ti darà il sistema.

    A presto,
    Matteo

    Chi ha creato la discussione forlanistudio

    (@forlanistudio)

    https://ibb.co/QJRYgzc

    Confermo Ora e Data esatta,

    https://ibb.co/J7GMk5Y

    https://ibb.co/dMQsWZ2

    Se carico il PDF dall’articolo che scrivo esempio oggi, carica normale, con url corretto. Questo succede solo se carico dalla sezione media

    Ciao Antonio,

    WordPress è aggiornato?

    Se sì, prima di effettuare altri test ti prego di effettuare un Backup di tutto WordPress. (Tip: Se clicchi su “Backup” potrai vedere una guida sul Codex).

    Tramite FTP (o il sistema di Gestione File che utilizza il tuo hosting, che da quel che vedo è Aruba) vai in wp-content -> uploads e controlla che tutte le cartelle siano impostate correttamente. Dopo averlo fatto, fai una prova “pratica”. Cancella tutti i media da WordPress. Puoi farlo in modo semplice cliccando, nella sezione Media in alto a sinistra, l’ordinamento degli elementi in orizzontale. Ecco uno screenshot per farti capire meglio:
    image

    Clicca dove ho messo il mouse io e poi, come fossero articoli, seleziona la spunta più in alto e poi scegli “Azioni di gruppo” e “Elimina definitivamente”. A questo punto clicca su “Applica” e su “OK”.

    Dopo aver fatto ciò, prova a vedere se nella cartella “uploads” c’è ancora qualcosa. Se ci sono ancora le cartelle, cancellale tutte.

    Prova dunque ora a vedere se riaccade.

    Resto a disposizione.

    Un saluto,
    Matteo

    Chi ha creato la discussione forlanistudio

    (@forlanistudio)

    Purtroppo no ho la possibilità di cancellare tutto. Il sito è di un istituto con delle esigenze di reperibilità molto particolari.

    WordPress è aggiornato?

    PS: Si tratterebbe di un attimo, ci serve per il trobuleshooting. Poi potrai subito ricaricare il resto.

    Chi ha creato la discussione forlanistudio

    (@forlanistudio)

    La versione WP è la 5.5.3

    Avevo aggiornato all’ultima versione sperando di risolvere, ma il problema è continuato. Ho preferito tornare a questa versione per la stabilità con altri plugin meno aggiornati (es plugin per la gestione di amministrazione pubblica).

    Devo provare questa cosa dei media la sera a questo punto. in un momento di minor traffico.

    Il consiglio è sempre, per maggior stabilità e sicurezza, di tenere sempre aggiornata la propria versione WordPress e, piuttosto, cambiare i plugin nel caso vengano poco aggiornati.

    Il consiglio che ti dò è di testare sempre sull’ultimo update, perchè i problemi potrebbero anche essere legati a quello.

    Chi ha creato la discussione forlanistudio

    (@forlanistudio)

    Ho provato ad aggiornare all’ultima versione, il problema non è risolto purtroppo

    Fallo comunque e fammi sapere se risolvi con la cancellazione dei media. Grazie.

Stai visualizzando 11 risposte - dal 1 al 11 (di 11 totali)
  • Devi essere collegato per rispondere a questo topic.