Supporto » Installazione e Aggiornamento » Versione WP visualizzata errata

  • akira78

    (@akira78)


    Buongiorno a tutti, un mio amico mi ha chiesto di dare una rinfrescata al suo sito WordPress in quanto, avendo la versione 4.0.5, non riusciva più a trovare plugin usabili.
    Il suo hosting aveva php 5.3 mi pare, fatto sta che, dopo aver effettuato il backup (sia tramite Updraft che manualmente tramite ftp) e disattivato i plugin, ho tentato di aggiornare WP alla 5.1.8 poichè risultava essere l’ultima release installabile con quella versione di php…. niente da fare, continua a venire richiesta la psw ftp dal pannello di controllo di WP e dopo vari tentativi inutili decido di tentare l’aggiornamento manuale tramite ftp (usando filezilla).
    Scarico la 5.1.8 dal sito ufficiale, faccio tutti gli upload del caso stando attendo a non dimenticare niente o a cancellare qualcosa che non dovrei, controllo sul version.php che sia effettivamente indicata la 5.1.8, torno sul pannello di controllo del sito e… 4.0.5.
    Ho provato a cancellare la cache del browser, ad usarne un altro (il sito non ha un plugin di caching), ho anche aggiornato il php alla 5.6 (essendo il tema piuttosto vecchio, ho paura ad aggiornare subito alla 7, vorrei fare una cosa più graduale) ma niente da fare…
    Avete qualche indicazione da fornirmi?Sono 2 giorni che faccio prove e non riesco a venirne a capo.

    Grazie mille a chi mi risponderà.

    Hosting Aruba con Windows + Linux (gira su Windows attualmente).

    La pagina su cui ho bisogno di aiuto: [devi essere connesso per vedere il link]

Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)
  • Ciao akira78,

    Le versioni più recenti di WordPress richiedono PHP 5.6.20 come requisito minimo.

    Hai verificato se nel pannello di controllo dell’hosting Linux Aruba sono disponibili versioni PHP più recenti per il dominio su cui stai lavorando?

    Nel caso fosse disponibile, potresti provare ad impostare una versione di PHP 7, confermare e ricaricare il sito per verificare che tutto funzioni. Nel caso non ci siano errori, potresti provare versioni più aggiornate (Aruba attualmente supporta fino alla versione 7.4.x sul suo hosting).

    Se invece dovessi vedere degli errori dopo aver provato il sito con una versione PHP 7 o superiore, puoi sempre tornare sul pannello di controllo di Aruba e impostare nuovamente la versione PHP che usavi in precedenza.

    In generale, se aggiornare ad una versione più recente di PHP crea problemi / errori con il tema o i plugin in uso, consiglierei a te ed al tuo amico di cambiare tema ed aggiornare ad una versione PHP più recente.

    La realtà è che le versioni 5.x di PHP presto non saranno più supportate e continuare ad utilizzarle può esporre il sito, oltre a problemi di compatibilità con temi e plugin, anche a problemi di sicurezza.

    La cosa migliore è aprire un ticket di assistenza con il supporto di Aruba, che solitamente è piuttosto disponibile per risolvere questo genere di problemi.

    Spero la risposta possa esserti utile.

    Buona giornata

    Chi ha creato la discussione akira78

    (@akira78)

    Buongiorno e grazie per la risposta.
    So anche io che l’ideale è avere la versione php più aggiornata possibile, ma desideravo provare uno step intermedio per vedere se il tema reggeva… nel pannello di aggiornamento di WordPress mi veniva indicata la 5.1.8 come release massima installabile e dalla 4.0 era già un bel salto… poi magari avrei rifatto un secondo aggiornamento per portare tutto alla 5.6 e php 7.
    Però continuo a non capire perché, dopo aver aggiornato manualmente wordpress alla 5.1.8, continuo a vedere la versione vecchia (4.0.5) sul pannello di controllo…

    Capisco. Di solito in casi simili faccio una prova per gradi impostando man mano versioni più aggiornate di PHP dal pannello di controllo dell’hosting. Verifico prima eventuali errori e, nel caso dovessi vedere che sta funzionando tutto, passo ad installare gli aggiornamenti disponibili.

    Anche nel caso in cui il tema o un plugin dovessero dare qualche errore dopo un aggiornamento, è rarissimo che questi non vengano risolti con una versione più aggiornata del tema o del plugin stesso.

    Se il tema o eventuali plugin che state usando non sono compatibili con versioni più aggiornate di PHP, vi consiglierei di considerare delle alternative che continuano ad essere sviluppate e seguono gli aggiornamenti anche tecnici di WordPress.

    In bocca al lupo con il resto della manutenzione!

    Buona giornata

    Chi ha creato la discussione akira78

    (@akira78)

    È proprio quello che vorrei fare, un aggiornamento per gradi… ma continuo a non avere risposta riguardo una possibile risoluzione del mio problema.
    Se ho aggiornato alla 5.1.8 ed il pannello di controllo di WordPress mi indica ancora la 4.0.5, sono bloccato perché non ho modo di sapere con certezza che versione è realmente attiva e se posso proseguire con gli aggiornamenti!

    Ti consiglierei di contattare l’assistenza di Aruba.

    Nel dubbio, l’aggiornamento manuale molto probabilmente non è andato a buon fine. Provare ad aggiornare WordPress senza aggiornare anche PHP è una soluzione che può durare ancora per qualche tempo, ma mette il sito a rischio di instabilità.

    Chi ha creato la discussione akira78

    (@akira78)

    Buongiorno, non so quanto Aruba possa/voglia poi aiutarmi riguardo un problema che alla fine non li riguarda… a questo punto non mi resta che provare a passare direttamente a php7, aggiornare wordpress e tema all’ultima versione e sperare che vada tutto bene…
    Speravo ci fosse una soluzione intermedia meno drastica a dire la verità 🙁

    Se qualcuno a altre indicazioni alternative da darmi, ovviamente sono ben accette! 🙂

Stai visualizzando 6 risposte - dal 1 al 6 (di 6 totali)
  • Il topic ‘Versione WP visualizzata errata’ è chiuso a nuove risposte.